Closed Bug 1537722 Opened 7 months ago Closed 4 months ago

Intermittent js/src/jit-test/tests/basic/bug642772-3.js | Timeout (code -6, args "") [150.0 s]

Categories

(Core :: JavaScript Engine, defect, P5)

defect

Tracking

()

RESOLVED FIXED
mozilla69
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- wontfix
firefox68 --- wontfix
firefox69 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jandem)

Details

(Keywords: intermittent-failure, regression, Whiteboard: [stockwell needswork:owner])

Attachments

(1 file)

#[markdown(off)]
Filed by: ncsoregi [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=235151290&repo=autoland

https://queue.taskcluster.net/v1/task/dXeSzC6ISoWJW8Q8Rkfh_g/runs/0/artifacts/public/logs/live_backing.log

[task 2019-03-21T09:01:31.931Z] TEST-PASS | js/src/jit-test/tests/jaeger/inline/scripted-05.js | Success (code 0, args "") [0.3 s]
[task 2019-03-21T09:01:31.940Z] TEST-PASS | js/src/jit-test/tests/jaeger/inline/scripted-04.js | Success (code 0, args "") [0.3 s]
[task 2019-03-21T09:01:31.977Z] TEST-PASS | js/src/jit-test/tests/jaeger/inline/scripted-02.js | Success (code 0, args "") [0.4 s]
[task 2019-03-21T09:01:32.003Z] TEST-PASS | js/src/jit-test/tests/jaeger/inline/scripted-06.js | Success (code 0, args "") [0.3 s]
[task 2019-03-21T09:01:32.017Z] TEST-PASS | js/src/jit-test/tests/jaeger/inline/scripted-01.js | Success (code 0, args "") [0.5 s]
[task 2019-03-21T09:01:32.019Z] TEST-PASS | js/src/jit-test/tests/jaeger/inline/scripted-08.js | Success (code 0, args "") [0.3 s]
[task 2019-03-21T09:01:32.031Z] TEST-PASS | js/src/jit-test/tests/jaeger/inline/scripted-07.js | Success (code 0, args "") [0.3 s]
[task 2019-03-21T09:01:32.114Z] TEST-PASS | js/src/jit-test/tests/jaeger/inline/scripted-09.js | Success (code 0, args "") [0.3 s]
[task 2019-03-21T09:01:32.169Z] TEST-PASS | js/src/jit-test/tests/jaeger/inline/scripted-10.js | Success (code 0, args "") [0.3 s]
[task 2019-03-21T09:01:32.198Z] Exit code: -6
[task 2019-03-21T09:01:32.199Z] TIMEOUT - basic/bug642772-3.js
[task 2019-03-21T09:01:32.200Z] TEST-UNEXPECTED-FAIL | js/src/jit-test/tests/basic/bug642772-3.js | Timeout (code -6, args "") [150.0 s]
[task 2019-03-21T09:01:32.201Z] INFO exit-status : -6
[task 2019-03-21T09:01:32.201Z] INFO timed-out : 0:00:00.008815

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → INCOMPLETE

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=248058142&repo=autoland&lineNumber=7836

[task 2019-05-23T21:17:48.502Z] TEST-PASS | js/src/jit-test/tests/profiler/bug1261324.js | Success (code 0, args "") [0.3 s]
[task 2019-05-23T21:17:48.521Z] TEST-PASS | js/src/jit-test/tests/profiler/bug1242840.js | Success (code 0, args "") [0.3 s]
[task 2019-05-23T21:17:48.642Z] Exit code: -6
[task 2019-05-23T21:17:48.643Z] TIMEOUT - basic/bug642772-3.js
[task 2019-05-23T21:17:48.643Z] TEST-UNEXPECTED-FAIL | js/src/jit-test/tests/basic/bug642772-3.js | Timeout (code -6, args "") [150.0 s]
[task 2019-05-23T21:17:48.643Z] INFO exit-status : -6
[task 2019-05-23T21:17:48.643Z] INFO timed-out : 0:00:00.007373
[task 2019-05-23T21:17:48.664Z] TEST-PASS | js/src/jit-test/tests/profiler/bug1352507-1.js | Success (code 0, args "") [0.3 s]
[task 2019-05-23T21:17:48.741Z] TEST-PASS | js/src/jit-test/tests/parser/modifier-arrow-rest.js | Success (code 0, args "") [6.9 s]
[task 2019-05-23T21:17:48.744Z] TEST-PASS | js/src/jit-test/tests/profiler/bug1427774.js | Success (code 0, args "") [0.2 s]

From IRC:

RyanVM> a bit of a big drop, but it was at least a pretty slow test already
1:15 AM 132.2s on the green run on tip
<RyanVM> apavel|sheriffduty: I suspect that the answer here is adding it to https://searchfox.org/mozilla-central/source/js/src/devtools/automation/arm64-jstests-slow.txt
1:17 AM yeah, i'm seeing runs from earlier today when we were already in the high 130's for runtime
RyanVM> NI sstangl though because I suspect we'll want to just skip the test on those builds

Status: RESOLVED → REOPENED
Flags: needinfo?(sstangl)
Resolution: INCOMPLETE → ---

There have been 33 occurrences in the last 7 days on linux64 debug: https://treeherder.mozilla.org/intermittent-failures.html#/bugdetails?startday=2019-05-29&endday=2019-06-05&tree=trunk&bug=1537722

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=250069152&repo=autoland&lineNumber=7968

[task 2019-06-05T01:21:51.867Z] TEST-PASS | js/src/jit-test/tests/parser/modifier-semicolon-insertion.js | Success (code 0, args "") [0.2 s]
[task 2019-06-05T01:21:51.945Z] Exit code: -6
[task 2019-06-05T01:21:51.945Z] TIMEOUT - basic/bug642772-3.js
[task 2019-06-05T01:21:51.945Z] TEST-UNEXPECTED-FAIL | js/src/jit-test/tests/basic/bug642772-3.js | Timeout (code -6, args "") [150.0 s]
[task 2019-06-05T01:21:51.946Z] INFO exit-status : -6
[task 2019-06-05T01:21:51.946Z] INFO timed-out : 0:00:00.017517
[task 2019-06-05T01:21:52.307Z] TEST-PASS | js/src/jit-test/tests/parser/redeclaration-message.js | Success (code 0, args "") [0.4 s]

Ryan, sstangl doesn't seem to respond to the ni, can you redirect this to someone else who can look into it?

Flags: needinfo?(ryanvm)
Flags: needinfo?(ryanvm) → needinfo?(sdetar)

Sean, could you make it a priority to take a look at this. I see other folks tried to NI you already. If you are the wrong person to look at this, please let me know who I should have look at it.

Flags: needinfo?(sdetar)

There have been 43 failures within the last 7 days, all of them on Linux x64 debug Spidermonkey.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=251819421&repo=autoland&lineNumber=7926

[task 2019-06-14T02:52:36.692Z] TEST-PASS | js/src/jit-test/tests/pic/callname-with.js | Success (code 0, args "") [0.3 s]
[task 2019-06-14T02:52:36.780Z] TEST-PASS | js/src/jit-test/tests/pic/densearray.js | Success (code 0, args "") [0.3 s]
[task 2019-06-14T02:52:36.848Z] Exit code: -6
[task 2019-06-14T02:52:36.848Z] TIMEOUT - basic/bug642772-3.js
[task 2019-06-14T02:52:36.848Z] TEST-UNEXPECTED-FAIL | js/src/jit-test/tests/basic/bug642772-3.js | Timeout (code -6, args "") [150.0 s]
[task 2019-06-14T02:52:36.849Z] INFO exit-status : -6
[task 2019-06-14T02:52:36.849Z] INFO timed-out : 0:00:00.007160

There have been 46 occurrences in the last 7 days, all on Linux 64 Debug.

Recent failure: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=252868093&repo=mozilla-central&lineNumber=9613

[task 2019-06-21T22:01:11.826Z] TEST-PASS | js/src/jit-test/tests/pic/bug584642.js | Success (code 3, args "") [0.3 s]
[task 2019-06-21T22:01:11.994Z] TEST-PASS | js/src/jit-test/tests/pic/bug595706.js | Success (code 0, args "") [0.3 s]
[task 2019-06-21T22:01:12.118Z] TEST-PASS | js/src/jit-test/tests/pic/bug645184.js | Success (code 0, args "") [0.3 s]
[task 2019-06-21T22:01:12.262Z] TEST-PASS | js/src/jit-test/tests/pic/call_self.js | Success (code 0, args "") [0.3 s]
[task 2019-06-21T22:01:12.398Z] TEST-PASS | js/src/jit-test/tests/pic/callname-eager-this1.js | Success (code 0, args "") [0.3 s]
[task 2019-06-21T22:01:12.562Z] TEST-PASS | js/src/jit-test/tests/pic/callname-eager-this2.js | Success (code 0, args "") [0.3 s]
[task 2019-06-21T22:01:12.738Z] TEST-PASS | js/src/jit-test/tests/pic/callname-global1.js | Success (code 0, args "") [0.3 s]
[task 2019-06-21T22:01:12.846Z] TEST-PASS | js/src/jit-test/tests/pic/callname-global2.js | Success (code 0, args "") [0.3 s]
[task 2019-06-21T22:01:13.006Z] TEST-PASS | js/src/jit-test/tests/pic/callname-with.js | Success (code 0, args "") [0.3 s]
[task 2019-06-21T22:01:13.090Z] TEST-PASS | js/src/jit-test/tests/pic/densearray.js | Success (code 0, args "") [0.2 s]
[task 2019-06-21T22:01:13.270Z] TEST-PASS | js/src/jit-test/tests/pic/getelem-large-index.js | Success (code 0, args "") [0.3 s]
[task 2019-06-21T22:01:13.276Z] Exit code: -6
[task 2019-06-21T22:01:13.276Z] TIMEOUT - basic/bug642772-3.js
[task 2019-06-21T22:01:13.277Z] TEST-UNEXPECTED-FAIL | js/src/jit-test/tests/basic/bug642772-3.js | Timeout (code -6, args "") [150.0 s]
[task 2019-06-21T22:01:13.277Z] INFO exit-status : -6
[task 2019-06-21T22:01:13.277Z] INFO timed-out : 0:00:00.007286
[task 2019-06-21T22:01:13.358Z] TEST-PASS | js/src/jit-test/tests/pic/grandproto.js | Success (code 0, args "") [0.3 s]

From https://wiki.mozilla.org/Modules/All Benjamin can you take a look? We've reached out to Sean but there is no reply.

Flags: needinfo?(sstangl) → needinfo?(bbouvier)

The test does very little, but is linear in the number of global object's properties. Since we tend to only add new properties onto the global object, the situation is to become worse over time. It could be a performance cliff or an iloop in our code. I'm not so specialized on the JIT these days, so deferring to jit people.

Flags: needinfo?(tcampbell)
Flags: needinfo?(nicolas.b.pierron)
Flags: needinfo?(jdemooij)
Flags: needinfo?(bbouvier)
Assignee: nobody → jdemooij
Status: REOPENED → ASSIGNED
Flags: needinfo?(tcampbell)
Flags: needinfo?(nicolas.b.pierron)

There are 60 total failures in the last 7 days on linux64 debug.

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=254522195&repo=autoland&lineNumber=9446

[task 2019-07-03T01:01:55.181Z] TEST-PASS | js/src/jit-test/tests/parser/redeclaration-message.js | Success (code 0, args "") [0.3 s]
[task 2019-07-03T01:01:55.387Z] TEST-PASS | js/src/jit-test/tests/parser/bug-1465695.js | Success (code 0, args "") [2.4 s]
[task 2019-07-03T01:01:55.466Z] TEST-PASS | js/src/jit-test/tests/parser/oom-tracking-line-starts-in-tokenizer.js | Success (code 0, args "") [0.6 s]
[task 2019-07-03T01:01:55.677Z] TEST-PASS | js/src/jit-test/tests/parser/regexp-after-do-while.js | Success (code 0, args "") [0.3 s]
[task 2019-07-03T01:01:55.764Z] TEST-PASS | js/src/jit-test/tests/parser/regexp-after-variable.js | Success (code 0, args "") [0.3 s]
[task 2019-07-03T01:01:55.767Z] TEST-PASS | js/src/jit-test/tests/parser/redeclaration.js | Success (code 0, args "") [0.6 s]
[task 2019-07-03T01:01:55.933Z] TEST-PASS | js/src/jit-test/tests/parser/standalone-function-name.js | Success (code 0, args "") [0.3 s]
[task 2019-07-03T01:01:56.093Z] TEST-PASS | js/src/jit-test/tests/parser/truncation.js | Success (code 0, args "") [0.3 s]
[task 2019-07-03T01:01:56.201Z] TEST-PASS | js/src/jit-test/tests/parser/yield-in-formal-destructuring.js | Success (code 0, args "") [0.3 s]
[task 2019-07-03T01:01:56.369Z] TEST-PASS | js/src/jit-test/tests/pic/arguments.js | Success (code 0, args "") [0.3 s]
[task 2019-07-03T01:01:56.481Z] TEST-PASS | js/src/jit-test/tests/pic/bug584642.js | Success (code 3, args "") [0.3 s]
[task 2019-07-03T01:01:56.641Z] TEST-PASS | js/src/jit-test/tests/pic/bug595706.js | Success (code 0, args "") [0.3 s]
[task 2019-07-03T01:01:56.777Z] TEST-PASS | js/src/jit-test/tests/pic/bug645184.js | Success (code 0, args "") [0.3 s]
[task 2019-07-03T01:01:56.917Z] TEST-PASS | js/src/jit-test/tests/pic/call_self.js | Success (code 0, args "") [0.3 s]
[task 2019-07-03T01:01:57.023Z] Exit code: -6
[task 2019-07-03T01:01:57.023Z] TIMEOUT - basic/bug642772-3.js
[task 2019-07-03T01:01:57.023Z] TEST-UNEXPECTED-FAIL | js/src/jit-test/tests/basic/bug642772-3.js | Timeout (code -6, args "") [150.0 s]
[task 2019-07-03T01:01:57.024Z] INFO exit-status : -6
[task 2019-07-03T01:01:57.024Z] INFO timed-out : 0:00:00.008816
[task 2019-07-03T01:01:57.065Z] TEST-PASS | js/src/jit-test/tests/pic/callname-eager-this1.js | Success (code 0, args "") [0.3 s]
[task 2019-07-03T01:01:57.213Z] TEST-PASS | js/src/jit-test/tests/pic/callname-eager-this2.js | Success (code 0, args "") [0.3 s]
[task 2019-07-03T01:01:57.364Z] TEST-PASS | js/src/jit-test/tests/pic/callname-global2.js | Success (code 0, args "") [0.3 s]
[task 2019-07-03T01:01:57.366Z] TEST-PASS | js/src/jit-test/tests/pic/callname-global1.js | Success (code 0, args "") [0.3 s]
[task 2019-07-03T01:01:57.493Z] TEST-PASS | js/src/jit-test/tests/pic/callname-with.js | Success (code 0, args "") [0.3 s]
[task 2019-07-03T01:01:57.621Z] TEST-PASS | js/src/jit-test/tests/pic/getelem-large-index.js | Success (code 0, args "") [0.3 s]

Jan are there updates here?

Whiteboard: [stockwell needswork:owner]

This test has questionable value but this just makes it
faster by reducing iteration count.

Flags: needinfo?(jdemooij)
Pushed by jdemooij@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/34b24a5f927a
Make bug642772-3.js jit-test faster to avoid time-outs. r=jonco
Status: ASSIGNED → RESOLVED
Closed: 6 months ago4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69
You need to log in before you can comment on or make changes to this bug.