Closed Bug 1537735 Opened 2 years ago Closed 1 year ago

[macOS] After vertical resize content from themes reappears only with mouse hover

Categories

(Toolkit :: Add-ons Manager, defect, P3)

Desktop
macOS
defect

Tracking

()

VERIFIED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- wontfix
firefox67 --- wontfix
firefox68 --- verified

People

(Reporter: atrif, Assigned: mattwoodrow)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Affected versions

  • Firefox 67.0b3 (20190318154932)
  • Firefox 68.0a1 (20190319215514)

Affected platforms

  • macOS 10.14

[Prerequisites]:

  • Have a random theme installed.

Steps to reproduce

  1. Open Firefox.
  2. Open the Add-ons Manager from menu [≡] → Add-ons.
  3. Click on the "Themes" category from the left, vertical menu (if it's not already in focus).
  4. Grab the browser by the top/bottom edge and resize it vertically (to cover up the 1st theme).
  5. Grab the browser by the top/bottom edge and restore it to the previous size.

Expected result

  • The content is shown with no issues.

Actual result

  • Themes content reappear only when hovering.

Regression range

  • I will search for a regression range ASAP.

Additional Notes

  • Attached screen recording with the issue: link
  • The issue reproduces by resizing the browser and covering the first theme.
  • Has a higher chance to reproduce when the browser width is bigger than half of the screen.
Has Regression Range: --- → no
Has STR: --- → yes
Component: Theme → Add-ons Manager
Product: Firefox → Toolkit

Hello,

After further investigation, I found that categories from “about:addons” page and content from “Plugins” section it’s deleted as well after resizing the browser.
For "Themes" category content this bug reproduces much easier if you have an installed theme, but it can be reproduced without having one.

Mozregression provided this pushlog:
Last good revision: a39aab288a0074cbba09f48b41035dc63c1126a9
First bad revision: 8b2453d488ae5cf3f2fce628da66cb72697b8b8d
Pushlog: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=a39aab288a0074cbba09f48b41035dc63c1126a9&tochange=8b2453d488ae5cf3f2fce628da66cb72697b8b8d

I hope this information is useful. Thank you!

Has Regression Range: no → yes

Paolo, it seems that your patch in bug 1472557 caused this regression, could you have a look please? Thanks

Blocks: 1472557
Flags: needinfo?(paolo.mozmail)
Priority: -- → P3
Flags: needinfo?(paolo.mozmail) → needinfo?(bgrinstead)

FWIW, this seems fixed by webrender (tested with ./mach run --setpref gfx.webrender.enabled=true)

(In reply to Brian Grinstead [:bgrins] from comment #3)

FWIW, this seems fixed by webrender (tested with ./mach run --setpref gfx.webrender.enabled=true)

Matt, could you help figure out what's going on with this or point me to an appropriate person? Since this is fixed by flipping the webrender pref I take it this is a graphics issue. It's easily reproducible for me following STR in Comment 0 (video of the issue can be seen at https://drive.google.com/open?id=1HWX2SndrDUs1rKEhvRLgvRYv6C9uI8qv).

A couple relevant notes:

  • it's happening in a XUL document (about:addons).
  • this was triggered by making some frontend changes to the scroll container in Bug 1472557.
Flags: needinfo?(bgrinstead) → needinfo?(matt.woodrow)
No longer blocks: 1472557
Regressed by: 1472557
Assignee: nobody → matt.woodrow
Flags: needinfo?(matt.woodrow)
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/bb38c692e519
Always update mask layers for ClientTiledPaintedLayer, even if nothing within the Layer itself has changed. r=mstange
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Hello,
The fix is verified with Firefox 68.0a1 (20190505213908) on macOS 10.14.3.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.