Flash plug-in not working properly

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
P3
normal
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Marco Brandizi, Assigned: serge (gone))

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL2:NA])

(Reporter)

Description

16 years ago
I've downloaded and installed Macromedia Flash 5 plugin for linux. It works, but
after an exaggerated delay (1-2 minutes). Until such a time is lasted, all
Mozilla is completely blocked (even mail windows) and you neither cannot resize
the windows. This happens almost for all pages embedding swf files of whatever
dimensions.

Comment 1

16 years ago
test url pls , thx!
(Reporter)

Comment 2

16 years ago
About the URL: as already sayd, whatever page containing an SWF file issues the
problem. For instance, the macromedia home itself (www.macromedia.com).
Also, if you try the file inside http://www.mycgiserver.com/~zakmck/drive.zip
you may either do another test and have fun... ;-)

Comment 3

16 years ago
this kind of sounds like the cpu usage issue -- could it be that it just
manifests itself more clearly on linux?

Comment 4

16 years ago
The plug-ins triage team (av, beppe, peterl, serge and shrir) have reviewed this
issue and have made the following determination:

Reporter: can you reproduce this same issue if the .swf file is on your local drive?
Assignee: beppe → serge
Whiteboard: [PL2:P2]
(Reporter)

Comment 5

16 years ago
> Reporter: can you reproduce this same issue if the .swf file is on your local 
> drive?
>

Positive. When an SWF is loaded locally, or even by my LAN proxy, it's only a 
little faster, but yet the browser remains a lot of time stalled as described. 
I don't know, it looks like it needs long time to load Flash engine, like once, 
NN 4.x required a lot of time to load JVM in some platforms.

Updated

16 years ago
Priority: -- → P3
Whiteboard: [PL2:P2] → [PL2:NA]
Target Milestone: --- → mozilla1.0.2

Comment 6

16 years ago
future
Target Milestone: mozilla1.0.2 → Future

Comment 7

16 years ago
Marco, can you reproduce this problem with a current version of mozilla?

There's a known problem with flash on linux; the plugin tries to open the sound
device and hangs if another process is already using sound. Both KDE and Gnome
include sound servers which trigger this behavior in mozilla, even when the user
isn't using any obviously sound-related applications.

If you use KDE, please try running mozilla through the "artsdsp" program, e.g.
"artsdsp /path/to/mozilla". With gnome, I believe the equivalent program is
esddsp. These programs intercept attempts to access the sound device and direct
them to the sound server instead.

You could also try upgrading your flash plugin. A beta release of flash version
6 is available; it's supposed to fixes some issues, though I haven't tried it
myself.

Please update this bug report to indicate whether you're still experiencing this
problem.
(Reporter)

Comment 8

16 years ago
I'm using the 1.1 version, with latest KDE (artsd wrapped), latest flash. Flash
is yet a bit slow, but substantially the bug seems fixed.

Thanks Guys.

Comment 9

16 years ago
marking WFM based on reporter's comments
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.