Closed Bug 1537890 Opened 10 months ago Closed 3 months ago

Perfherder shouldn't center numbers in their cells and should use thousands separators for formatting them

Categories

(Tree Management :: Perfherder, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Gijs, Assigned: Draci)

Details

(Keywords: good-first-bug, outreachy)

Attachments

(3 files)

Priority: -- → P2
Assignee: nobody → sclements
Status: NEW → ASSIGNED

Sarah, I think this bug was already fixed. Or am I wrong?

Flags: needinfo?(sclements)

No this still needs to get done. It's an easy fix I'll get pushed out soon.

Flags: needinfo?(sclements)

Actually this will make a good first bug for prospective Outreachy applicants so I'll un-assign it.

Assignee: sclements → nobody
Status: ASSIGNED → NEW
Priority: P2 → P3

Hi, I am an Outreachy applicant and I would like to contribute by fixing this bug.
Thank you!

Flags: needinfo?(sclements)

Hi Viktor, I'll assign it you.

Assignee: nobody → viktor.stojanov90
Status: NEW → ASSIGNED
Flags: needinfo?(sclements)
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED

I don't think this ticket is done yet. According to the summary, we were required to provide the thousands separator to all our numbers from Compare view, but we're still lacking this.

Flags: needinfo?(sclements)

(In reply to Ionuț Goldan [:igoldan], Performance Sheriff from comment #7)

I don't think this ticket is done yet. According to the summary, we were required to provide the thousands separator to all our numbers from Compare view, but we're still lacking this.

TBF, I should probably have filed a separate bug for the thousands separator / number formatting... we could clone this bug and provide an opportunity for Draci or another outreachy applicant to fix that separately.

I would gladly finish whatever I missed on the first run. After closer inspection of the link provided the only place I can see that is missing the thousands separators is on hover. Is that what you're referring to @Ionuț ? If @Sarah is OK with it I would like to do what @Gijs mentioned above.

Flags: needinfo?(igoldan)

It looks like we missed the numbers in the tooltip. I'll reopen this bug and :Draci can do a follow up pr (Draci just use this same bug number and include a description of the commit that this is for formatting numbers in tooltip).

Flags: needinfo?(sclements)
Status: RESOLVED → REOPENED
Flags: needinfo?(igoldan)
Resolution: FIXED → ---

Viktor, were you still planning to complete a follow up pull request for this bug?

Flags: needinfo?(viktor.stojanov90)

Hi :sclements,

I do plan on finishing this. I will finish this and the second part this week.

Thank you for your patience!

Flags: needinfo?(viktor.stojanov90)
Status: REOPENED → RESOLVED
Closed: 4 months ago3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.