Closed Bug 1538092 Opened 8 months ago Closed 3 months ago

Section headers are rendering very slow

Categories

(DevTools :: Inspector: Layout, defect, P3)

65 Branch
defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1576604

People

(Reporter: mbalfanz, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached video slow-rendering.mp4

STR:

  • open devtools
  • in the top right panel, switch away from and back to layout panel

ER:

  • section headers should be visible from the start

AR:

  • section headers seem to render with a big delay, appearing as last content. This seems "the wrong way around"

See video attached

Severity: normal → enhancement
Priority: -- → P3

Fixed in the patch for bug 1576604.

The issue was a transition: all 0.25s on the headers inheriting visibility: hidden|visible from an ancestor and trying to animate that, resulting in 250ms of visibility: hidden when switching back to the Layout tab.

Closing as duplicate since I'm landing a patch there.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1576604
You need to log in before you can comment on or make changes to this bug.