Closed Bug 1538111 Opened 2 years ago Closed 1 month ago

Firefox does not display text highlighted with evince in PDFs

Categories

(Firefox :: PDF Viewer, defect, P3)

68 Branch
defect

Tracking

()

RESOLVED FIXED
82 Branch

People

(Reporter: linuxhippy, Unassigned)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

opened a PDF document which was annotated (notes + highlighted text) using evince

Actual results:

notes are displayed, highlighted text isn't

Expected results:

firefox should behave like poppler, acrobat reader or google pdf preview and display the hightlighted text.

In times where emscripten and wasm perform so well, wouldn't it be better to replace pdf.js with poppler compiler to wasm? PDF seems to cause tons of troubles and maintenance costs - wouldn't it be better to have the pdf.js team join firefox again, instead of burning ressources for even mroe years?

Component: Untriaged → PDF Viewer

(In reply to Clemens Eisserer from comment #1)

In times where emscripten and wasm perform so well, wouldn't it be better to replace pdf.js with poppler compiler to wasm? PDF seems to cause tons of troubles and maintenance costs - wouldn't it be better to have the pdf.js team join firefox again, instead of burning ressources for even mroe years?

Let's leave this bug for discussion about the annotation bug, but this has been considered and it is much more work than it appears to switch.

Tim,
Maybe you have some thoughts on why the annotation isn't working?

Flags: needinfo?(timvandermeij)
Priority: -- → P3

The problem is that the highlight annotations don't have appearance streams, which is a deprecated practice for PDF file generators. We have two open issues on GitHub for solving this: https://github.com/mozilla/pdf.js/issues/6810 should make sure that we draw the yellow highlight correctly and https://github.com/mozilla/pdf.js/issues/6811 should make sure that the highlight is able to go over multiple rows.

Flags: needinfo?(timvandermeij)

Can confirm for Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:79.0) Gecko/20100101 Firefox/79.0.

Status: UNCONFIRMED → RESOLVED
Closed: 1 month ago
Depends on: 1663343
Resolution: --- → FIXED
Target Milestone: --- → 82 Branch
Duplicate of this bug: 1528687
You need to log in before you can comment on or make changes to this bug.