Closed Bug 1538183 Opened 3 years ago Closed 3 years ago

WebSocket entry will be missing if the filter is set on 'WS' only when I make the request

Categories

(DevTools :: Netmonitor, defect)

66 Branch
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1457379

People

(Reporter: raymondchen625, Unassigned)

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

With the web developer tools open and network tab selected, I set the filter to 'WS' only, and checked 'Persist logs'. And I made a request which would initiate a websocket connection.

Actual results:

I didn't see the websocket entry, which was supposed to be status=101 and type=websocket. Even I unset the filter, putting it back to 'All', the websocket entry was still missing.

Expected results:

I should see the websocket entry. If also check 'other' filter, or I don't set any filter at all, it works well. The websocket entry is there.

Component: Untriaged → Networking: WebSockets
Product: Firefox → Core
Component: Networking: WebSockets → Netmonitor
Product: Core → DevTools

I just tested Firefox Nightly 68 and it seems to be working for me

I tried this page:
http://janodvarko.cz/test/websockets/

Can you please try your test page with 68?
https://www.mozilla.org/en-US/firefox/nightly/all/

Honza

Flags: needinfo?(raymondchen625)

(In reply to Jan Honza Odvarko [:Honza] (always need-info? me) from comment #1)

I just tested Firefox Nightly 68 and it seems to be working for me

I tried this page:
http://janodvarko.cz/test/websockets/

Can you please try your test page with 68?
https://www.mozilla.org/en-US/firefox/nightly/all/

Honza

It's still reproducible on Firefox 66. But when I tried with 68 nightly build, it's no longer reproducible. It looks fixed.

Flags: needinfo?(raymondchen625)

Thanks for the update!

This has been fixed in bug 1457379, so I am marking this one as dup.

Honza

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1457379
You need to log in before you can comment on or make changes to this bug.