Unable to keep distribution directory when installing MSI

VERIFIED FIXED in Firefox 67

Status

()

defect
P1
normal
VERIFIED FIXED
3 months ago
Last month

People

(Reporter: michael.brosi, Assigned: mkaply)

Tracking

66 Branch
Firefox 68
Points:
---

Firefox Tracking Flags

(firefox66 wontfix, firefox67 verified, firefox68 verified)

Details

Attachments

(1 attachment)

Reporter

Description

3 months ago

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

Changed property "REMOVE_DISTRIBUTION_DIR" to value "false" in MSI File to prevent the installer to remove the "distribution" directory with policies.json

Actual results:

The "distribution" directory is always deleted no matter if you set the property to "false" or "true"

Expected results:

If the property "REMOTE_DISTRIBUTION_DIR" is set to "false" the directory "distribution" incl. policies.json

REASON:
There's a typo in the variable of the "Custom Actions" of the MSI.
It should be "REMOVE_DISTRIBUTION_DIR" but it is "REMOTE_DISTRIBUTION_DIR".
Note "REMOTE" vs. "REMOVE".

SOLUTION: Please correct the variable in the "Custom Actions" of the MSI.

Reporter

Updated

3 months ago
Summary: Unable to keep distribution directory → Unable to keep distribution directory when installing MSI

Updated

3 months ago
Component: Untriaged → Enterprise Policies
Assignee

Comment 1

3 months ago

Not sure how we missed this in testing.

Assignee: nobody → mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Assignee

Updated

3 months ago
Priority: -- → P1

Comment 3

3 months ago
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/090b1c918561
Correct REMOVE_DISTRIBUTION_DIR command. r=mhowell

Comment 4

3 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Is this important to fix in 66/67? And how can the fix be verified?

Flags: qe-verify+
Flags: needinfo?(mozilla)
Assignee

Comment 6

3 months ago

This is a pretty easy uplift, so it would be nice to have for correctness. Information on how to test is here:

https://support.mozilla.org/en-US/kb/deploy-firefox-msi-installers

Flags: needinfo?(mozilla)
Assignee

Comment 7

3 months ago

Comment on attachment 9054993 [details]
Bug 1538218 - Correct REMOVE_DISTRIBUTION_DIR command.

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: MSI
  • User impact if declined: Admins have to use the wrong command to keep from removing the distribution directory.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See https://support.mozilla.org/en-US/kb/deploy-firefox-msi-installers
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Just changes the name of an installer variable. MSI only.
  • String changes made/needed:
Attachment #9054993 - Flags: approval-mozilla-beta?
Assignee

Updated

3 months ago
Flags: qe-verify+ → qe-verify?
Assignee

Comment 8

3 months ago

mberlinger did the original MSI QE work, so that expertise would probably help get this tested quickly.

Flags: needinfo?(maria.berlinger)

It sounds like we could note this as a known issue for 66 (maybe with a SUMO article on the workaround) and aim to fix it in 67.

I would like it to be verified in Nightly by QA before uplifting to Beta.

Flags: qe-verify? → qe-verify+
QA Whiteboard: [qa-triaged]

I've tested on Windows 7 x64, Windows 10 x86 and Windows 8.1 x64 using latest Nightly 68.0a1 (2019-04-04):

  • the variable in the "CustomAction" of the MSI is now [REMOVE_DISTRIBUTION_DIR]
  • if the property "REMOVE_DISTRIBUTION_DIR" is set to "false", the directory "distribution" is not deleted
Flags: needinfo?(maria.berlinger)

Comment on attachment 9054993 [details]
Bug 1538218 - Correct REMOVE_DISTRIBUTION_DIR command.

Low risk patch for our MSI, verified by QA, uplift approved for 67 beta 9, thanks!

Attachment #9054993 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified fixed on Windows 7 x64, Windows 8.1 x64 and Windows x86 using Firefox 67 Beta 9 (20190408123043).

Status: RESOLVED → VERIFIED
Flags: qe-verify+
Duplicate of this bug: 1552167
You need to log in before you can comment on or make changes to this bug.