Manage Bookmarks appears in the Create In menu (Add Page to Bookmarks)

VERIFIED DUPLICATE of bug 153276

Status

Camino Graveyard
Bookmarks
--
critical
VERIFIED DUPLICATE of bug 153276
16 years ago
16 years ago

People

(Reporter: Chris Petersen, Assigned: Mike Pinkerton (not reading bugmail))

Tracking

({crash})

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
Build: 2002-06-23-05 NB
Platform: OS X 10.1.5
Expected results: Menu items should be displayed correctly in Bookmarks menu.
What I got: Bookmark folder item appears at the top of Bookmark menu instead of
  Add Page to Bookmark.

Steps to reproduce:

1) Launch application
2) Open Sidebar
3) Drag the bottom folder (My Panels) to the top (in front of Toolbar Bookmarks).
4) Select Bookmarks menu. Notice My Panels is the first menu item. This is
incorrect since the bookmark folder item must only be displayed at the bottom of
this menu.
(Reporter)

Comment 1

16 years ago
This bug causes "Manage Bookmarks" menu item to appear as folder when saving
page bookmark in sidebar.

1) Drag a different folder (in sidebar) to the very top twice
2) Select Add Page to Bookmarks from Bookmarks menu
3) Sheet appears to save bookmark. Click on Create In: and select Manage
Bookmarks. Click Ok.
4) Crash occurs.
Keywords: crash
(Reporter)

Comment 2

16 years ago
Created attachment 88906 [details]
stack trace

Comment 3

16 years ago
Is it not a duplicate of
http://bugzilla.mozilla.org/show_bug.cgi?id=153276
(Reporter)

Comment 4

16 years ago
Yes, this bug is related. But I have found a crash that can occur since this
problem reduces the available folders in the sidebar. Manage bookmarks menu
items appears in the Create In pop-up menu.
(Reporter)

Comment 5

16 years ago
Actually, this problem reduces the number of folders in the Create In popup menu
not the actual sidebar.
(Reporter)

Updated

16 years ago
Summary: Bookmark menu is incorrectly displayed after changing order of bookmark folder in sidebar. → Manage Bookmarks appears in the Create In menu (Add Page to Bookmarks)

Comment 6

16 years ago
->pinkerton, although I still think this is a dup
Assignee: saari → pinkerton
(Assignee)

Comment 7

16 years ago
dupe

*** This bug has been marked as a duplicate of 153276 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.