crash when changing Window's windows colors; trunk [@ JS_HashTableRawLookup][@ js_SuspendThread][@ FindConstructor]

RESOLVED FIXED

Status

()

Core
XUL
--
critical
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: lancer, Assigned: Adam Lock)

Tracking

(4 keywords)

Trunk
x86
Windows ME
crash, regression, testcase, topcrash+
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
Browser crash when changing Window's windows colors and a extrange window appear... 

See http://latinmoz.f2g.net/asdf/ for better description
(Reporter)

Comment 1

16 years ago
extrange = strange
(Reporter)

Comment 2

16 years ago
Sorry, I am using:

Mozilla 1.1a+
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.1a+) Gecko/20020622

Comment 3

16 years ago
wfm using build 2002062304 on Win2k (trunk).
Reporter, do you get a Talkback window popup when crashing ? If so, please post
Talkback ID for this crash by running 'mozilla\bin\components\talkback.exe'.
Severity: normal → critical
Keywords: crash, stackwanted
(Reporter)

Comment 4

16 years ago
TB7649046Q TB7644741W

Comment 5

16 years ago
Doron, can you retreive Talkback data please: TB7649046Q ?
Whiteboard: Need TB7649046Q data
(Reporter)

Comment 6

16 years ago
i have tested with the lastest build:

Mozilla 1.1a+
Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.1a+) Gecko/20020623

and crash.  Talback ID: TB7650912M

Comment 7

16 years ago
Incident ID 7644741
Stack Signature JS_HashTableRawLookup 83cc7b08
Email Address
Product ID MozillaTrunk
Build ID 2002062208
Trigger Time 2002-06-23 22:49:06
Platform Win32
Operating System Windows 98 4.90 build 73010104
Module JS3250.DLL
URL visited
User Comments
Trigger Reason Access violation
Source File Name c:/builds/seamonkey/mozilla/js/src/jshash.c
Trigger Line No. 179
Stack Trace
JS_HashTableRawLookup [c:/builds/seamonkey/mozilla/js/src/jshash.c, line 179]
js_AtomizeString [c:/builds/seamonkey/mozilla/js/src/jsatom.c, line 573]
js_Atomize [c:/builds/seamonkey/mozilla/js/src/jsatom.c, line 652]
JS_NewFunction [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 2753]
XPCNativeMember::Resolve
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativeinfo.cpp, line
147]
DefinePropertyIfFound
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 429]
XPC_WN_NoHelper_Resolve
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 706]
js_LookupProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2294]
js_GetProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2455]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2576]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 806]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 881]
JS_CallFunctionValue [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 3430]
nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1045]
nsJSEventListener::HandleEvent
[c:/builds/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp, line 184]
nsEventListenerManager::HandleEventSubType
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1222]
nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
2221]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3447]
PresShell::HandleDOMEventWithTarget
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6228]
nsMenuFrame::Execute
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsMenuFrame.cpp, line 1681]
nsMenuFrame::HandleEvent
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsMenuFrame.cpp, line 466]
PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6197]
PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6103]
nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2085]
nsView::HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 306]
nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1896]
HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1029]
nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1046]
nsWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 4932]
ChildWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 5187]
nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3759]
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1291]
KERNEL32.DLL + 0x3613 (0xbff63613)
KERNEL32.DLL + 0x248f7 (0xbff848f7)
0x00648bf6
0x00058f64
0x559e5209 
---------------------------------------------------
Incident ID 7649046
Stack Signature js_SuspendThread 9b867802
Email Address charadew@netscape.net
Product ID MozillaTrunk
Build ID 2002062208
Trigger Time 2002-06-24 03:07:03
Platform Win32
Operating System Windows 98 4.90 build 73010104
Module JS3250.DLL
URL visited
User Comments
Trigger Reason Access violation
Source File Name c:/builds/seamonkey/mozilla/js/src/jslock.c
Trigger Line No. 915
Stack Trace
js_SuspendThread [c:/builds/seamonkey/mozilla/js/src/jslock.c, line 915]
js_Enqueue [c:/builds/seamonkey/mozilla/js/src/jslock.c, line 959]
js_Lock [c:/builds/seamonkey/mozilla/js/src/jslock.c, line 996]
js_AtomizeString [c:/builds/seamonkey/mozilla/js/src/jsatom.c, line 571]
js_Atomize [c:/builds/seamonkey/mozilla/js/src/jsatom.c, line 652]
JS_NewFunction [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 2753]
XPCNativeMember::Resolve
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativeinfo.cpp, line
147]
DefinePropertyIfFound
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 429]
XPC_WN_NoHelper_Resolve
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 706]
js_LookupProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2294]
js_GetProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2455]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2576]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 806]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 881]
JS_CallFunctionValue [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 3430]
nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1045]
nsJSEventListener::HandleEvent
[c:/builds/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp, line 184]
nsEventListenerManager::HandleEventSubType
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1222]
nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
2221]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3447]
PresShell::HandleDOMEventWithTarget
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6228]
nsMenuFrame::Execute
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsMenuFrame.cpp, line 1681]
nsMenuFrame::HandleEvent
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsMenuFrame.cpp, line 466]
PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6197]
PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6103]
nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2085]
nsView::HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 306]
nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1896]
HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1029]
nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1046]
nsWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 4932]
ChildWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 5187]
nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3759]
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1291]
KERNEL32.DLL + 0x3613 (0xbff63613)
KERNEL32.DLL + 0x248f7 (0xbff848f7)
0x00648bf6
0x00058f64
0xffffffff 
-----------------------------------------------
Incident ID 7650912
Stack Signature FindConstructor 62fb73c4
Email Address charadew@netscape.net
Product ID MozillaTrunk
Build ID 2002062308
Trigger Time 2002-06-24 04:50:13
Platform Win32
Operating System Windows 98 4.90 build 73010104
Module JS3250.DLL
URL visited
User Comments
Trigger Reason Access violation
Source File Name c:/builds/seamonkey/mozilla/js/src/jsobj.c
Trigger Line No. 1725
Stack Trace
FindConstructor [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 1725]
GetClassPrototype [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 3236]
js_NewObject [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 1639]
js_NewFunction [c:/builds/seamonkey/mozilla/js/src/jsfun.c, line 1915]
JS_NewFunction [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 2757]
XPCNativeMember::Resolve
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativeinfo.cpp, line
147]
DefinePropertyIfFound
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 429]
XPC_WN_NoHelper_Resolve
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 706]
js_LookupProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2294]
js_GetProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2455]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2576]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 806]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 881]
JS_CallFunctionValue [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 3430]
nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1045]
nsJSEventListener::HandleEvent
[c:/builds/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp, line 184]
nsEventListenerManager::HandleEventSubType
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1222]
nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
2221]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3447]
PresShell::HandleDOMEventWithTarget
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6228]
nsMenuFrame::Execute
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsMenuFrame.cpp, line 1681]
nsMenuFrame::HandleEvent
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsMenuFrame.cpp, line 466]
PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6197]
PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6103]
nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2085]
nsView::HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 306]
nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1896]
HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1029]
nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1046]
nsWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 4932]
ChildWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 5187]
nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3759]
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1291]
KERNEL32.DLL + 0x3613 (0xbff63613)
KERNEL32.DLL + 0x248f7 (0xbff848f7)
0x00648bf6
0x00058f64
0x559e5209 

Those are the 3 incidents posted by lancer.  The stacks are all different, but
if you are crashing doing the same tast it's probably worth a closer look.  None
of them look like topcrashers though.
Keywords: stackwanted

Comment 8

16 years ago
-> JavaScript (all stacks ends in JS area)
Assignee: Matti99 → rogerl
Component: Browser-General → JavaScript Engine
QA Contact: imajes-qa → pschwartau
Summary: Browser crash when changing Window's windows colors → crash when changing Window's windows colors [@ JS_HashTableRawLookup][@ js_SuspendThread][@ FindConstructor]
Whiteboard: Need TB7649046Q data

Comment 9

16 years ago
I think Embedding:Docshell might be a better component; reassigning.
It sounds like events are being sent to the wrong window context
when the new window is being created (or something like that).
cc'ing jband, dbradley in case they can see the problem.

Note there are exellent steps to reproduce, with screenshots,
at the page the reporter has created: http://latinmoz.f2g.net/asdf/

Note he refers to the Windows control panel for screen properties.
On my WinNT box, for example, this is found at

     Settings > Control Panel > Display > "Appearance" tab


So far, I have not been able to reproduce the crash, however.
Using Mozilla trunk binary 20020617xx on WinNT -
Assignee: rogerl → adamlock
Component: JavaScript Engine → Embedding: Docshell
QA Contact: pschwartau → adamlock
(Assignee)

Comment 10

16 years ago
Reassigning to XP Apps.

I see this on Windows XP too, when I switch to Windows Classic theme and change
colours. I think the cause has something to do with that blank window that
appears, possibly caused by incorrect handling of WM_SYSCOLORCHANGE (and
subsequent NS_SYSCOLORCHANGED).

http://lxr.mozilla.org/seamonkey/source/widget/src/windows/nsWindow.cpp#3495
Assignee: adamlock → sgehani
Component: Embedding: Docshell → XP Apps
QA Contact: adamlock → paw

Comment 11

16 years ago
bouncing since i doubt xpapps cares.
Assignee: sgehani → jaggernaut
Component: XP Apps → XP Toolkit/Widgets
QA Contact: paw → jrgm
(Assignee)

Comment 12

16 years ago
Further investigation with Spy++ suggests the blank window was originally an
invisible window (for accessibility, clipboard or something) and was being made
visible by the system colour change. This appears to happen because straight
after every window is sent a focus and activation event during which
GlobalWindowImpl::Focus calls SetVisibility(PR_TRUE) to display it.

Whatever is enumerating the windows and sending focus/activate should be fixed
to ignore invisible windows.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 13

16 years ago
js_SuspendThread is a Topcrash on the trunk
Adding trunk to summary line for tracking; adding topcrash to keywords.

Comments/Urls:

   (7868388)	Comments: Open Mozilla -> Change theme in windows xp with the
StyleXP application -> Click link in mozilla -> mozilla crash
   (7793802)	URL: http://www.cnet.com
   (7853934)	URL: mail.yahoo.com
   (7853934)	Comments: crashed when changing appearance from win9x to luna
   (7686917)	Comments: resize window?
Keywords: topcrash
Summary: crash when changing Window's windows colors [@ JS_HashTableRawLookup][@ js_SuspendThread][@ FindConstructor] → crash when changing Window's windows colors; trunk [@ JS_HashTableRawLookup][@ js_SuspendThread][@ FindConstructor]

Comment 14

16 years ago
Are there any builds before the 22nd that have this crash?

Comment 15

16 years ago
Yes.  Here's a stacktrace from "Netscape Win32 (2002062109)"  Talkback ID 7841307

     js_SuspendThread   [c:/builds/seamonkey/mozilla/js/src/jslock.c, line 915]
     js_Enqueue [c:/builds/seamonkey/mozilla/js/src/jslock.c, line 959]
     js_Lock [c:/builds/seamonkey/mozilla/js/src/jslock.c, line 996]
     js_AtomizeString [c:/builds/seamonkey/mozilla/js/src/jsatom.c, line 571]
     js_Atomize [c:/builds/seamonkey/mozilla/js/src/jsatom.c, line 652]
     JS_NewFunction [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 2753]
     XPCNativeMember::Resolve
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativeinfo.cpp, line
147]
     DefinePropertyIfFound
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 429]
     XPC_WN_Helper_NewResolve
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 955]
     js_LookupProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2251]
     js_GetProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2455]
     js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2576]
     js_Execute [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 970]
     JS_ExecuteScript [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 3276]
     nsJSContext::ExecuteScript
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 850]
     nsXULDocument::ExecuteScript
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULDocument.cpp, line 5967]
     nsXULDocument::OnStreamComplete
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULDocument.cpp, line 5903]
     nsStreamLoader::OnStopRequest
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsStreamLoader.cpp, line 163]
     nsJARChannel::OnStopRequest
[c:/builds/seamonkey/mozilla/netwerk/protocol/jar/src/nsJARChannel.cpp, line 609]
     nsOnStopRequestEvent::HandleEvent
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsRequestObserverProxy.cpp, line 213]
     PL_HandleEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 597]
     PL_ProcessPendingEvents
[c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 530]
     _md_EventReceiverProc [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c,
line 1078]
     USER32.dll + 0x3c076 (0x77d7c076)  
     USER32.dll + 0x3c076 (0x77d7c076)  
     _except_handler3()  
     kernel32.dll + 0x3bb86 (0x77e9bb86)  

Comment 16

16 years ago
Making this a topcrash+ and adding testcase keyword.  I was able to reproduce
this numerous times with today's MozillaTrunk build 2002070108 on Win2k.  All
the crashes are being reported under various 0xXXXXXXXX stack signatures, but
the steps I took to crash are all related.  I will attach my incidents.
Keywords: topcrash → testcase, topcrash+

Comment 17

16 years ago
The one in comment 15 looks like a different stack.

Comment 18

16 years ago
Created attachment 89849 [details]
[0xXXXXXXXX - JS_DHashTableOperate | XPCWrappedNativeProto::JSProtoObjectFinalized] crashes

My crashes on Win2k.  All are being reported under some 0xXXXXXXXX stack
signature with JS_DHashTableOperate and/or
XPCWrappedNativeProto::JSProtoObjectFinalized a frame or 2 below that in the
stack.

Comment 19

16 years ago
I pretty much followed the steps at http://latinmoz.f2g.net/asdf/ to crash.  My
comments for the incidents I attached say more about what I was doing.

Comment 20

16 years ago
Jag:  I was able to reproduce this crash with MozillaTrunk build 2002062109:

Incident ID 7905509
Stack Signature 0x0156d225 02aa9d7a
Email Address jpatel@netscape.com
Product ID MozillaTrunk
Build ID 2002062109
Trigger Time 2002-07-01 16:45:02
Platform Win32
Operating System Windows NT 5.0 build 2195
Module
URL visited bug 153834
User Comments 1. start netscape in modern theme 2. change windows theme color 3.
small blank window opens 4. close small window and then nav window 5. crash.
Trigger Reason Privileged instruction
Source File Name
Trigger Line No.
Stack Trace
0x0156d225
XPCWrappedNativeProto::JSProtoObjectFinalized
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativeproto.cpp,
line 131]
XPC_WN_Shared_Proto_Finalize
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1357]
js_FinalizeObject [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 1819]
js_GC [c:/builds/seamonkey/mozilla/js/src/jsgc.c, line 1287]
js_ForceGC [c:/builds/seamonkey/mozilla/js/src/jsgc.c, line 981]
js_DestroyContext [c:/builds/seamonkey/mozilla/js/src/jscntxt.c, line 243]
nsJSContext::~nsJSContext
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 468]
nsJSContext::`scalar deleting destructor'
nsJSContext::Release
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 500]
nsCOMPtr_base::assign_with_AddRef
[c:/builds/seamonkey/mozilla/xpcom/glue/nsCOMPtr.cpp, line 74]
nsXBLDocumentInfo::~nsXBLDocumentInfo
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLDocumentInfo.cpp, line 347]
nsXBLDocumentInfo::`scalar deleting destructor'
nsXBLDocumentInfo::Release
[c:/builds/seamonkey/mozilla/content/xbl/src/nsXBLDocumentInfo.cpp, line 316]
nsProperties::ReleaseValues
[c:/builds/seamonkey/mozilla/xpcom/ds/nsProperties.cpp, line 70]
PL_HashTableEnumerateEntries [plhash.c, line 430]
nsHashtable::Enumerate [c:/builds/seamonkey/mozilla/xpcom/ds/nsHashtable.cpp,
line 363]
nsSupportsHashtable::~nsSupportsHashtable
[c:/builds/seamonkey/mozilla/xpcom/ds/nsHashtable.cpp, line 945]
nsXULPrototypeCache::~nsXULPrototypeCache
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULPrototypeCache.cpp,
line 210]
nsXULPrototypeCache::Release
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULPrototypeCache.cpp,
line 210]
nsXULPrototypeScript::ReleaseGlobals
[c:/builds/seamonkey/mozilla/content/build/../xul/content/src\nsXULElement.h,
line 342]
Shutdown [c:/builds/seamonkey/mozilla/content/build/nsContentModule.cpp, line 257]
nsGenericModule::Shutdown
[c:/builds/seamonkey/mozilla/xpcom/glue/nsGenericFactory.cpp, line 325]
nsThreadPool::Release [c:/builds/seamonkey/mozilla/xpcom/threads/nsThread.cpp,
line 505]
nsDll::Shutdown [c:/builds/seamonkey/mozilla/xpcom/components/xcDll.cpp, line 394]
nsFreeLibrary
[c:/builds/seamonkey/mozilla/xpcom/components/nsNativeComponentLoader.cpp, line 309]
nsFreeLibraryEnum
[c:/builds/seamonkey/mozilla/xpcom/components/nsNativeComponentLoader.cpp, line 358]
_hashEnumerate [c:/builds/seamonkey/mozilla/xpcom/ds/nsHashtable.cpp, line 200]
PL_HashTableEnumerateEntries [plhash.c, line 430]
nsHashtable::Enumerate [c:/builds/seamonkey/mozilla/xpcom/ds/nsHashtable.cpp,
line 363]
nsNativeComponentLoader::UnloadAll
[c:/builds/seamonkey/mozilla/xpcom/components/nsNativeComponentLoader.cpp, line 949]
nsComponentManagerImpl::UnloadLibraries
[c:/builds/seamonkey/mozilla/xpcom/components/nsComponentManager.cpp, line 2960]
nsComponentManagerImpl::Shutdown
[c:/builds/seamonkey/mozilla/xpcom/components/nsComponentManager.cpp, line 860]
NS_ShutdownXPCOM [c:/builds/seamonkey/mozilla/xpcom/build/nsXPComInit.cpp, line
608] 
-------------------------------------------------
Incident ID 7905544
Stack Signature FreeArenaList 6eaf820a
Email Address jpatel@netscape.com
Product ID MozillaTrunk
Build ID 2002062109
Trigger Time 2002-07-01 16:49:02
Platform Win32
Operating System Windows NT 5.0 build 2195
Module js3250.dll
URL visited bug 153834
User Comments 1. nav window open 2. change windows color theme 3. small blank
window opens 4. open new nav window 5. close small window, new nav window and
original nav window 6. crash.
Trigger Reason Access violation
Source File Name c:/builds/seamonkey/mozilla/js/src/jsarena.c
Trigger Line No. 323
Stack Trace
FreeArenaList [c:/builds/seamonkey/mozilla/js/src/jsarena.c, line 323]
JS_FinishArenaPool [c:/builds/seamonkey/mozilla/js/src/jsarena.c, line 448]
JS_GC [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 1654]
nsDOMSOFactory::Observe
[c:/builds/seamonkey/mozilla/dom/src/build/nsDOMFactory.cpp, line 231]
nsObserverService::NotifyObservers
[c:/builds/seamonkey/mozilla/xpcom/ds/nsObserverService.cpp, line 213]
NS_ShutdownXPCOM [c:/builds/seamonkey/mozilla/xpcom/build/nsXPComInit.cpp, line 550]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1816]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1826]
WinMainCRTStartup()
KERNEL32.DLL + 0x17d08 (0x77e97d08) 

The second crash has a different stack, but the only difference in the steps is
that I created a new nav window after changing the colors.

Comment 21

16 years ago
Jay: okay. Do you have time to find out when this started? If not I'll see if I
can find a w2k machine here.

Comment 22

16 years ago
Jag:  I can spend some time tommorrow narrowing this down...but do we have any
idea or time period around where this problem might have started?  

Adam:  Do you know of any changes that might have exposed this bug?  Your
comment #12 seems to explain a lot, but do we know if something checked in
recently would have caused this bug?

Comment 23

16 years ago
Ok, after installing a few builds I have found out that MozillaTrunk builds from
6/20 were the first to popup the small blank window when changing the windows
system colors.  I was able to crash (with yet another stack signature) with
build 2002062008:

Incident ID 7908724
Stack Signature js_Lock 82fca052
Email Address jpatel@netscape.com
Product ID MozillaTrunk
Build ID 2002062008
Trigger Time 2002-07-01 18:46:07
Platform Win32
Operating System Windows NT 5.0 build 2195
Module js3250.dll
URL visited bug 153834
User Comments same as before, changing windows system colors, seeing a small
blank window open, opening second nav window...then closing the small window,
and the nav windows...boom!
Trigger Reason Access violation
Source File Name c:/builds/seamonkey/mozilla/js/src/jslock.c
Trigger Line No. 990
Stack Trace
js_Lock [c:/builds/seamonkey/mozilla/js/src/jslock.c, line 990]
js_AtomizeString [c:/builds/seamonkey/mozilla/js/src/jsatom.c, line 571]
js_Atomize [c:/builds/seamonkey/mozilla/js/src/jsatom.c, line 652]
JS_NewFunction [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 2753]
XPCNativeMember::Resolve
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativeinfo.cpp, line
147]
DefinePropertyIfFound
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 429]
XPC_WN_NoHelper_Resolve
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 706]
js_LookupProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2294]
js_GetProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2455]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2576]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 806]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 881]
JS_CallFunctionValue [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 3430]
nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1045]
nsJSEventListener::HandleEvent
[c:/builds/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp, line 184]
nsEventListenerManager::HandleEventSubType
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1222]
nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1904]
GlobalWindowImpl::HandleDOMEvent
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 736]
DocumentViewerImpl::Unload
[c:/builds/seamonkey/mozilla/content/base/src/nsDocumentViewer.cpp, line 1581]
nsDocShell::FireUnloadNotification
[c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp, line 754]
nsDocShell::Destroy [c:/builds/seamonkey/mozilla/docshell/base/nsDocShell.cpp,
line 2693]
nsWebShell::Destroy [c:/builds/seamonkey/mozilla/docshell/base/nsWebShell.cpp,
line 1298]
nsXULWindow::Destroy
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsXULWindow.cpp, line 397]
nsWebShellWindow::Destroy
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsWebShellWindow.cpp, line 1765]
nsWebShellWindow::Close
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsWebShellWindow.cpp, line 388]
nsWebShellWindow::HandleEvent
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsWebShellWindow.cpp, line 487]
nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1029]
nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1046]
nsWindow::DispatchStandardEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1067]
nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3518]
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1291]
USER32.DLL + 0x2e98 (0x77e12e98)
USER32.DLL + 0x39a3 (0x77e139a3)
USER32.DLL + 0x395f (0x77e1395f)
ntdll.dll + 0x2032f (0x77fa032f)
USER32.DLL + 0x4ef0 (0x77e14ef0)
USER32.DLL + 0x2e98 (0x77e12e98)
USER32.DLL + 0x6a72 (0x77e16a72)
USER32.DLL + 0x6aee (0x77e16aee)
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1302]
USER32.DLL + 0x2e98 (0x77e12e98)
USER32.DLL + 0x39a3 (0x77e139a3)
USER32.DLL + 0x395f (0x77e1395f)
ntdll.dll + 0x2032f (0x77fa032f)
USER32.DLL + 0x4ef0 (0x77e14ef0)
USER32.DLL + 0x2e98 (0x77e12e98)
USER32.DLL + 0x6a72 (0x77e16a72)
USER32.DLL + 0x6aee (0x77e16aee)
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1302]
USER32.DLL + 0x2e98 (0x77e12e98)
USER32.DLL + 0x30e0 (0x77e130e0)
USER32.DLL + 0x5824 (0x77e15824)
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 458]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1472]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1808]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1826]
WinMainCRTStartup()
KERNEL32.DLL + 0x17d08 (0x77e97d08)

I was unable to crash with builds from 6/19, so this is a regression introduced
between 6/19 and 6/20.  Adding regression keyword.
Keywords: regression

Comment 25

16 years ago
Argh, I meant between 06/19/2002 00:00 and 06/20/02 08:00.  Sorry for the spam.
(Assignee)

Comment 26

16 years ago
This change to nsWindow.cpp looks a possible culprit:

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&file=nsWindow.cpp&root=/cvsroot&subdir=mozilla/widget/src/windows&command=DIFF_FRAMESET&rev1=3.426&rev2=3.427

It is possible that a WM_WINDOWPOSCHANGED message is sent to all frames after a
system colour change to account the new frame sizes. I'm just waiting for a
build to complete, but I suspect the new code testing SWP_FRAMECHANGED should
not be performed on invisible windows.

I will attach a patch if that is the case.
(Assignee)

Comment 27

16 years ago
Created attachment 89949 [details] [diff] [review]
Patch

This simple patch prevents the focus/activate if the window is not visible. 

In case anyone is wondering, I call ::IsWindowVisible() because it takes into
account the visibility of any parent windows whereas testing mIsVisible
wouldn't.

Reviews please?

Chris can you check to make sure I haven't broken what you were trying to fix
here?

Comment 28

16 years ago
-> Adam Lock

Thanks Adam!
Assignee: jaggernaut → adamlock

Comment 29

16 years ago
Comment on attachment 89949 [details] [diff] [review]
Patch

r=saari, sr=jag
Attachment #89949 - Flags: superreview+
Attachment #89949 - Flags: review+

Comment 30

16 years ago
adding adt1.0.1+.  Please get drivers approval before checking into the branch.
Keywords: adt1.0.1+, mozilla1.0.1

Comment 31

16 years ago
Comment on attachment 89949 [details] [diff] [review]
Patch

a=chofmann for 1.0.1.  Add the fixed1.0.1 keyword after checking the change in
on the branch.
Attachment #89949 - Flags: approval+

Updated

16 years ago
Keywords: mozilla1.0.1 → mozilla1.0.1+

Comment 32

16 years ago
Checked in on both trunk and branch. Marking fixed, adding fixed1.0.1
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: mozilla1.0.1+ → fixed1.0.1
Resolution: --- → FIXED
Crash Signature: [@ JS_HashTableRawLookup] [@ js_SuspendThread] [@ FindConstructor]
You need to log in before you can comment on or make changes to this bug.