Mozilla crashes when editing this mail

VERIFIED DUPLICATE of bug 141054

Status

MailNews Core
Composition
--
critical
VERIFIED DUPLICATE of bug 141054
16 years ago
10 years ago

People

(Reporter: Aurele Venet, Assigned: Jean-Francois Ducarroz)

Tracking

({crash, stackwanted})

Trunk
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Need TB7652504X data)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
I have a mail which when I reply to and proceeed to delete part of the quoted
text from the original mail it causes the whole of mozilla to crash.  It only
works with a perticular e/mail (please send me the e/mail address of the
developper who is going to fix this, and I will forward him/her the e/mail in
question).

Comment 1

16 years ago
Please attach e-mail here, after removing confidential informations if possible.
Severity: major → critical
Keywords: crash, stackwanted
(Reporter)

Comment 2

16 years ago
Created attachment 88926 [details]
e/mail which causes crash when editing the reply

I have saved the e/mail from the mail & news group window to this file.  The
orginal e/mail appears as plain text along with an attachment att.htm which is
included at the bottom of this attachment.
(Reporter)

Comment 3

16 years ago
I am running mozilla on the sun platform and my distro does not appear to have
the talkback facility.  Hence I am going to try to reproduce the error on a
win32 platform with a talkback enabled mozilla1.0 build.   I will comment my
findings here when I have some more info.
(Reporter)

Comment 4

16 years ago
TALKBACK info available (ID #: TB7652504X).  I have run mozilla1.0 on a
win98/intel platform with the talkback app switched on.  I was succesfully able
to reproduce the above bug.  
(Reporter)

Comment 5

16 years ago
Error reproducible under mozilla v1.1a (Talkback ID # TB7652504X).  I ran the
latest mozilla build (on a win98/intel platform) out of curiosity and it crashed
again.

Comment 6

16 years ago
Marking NEW.
OS -> All.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Solaris → All
Hardware: Sun → All
Whiteboard: Need TB7652504X data
(Assignee)

Comment 7

16 years ago
sound like a dup of a bug dbaron fixed recently
(Assignee)

Comment 8

16 years ago
stack trace from tallback:

nsLineLayout::IsPercentageUnitSides
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsLineLayout.cpp, line 1776]
IsPercentageAwareChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 1136]
nsBlockFrame::ReflowInlineFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3689]
nsBlockFrame::DoReflowInlineFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3578]
nsBlockFrame::DoReflowInlineFramesAuto
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3503]
nsBlockFrame::ReflowInlineFrames
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3448]
nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2606]
nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2245]
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 852]
nsBlockReflowContext::DoReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
581]
nsBlockReflowContext::ReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
359]
nsBlockFrame::ReflowBlockFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3204]
nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2472]
nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2245]
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 852]
nsBlockReflowContext::DoReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
581]
nsBlockReflowContext::ReflowBlock
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockReflowContext.cpp, line
359]
nsBlockFrame::ReflowBlockFrame
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 3204]
nsBlockFrame::ReflowLine
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2472]
nsBlockFrame::ReflowDirtyLines
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 2245]
nsBlockFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsBlockFrame.cpp, line 852]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 807]
CanvasFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLFrame.cpp, line 565]
nsBoxToBlockAdaptor::Reflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxToBlockAdaptor.cpp, line 837]
nsBoxToBlockAdaptor::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxToBlockAdaptor.cpp, line 619]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 1052]
nsScrollBoxFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsScrollBoxFrame.cpp, line 395]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 1052]
nsContainerBox::LayoutChildAt
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsContainerBox.cpp, line 650]
nsGfxScrollFrameInner::LayoutBox
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 1063]
nsGfxScrollFrameInner::Layout
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 1222]
nsGfxScrollFrame::DoLayout
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 1071]
nsBox::Layout [d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 1052]
nsBoxFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBoxFrame.cpp, line 1001]
nsGfxScrollFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsGfxScrollFrame.cpp, line 780]
nsContainerFrame::ReflowChild
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsContainerFrame.cpp, line 807]
ViewportFrame::Reflow
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsViewportFrame.cpp, line 588]
nsHTMLReflowCommand::Dispatch
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsHTMLReflowCommand.cpp, line 218]
PresShell::ProcessReflowCommand
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6305]
PresShell::ProcessReflowCommands
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6360]
PresShell::FlushPendingNotifications
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5069]
PresShell::EndReflowBatching
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 5100]
nsEditor::EndUpdateViewBatch
[d:\builds\seamonkey\mozilla\editor\libeditor\base\nsEditor.cpp, line 4269]
nsEditor::EndPlaceHolderTransaction
[d:\builds\seamonkey\mozilla\editor\libeditor\base\nsEditor.cpp, line 714]
nsPlaintextEditor::DeleteSelection
[d:\builds\seamonkey\mozilla\editor\libeditor\text\nsPlaintextEditor.cpp, line 950]
nsHTMLEditorLog::DeleteSelection
[d:\builds\seamonkey\mozilla\editor\libeditor\html\nsHTMLEditorLog.cpp, line 160]
nsTextEditorKeyListener::KeyPress
[d:\builds\seamonkey\mozilla\editor\libeditor\text\nsEditorEventListeners.cpp,
line 255]
nsEventListenerManager::HandleEvent
[d:\builds\seamonkey\mozilla\content\events\src\nsEventListenerManager.cpp, line
1663]
nsDocument::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsDocument.cpp, line 3290]
nsGenericElement::HandleDOMEvent
[d:\builds\seamonkey\mozilla\content\base\src\nsGenericElement.cpp, line 1687]
PresShell::HandleEventInternal
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6105]
PresShell::HandleEvent
[d:\builds\seamonkey\mozilla\layout\html\base\src\nsPresShell.cpp, line 6028]
nsViewManager::HandleEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 2030]
nsView::HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 306]
nsViewManager::DispatchEvent
[d:\builds\seamonkey\mozilla\view\src\nsViewManager.cpp, line 1887]
HandleEvent [d:\builds\seamonkey\mozilla\view\src\nsView.cpp, line 83]
nsWindow::DispatchEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 891]
nsWindow::DispatchWindowEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 908]
nsWindow::DispatchKeyEvent
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 2682]
nsWindow::OnChar [d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp,
line 2832]
nsWindow::ProcessMessage
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 3481]
nsWindow::WindowProc
[d:\builds\seamonkey\mozilla\widget\src\windows\nsWindow.cpp, line 1153]
KERNEL32.DLL + 0x363b (0xbff7363b)
KERNEL32.DLL + 0x24407 (0xbff94407) 
(Assignee)

Comment 9

16 years ago
The build the reporter is using is 2002053015. This is a dup of bug 141054 which
has been fixed in the trunk on 06/11 and in the branch on 06/20

*** This bug has been marked as a duplicate of 141054 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 10

16 years ago
verified that this is fixed too with the dup bug fix. winxp, mac os10.1 and  linux
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.