Chrome corruption, not updated

RESOLVED WORKSFORME

Status

()

defect
--
major
RESOLVED WORKSFORME
17 years ago
5 years ago

People

(Reporter: zac.spitzer, Unassigned)

Tracking

({qawanted})

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

17 years ago
i get a lot problems with my browsers chrome not being updated, ie the chrome is
not being re-painted.. sometimes going from full screen ( maximized to window)
fixes the problem.. but it is very annying.. mouseovers update certain areas
like tool bars and menus but it normally requires restarting mozilla

I am using cold fusion studio 5 which I know created problems before with apps
and repainting.... the two seem to cuasing problems

my config is w2k server english with two monitors, one pci and one agp.... the
problem only affcts the monitor where cf-studio is open on

video cards are ati 3d rage pro agp and matrox millenium pci
Reporter

Comment 1

17 years ago
using
Mozilla 1.1a
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a) Gecko/20020619
no blocker : never seen this on my win2k system
Severity: blocker → major

Comment 3

17 years ago
Confirming as this has been happening to me as well lately. Not reliably
reproducable, but usually after having surfed intensively (opening a few new
tabs every minute) for several hours, when I alt-tab to a different application
(usually irc or icq) and go back to Mozilla, all my chrome has disappeared.
Parts of it reappear on :hover, and sometimes minimizing Mozilla completely will
fix for a short while, but I need to close Mozilla completely and restart it to
truly fix it (no reboot required).
Currently using 2002062109, but I've seen it ever since I left the branch and
tried 1.1 alpha (2002061108). Clean installs, though old profile that's been
with me since 0.9.2 I'm not using quicklaunch, running windows 98 SE and a
voodoo 5 5500 (on the rare chance that video card matters for this).
The very same problem (at least in behaviour) was very active around 0.9.7, and
slowly disappeared till it was completely gone by 0.9.9 I don't know if that's
enough to mark this a regression, so I'll leave that up to someone else.

bug 133132 (and dupes) might be related, but (except for one occasion) I never
see the black & white effect described there.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

17 years ago
-> XUL (cache?)
Assignee: sgehani → hyatt
Component: XP Apps → XP Toolkit/Widgets: XUL
Keywords: qawanted
QA Contact: paw → shrir

Comment 5

17 years ago

*** This bug has been marked as a duplicate of 147845 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
Based on the screenshots from bug 147845 which are nothing at all like what is
mentioned here, plus the fact that I don't have a matrox card and have seen the
same problem (the chrome of the browser not being repainted - instead of seeing
artifacts in the page when scrolling), I sincerely doubt this is a dupe.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 7

17 years ago
Seeing this in 2003012417, i'm on Win98 and I *don't* have a Matrox videocard. 

What's strange is that when the chrome corruption occurs, pressing printscreen
and pasting the contents into Photoshop doesn't give me a real screenshot, but
rather just a monochrome mess of black and white lines.

Comment 8

17 years ago
Monochrome screenshots are a symptom of bug 133132. I'm not sure if this bug is 
a dup of bug 133132, if the two bugs are unrelated, or if they are partially 
related.

Comment 9

16 years ago
As the people seeing this all say it happens after a long time of browsing (as
did I): Could it be that this is caused by a leak of GDI resources?

I think I read about this in some bug report, but I could only find similar bugs
#159298 and #192605

Also, does anyone still see this in recent builds?

Comment 10

16 years ago
I've seen it happen on Mozilla 1.6, Win98 SE.  I thought it was related to GDI
handles, but IIRC the last time it happened, I shut down Mozilla, checked to see
that I had >60% System Resources free, restarted Mozilla, and the problem
immediately reappeared.  Of course, the System Resource meter is not a real
great debugging tool.

I still think it's connected to a GDI leak or something, though.  I had recently
been on pages with lots of large images.  And I've noticed this sort of thing
seems to happen much less often since bug 216430 was fixed.

Comment 11

15 years ago
It still happens in 1.7rc1 (on Windows 98 SE) on low GDI ressources. I continued 
to test (by placing a DOS window above the Moz window which forces a redraw) and 
opened the heavy graphics sites in the debug menu (Disney, CNN etc.). After 10 
minutes of pushing and kicking I was able to finally crash Mozilla and trigger 
a talkback report.

Where can I find the incident number of the talkback report that I sent? Or 
else, how do the developers find my report to see if it helps resolving this 
bug?? Does it contain my email address?

Best, Stefan.

Comment 12

14 years ago
is this still a problem with recent builds?
http://ftp.mozilla.org/pub/mozilla.org/mozilla/nightly/latest-trunk/
(use a zip build... installer builds are currently broken)

GDI leak ==> win32
Assignee: hyatt → win32
Status: REOPENED → NEW
Component: XP Toolkit/Widgets: XUL → Widget: Win32
QA Contact: shrir → ian

Comment 13

13 years ago
No response for over one year. This seems to be WFM. Please comment if you still see the chrome not being updated in a recent build.
Status: NEW → RESOLVED
Last Resolved: 17 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.