Status

()

defect
VERIFIED FIXED
2 months ago
a month ago

People

(Reporter: jovan.gerodetti, Assigned: kmag)

Tracking

(Regression, {regression})

Firefox 68
Firefox 68
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox66 unaffected, firefox67 verified, firefox68 verified)

Details

()

Attachments

(1 attachment)

Reporter

Description

2 months ago

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:67.0) Gecko/20100101 Firefox/67.0

Steps to reproduce:

  1. visit https://gauntface.github.io/simple-push-demo/
  2. enable Push Notifications
  3. click "Send A Push Via XHR"

Actual results:

Nothing. From the logcat output I gather that a firefox internal service does not work properly.

03-25 10:29:04.409 19385 24530 D GeckoPushGCM: Message received. Processing on background thread.
03-25 10:29:04.413 19385 19434 I GeckoPushService: Google Play Services GCM message received; delivering.
03-25 10:29:04.413 19385 19434 I GeckoPushService: Message directed to service: webpush
03-25 10:29:04.423 19385 19433 I GeckoConsole: While creating services from category 'android-push-service', could not create service for entry 'FxAccountsPush', contract ID '@mozilla.org/fxa-push;1'
03-25 10:29:04.423 19385 19434 I GeckoPushService: Required service not initialized, adding message to queue.

Expected results:

Notification should appear, like it does on desktop and did on android before.

Hello Jovan and thank you for this report!
I was able to reproduce this issue on the latest Nightly and Beta(67.0b5) build with Samsung Galaxy Note 9 (Android 8.1.0).
Not reproducible on the latest RC build.
Based on this I will set this issue as new.
After further investigation I was able to find a regression range:
build_date: 2019-02-15 19:17:24.413000 - last known good build.
build_date: 2019-02-15 04:14:20.974000 - first known bad build
It seems that the patches from bug 1524688 introduced this regression.
Kris Maglione can you please check this?

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(kmaglione+bmo)
OS: Unspecified → Android
Hardware: Unspecified → ARM

Moving to Firefox Accounts component, based on this:

  • 03-25 10:29:04.423 19385 19433 I GeckoConsole: While creating services from category 'android-push-service', could not create service for entry 'FxAccountsPush', contract ID '@mozilla.org/fxa-push;1'
Component: General → Firefox Accounts
Keywords: regression
Assignee

Updated

2 months ago
Assignee: nobody → kmaglione+bmo
Flags: needinfo?(kmaglione+bmo)
Assignee

Comment 3

2 months ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/779ab99bea09b7ffea6c287cd56d9a8d9a06534f
Bug 1538643: Fix unintended removal of FxAccountsPush from Android install manifest. r=backout
Assignee

Comment 5

2 months ago

Comment on attachment 9054719 [details]
Bug 1538643: Fix unintended removal of FxAccountsPush from Android install manifest.

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1524688
  • User impact if declined: This prevents web push from working on Android.
  • Is this code covered by automated tests?: Unknown
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment 0
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This simply restores a missing entry to the install manifest for Android. That file is only loaded when it's needed, and the cases which currently attempt to load it are already broken.
  • String changes made/needed: None
Attachment #9054719 - Flags: approval-mozilla-beta?
Assignee

Updated

2 months ago
Flags: qe-verify?

Comment 6

2 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Reporter

Comment 7

2 months ago

It doesn't work for me yet and I'm still getting these messages:

03-31 13:27:34.064 15887 16606 D GeckoPushGCM: Message received. Processing on background thread.
03-31 13:27:34.362 15887 15912 I GeckoPushService: Google Play Services GCM message received; delivering.
03-31 13:27:34.363 15887 15912 I GeckoPushService: Message directed to service: webpush
03-31 13:27:34.367 15887 15912 I GeckoPushService: Required service not initialized, adding message to queue.

My current Fennec build ID is 20190331090052 which I think should include the commit posted above.

Status: RESOLVED → REOPENED
Flags: needinfo?(kmaglione+bmo)
Resolution: FIXED → ---
Flags: qe-verify? → qe-verify+
Assignee

Comment 8

2 months ago

(In reply to Jovan Gerodetti from comment #7)

My current Fennec build ID is 20190331090052 which I think should include the commit posted above.

It does not.

Status: REOPENED → RESOLVED
Last Resolved: 2 months ago2 months ago
Flags: needinfo?(kmaglione+bmo)
Resolution: --- → FIXED

Verified as fixed in latest Nightly build(01-Apr-2019 14:01) with Samsung Galaxy Note 9(Android 8.1.).
Note that I've sent more than 15 push notifications and they were received every time.

Flags: qe-verify+
Regressed by: 1524688
Status: RESOLVED → VERIFIED

Comment on attachment 9054719 [details]
Bug 1538643: Fix unintended removal of FxAccountsPush from Android install manifest.

Low risk patch for a P1 67 regression, verified by QA on Nightly, uplift approved for our next 67 beta, thanks.

Attachment #9054719 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 12

a month ago

Hi!
Verified as fixed on Beta 67.0b9, with Samsung Galaxy S8 (Android 9.0), and Huawei MediaPad Mi2 (Android 5.1.1).
Thanks!

You need to log in before you can comment on or make changes to this bug.