Crash by removing from list

VERIFIED DUPLICATE of bug 153480

Status

--
critical
VERIFIED DUPLICATE of bug 153480
17 years ago
14 years ago

People

(Reporter: nagi, Assigned: bugzilla)

Tracking

({crash, stackwanted})

Trunk
x86
Windows 98
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Need TB7651121G data)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a+) Gecko/20020621
BuildID:    2002062104

Mozilla crashed when I try to remove the file from the downloadmanager.
This only happens by a special file, the others worked fine.
The name of the file is: Hüüslistrand.jpeg
Progress shows a not filed box and Transfered 0kb of 0kb.
Talkbacks:
TB7651121G
TB7651103Z

Reproducible: Always
Steps to Reproduce:
1. Open the downloadmanager
2. mark the file
3. click on remove from list

Actual Results:  crash

Expected Results:  no crash

Comment 1

17 years ago
Maybe related: bug 153732, bug 153093.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash, stackwanted
Whiteboard: Need TB7651121G data

Comment 2

17 years ago
Incident ID 7651121
Stack Signature InMemoryArcsEnumeratorImpl::HasMoreElements a4dd39a5
Email Address nagi@gmx.de
Product ID MozillaTrunk
Build ID 2002062104
Trigger Time 2002-06-24 04:58:59
Platform Win32
Operating System Windows 98 4.10 build 67766446
Module RDF.DLL
URL visited mp3.com
User Comments Delete a Bookmark MOZILLA verursachte einen Fehler durch eine
ungültige Seite in Modul RDF.DLL bei 017f:603b41fb. Register: EAX=00000000
CS=017f EIP=603b41fb EFLGS=00010246 EBX=ffffffff SS=0187 ESP=0064dffc
EBP=0064e008 ECX=00000001 DS=0187 ESI=01e4e498 FS=19a7 EDX=00000000 ES=0187
EDI=00000000 GS=0000 Bytes bei CS:EIP: 8b 07 57 ff 50 04 8b 45 0c c7 00 01 00 00
00 eb Stapelwerte: 80000000 60eb9885 00000000 0064e07c 609f1053 00000000
0064e058 01d87710 0064e0b4 0064e24c 60ebd124 0221d330 00000056 00000001 60ebbec8
02376010
Trigger Reason Access violation
Source File Name c:/builds/seamonkey/mozilla/rdf/base/src/nsInMemoryDataSource.cpp
Trigger Line No. 783
Stack Trace
InMemoryArcsEnumeratorImpl::HasMoreElements
[c:/builds/seamonkey/mozilla/rdf/base/src/nsInMemoryDataSource.cpp, line 783]
nsDownloadManager::RemoveDownload
[c:/builds/seamonkey/mozilla/xpfe/components/download-manager/src/nsDownloadManager.cpp,
line 672]
XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 1996]
XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 790]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2744]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 806]
nsXPCWrappedJSClass::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 1195]
nsXPCWrappedJS::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 430]
PrepareAndDispatch
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp,
line 117]
SharedStub
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcstubs.cpp,
line 139]
XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 1996]
XPC_WN_CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1267]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 790]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2744]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 806]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 881]
JS_CallFunctionValue [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 3430]
nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1045]
nsJSEventListener::HandleEvent
[c:/builds/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp, line 184]
nsEventListenerManager::HandleEventSubType
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
1222]
nsEventListenerManager::HandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp, line
2221]
nsXULElement::HandleDOMEvent
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 3447]
PresShell::HandleDOMEventWithTarget
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6228]
nsButtonBoxFrame::MouseClicked
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsButtonBoxFrame.cpp, line 192]
nsButtonBoxFrame::HandleEvent
[c:/builds/seamonkey/mozilla/layout/xul/base/src/nsButtonBoxFrame.cpp, line 142]
PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6197]
PresShell::HandleEventWithTarget
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6148]
nsEventStateManager::CheckForAndDispatchClick
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp, line 2751]
nsEventStateManager::PostHandleEvent
[c:/builds/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp, line 1757]
PresShell::HandleEventInternal
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6201]
PresShell::HandleEvent
[c:/builds/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp, line 6103]
nsViewManager::HandleEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2085]
nsView::HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 306]
nsViewManager::DispatchEvent
[c:/builds/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1896]
HandleEvent [c:/builds/seamonkey/mozilla/view/src/nsView.cpp, line 83]
nsWindow::DispatchEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1029]
nsWindow::DispatchWindowEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1046]
nsWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 4932]
ChildWindow::DispatchMouseEvent
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 5187]
nsWindow::ProcessMessage
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 3759]
nsWindow::WindowProc
[c:/builds/seamonkey/mozilla/widget/src/windows/nsWindow.cpp, line 1291]
KERNEL32.DLL + 0x363b (0xbff7363b)
KERNEL32.DLL + 0x24407 (0xbff94407)
0x00648bf6 

Looking at the stack, this is a dup of bug 153480.

*** This bug has been marked as a duplicate of 153480 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.