Closed Bug 1538705 Opened 5 years ago Closed 5 years ago

(Android) Crash in @ RetainedDisplayListBuilder::MergeDisplayLists with layout.display-list.retain=true

Categories

(Core :: Web Painting, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed

People

(Reporter: csheany, Assigned: tnikkel)

References

(Regression)

Details

(Keywords: crash, regression)

User Agent: Mozilla/5.0 (Android 7.1.1; Tablet; rv:68.0) Gecko/68.0 Firefox/68.0

Steps to reproduce:

https://crash-stats.mozilla.org/report/index/f444f4b5-eb07-4b02-8b5a-9b81e0190325

We had a similar bug about a year ago, Bug 1419546. It appears there still are a small amount of crashes in this signature following that fix. Do you have steps to reproduce? Thanks.

Status: UNCONFIRMED → NEW
Component: General → Web Painting
Ever confirmed: true
Keywords: crash
Product: Firefox for Android → Core
Version: Firefox 68 → Trunk

Thank you for your response.

This was after enabling the pref on mobile given Bug 1537667.

Flags: needinfo?(mozillamarcia.knous)

STR

  1. Open https://hg.mozilla.org/mozilla-central/pushloghtml
  2. Edit the range

Results:

The browser crashes

Has STR: --- → yes

Please test in a build with bug 1539391 fixed.

Flags: needinfo?(mozillamarcia.knous) → needinfo?(csheany)

Will do first thing with Nightly 67.0a1 (2019-03-28) :)

Are you able to reproduce with Nightly 67.0a1 (2019-03-27)?

Does it require enabling additional prefs?

Flags: needinfo?(csheany)

You just need to set layout.display-list.retain=true in order to test. Thanks.

Summary: (Android) Crash in @ RetainedDisplayListBuilder::MergeDisplayLists → (Android) Crash in @ RetainedDisplayListBuilder::MergeDisplayLists with layout.display-list.retain=true

If forgot to ask before and thought that might have been the cause.

Or it was too early as it is not the default yet.

Glad I reported it though.

layout.display-list.retain=true is ready for testing on android. Hopefully enabled by default soon.

Ironically ARM was late to the party but...

IT'S NOT CRASHING! :)

Status: NEW → RESOLVED
Closed: 5 years ago
Depends on: 1539391
Resolution: --- → FIXED

Thank you Timothy!

Assignee: nobody → tnikkel
Regressed by: 1537667
Target Milestone: --- → mozilla68
Keywords: regression
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.