"Redirection limit" error dialog should implicate cookie blocking

RESOLVED FIXED in mozilla1.3alpha

Status

()

Core
Networking: HTTP
P3
normal
RESOLVED FIXED
15 years ago
12 years ago

People

(Reporter: fouad murr, Assigned: Darin Fisher)

Tracking

Trunk
mozilla1.3alpha
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
sign into your hotmail e-mail account and try to change your password through
the options directory, you would find yourself in front of a translation error
with no apparent reason, where all tags are present instead of translated html.
Build ID ?
Do you see this with mozilla1.1b ?

Comment 2

15 years ago
Created attachment 96205 [details]
result of trying to change password

Received error while trying to change password or personal information on
hotmail

Comment 3

15 years ago
Well it's not the Mozilla's fault. Microsoft tries to make your day harder if
you do not follow what they want you to. One thing they want from you is to use
The Software. Mozilla unfortunately is not on the list. 
 You have to change your password in other browser (I do not know The List) or
switch to any other free mail account.

This bug is probably invalid.

PS. You may try to fool Hotmail using http://uabar.mozdev.org/ maybe this will
work? I think Multizilla has a way of changing your browser userAgent too.
Build 20020930/win2k

I have a different problem when I try to change my password.  I log into
Hotmail, go to Options, and click "Change Password" -- then I get the dialog box
"Redirection limit for this URL exceeded".  The same thing happens if I go
directly to www.passport.com and try to change the password.

is there a pref to change the redirection limit (what is the default)?  Might we
up the default a bit?

Networking: HTTP for the moment... maybe evagelism later? (haha)
Assignee: Matti → darin
Status: UNCONFIRMED → NEW
Component: Browser-General → Networking: HTTP
Ever confirmed: true
QA Contact: imajes-qa → httpqa
Summary: hotmail options- password managing -translation problem → cannot change Microsoft Passport password: redirection limit
(Assignee)

Comment 5

15 years ago
the limit has just been increased from 10 to 20 (on account of nytimes.com);
please try a newer build.  if you suspect 20 redirects is still insufficient,
then please try increasing the value of "network.http.redirection-limit"

the usual problem, however, is that you have too restrictive of a cookies
setting.  often a server will try to set a cookie along with a redirection.  if
the cookie is not set, then the server will try to set the cookie again via a
redirection.  this usually repeats until the browser's redirection limit is
reached.  so, please try this out with the default cookie preferences / a new
profile.
OK, I had inadvertantly blocked cookies from passport.net, and un-blocking them
fixed this problem.  Can we add a note to the dialog box: "This may be caused by
cookies that are blocked."
(Assignee)

Comment 7

15 years ago
that sounds like a great idea to me.. thx!
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: --- → mozilla1.3alpha
(Assignee)

Updated

15 years ago
Summary: cannot change Microsoft Passport password: redirection limit → "Redirection limit" error dialog should implicate cookie blocking
(Assignee)

Comment 8

15 years ago
Created attachment 107262 [details] [diff] [review]
patch: add "cookie blurb" to redirection error dialog
(Assignee)

Updated

15 years ago
Attachment #107262 - Flags: superreview?(rpotts)
Attachment #107262 - Flags: review?(adamlock)
(Assignee)

Comment 9

15 years ago
added testcase: http://unagi.mcom.com/cgi-bin/redirloop.cgi

this URL will fail to load w/ a redirection limit if unagi.mcom.com is prevented
from setting cookies.  here's what the contents of this CGI script looks like:

  #!/bin/sh
  if [ "x$HTTP_COOKIE" = "xx=1" ]; then
    echo 'content-type: text/plain'
    echo ''
    echo 'succeeded: '$HTTP_COOKIE
  else
    echo 'Status: 302 Temporary Redirect'
    echo 'Location: redirloop.cgi'
    echo 'Set-cookie: x=1'
    echo ''
  fi
(Assignee)

Updated

15 years ago
Keywords: nsbeta1, patch

Comment 10

15 years ago
Comment on attachment 107262 [details] [diff] [review]
patch: add "cookie blurb" to redirection error dialog

r=adamlock
Attachment #107262 - Flags: review?(adamlock) → review+

Comment 11

15 years ago
Comment on attachment 107262 [details] [diff] [review]
patch: add "cookie blurb" to redirection error dialog

sr=rpotts@netscape.com
Attachment #107262 - Flags: superreview?(rpotts) → superreview+
(Assignee)

Comment 12

15 years ago
fixed-on-trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 13

15 years ago
This fix is definitely going to help a lot of users not get stuck at a dead end,
but I wonder if there's a way to say specifically that a certain cookie is not
being accepted and may be the cause.  Just wondering....

Comment 14

15 years ago
V
Status: RESOLVED → VERIFIED
QA Contact: httpqa → junruh

Comment 15

15 years ago
REOPEN:

John, please put the platform and build you verified this on. Bugs 1700039 and
198415 suggest this error message is not working correctly.

Do we have a test case set up internally that forces this dialog to display?

I have seen a lot of bugs which discuss this re-direction problem, and people do
not report seeing this new, more descriptive error message.

Status: VERIFIED → REOPENED
Resolution: FIXED → ---

Comment 16

14 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 17

14 years ago
What if cookies can be reasonably eliminated from the equation?

I am accepting all cookies, i've deleted all my cookies, and can use cookies
jusr fine in any other case (in fact session vars are being stored there, and
those work swell.).

I am using:

Mozilla 1.3.1:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3.1) Gecko/20030425

In debian (woody) - everything updated yesterday.

this just started happening after upgrading from mozilla 1.0.0 yesterday

i am 99.8% sure it's not a cookie problem :/

Comment 18

14 years ago
never mind me :p

i just talked to the person developing the site and they found the problem was a
script getting stuck in a redirect loop, causeing this problem. please delete my
comments if possible.

sorry :(

Comment 19

14 years ago
RESOLVED/FIXED: back to where darin put it.
QA Contact: junruh → httpqa
Whiteboard: checkwin checklinux
Benc - did you mean to put this back to Resolved/Fixed?

Comment 21

14 years ago
RESOLVED:fixed
Yes, I should have changed the status.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago14 years ago
Resolution: --- → FIXED
Whiteboard: checkwin checklinux

Comment 22

12 years ago
I came here several weeks ago with a problem with the same bug, but on a
different URL. As I do a Google search on the Internet for: 

"Redirection limit for this URL exceeded. Unable to load the requested page.
This may be caused by cookies that are blocked." 

I see a lot of discussion going on. Apparently none of it is going on here. Now
all of a sudden I have another URL I cannot access. Again, this doesn't happen
with IE. Only Firefox. There appears to be no interest here for any solution. I
know this bug is mentioned somewhere else, but I can't find it, and I find this
reporting site very tedious. For example, I've "voted" for this bug three times,
but nothing has ever happened with that. I'm only asuming that voting for a bug
means the more votes the more attention the engineers would give it. I wonder
what will happen when 90% of the FireFox users will get the message that:
"Redirection limit for this URL exceeded. Unable to load the requested page.
This may be caused by cookies that are blocked." All I'm trying to do is visit
some web sites that are widely reachable by other browsers and people. I'm no
geek and find this overwhelming that I can't access several sites. The last one
was GG2.net which I was trying to access from Google News Page. ???

Here's another problem. The radio dial just below this comment box already has a
dot in the "Leave as RESOLVED FIXED."  Of course, I would un select that ... if
only I could. I'm blocked. So, really don't understand this reporting site or
its value. But what have I to lose? 

Dan
You need to log in before you can comment on or make changes to this bug.