Closed Bug 1538990 Opened 1 year ago Closed 1 year ago

clang-format pre-commit hook fails to "retrieve local files" when committing multiple files

Categories

(Firefox Build System :: Lint and Formatting, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1541409

People

(Reporter: myk, Unassigned)

Details

If I link .git/hooks/pre-commit to tools/lint/hooks_clang_format.py, as recommended by hg/git hooks for clang-format, and then try to commit changes to multiple files, I see an error like:

fatal: pathspec 'path/to/file1 path/to/file2 path/to/file3' did not match any files
Command to retrieve local files failed

Committing changes to a single file succeeds.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1541409
You need to log in before you can comment on or make changes to this bug.