Closed Bug 1539137 Opened 11 months ago Closed 11 months ago

Language settings Help doc link points to Webpage language settings Help doc

Categories

(Firefox :: Preferences, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Firefox 68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- wontfix
firefox67 + fixed
firefox68 --- verified

People

(Reporter: Tonnes, Assigned: mstriemer)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(1 file)

In FF 66, it looks like the Help button for the new Language settings dialog points to the same doc as the Webpage language settings Help button does, both resulting in https://support.mozilla.org/en-US/kb/choose-display-languages-multilingual-web-pages.

The problem may be here: https://searchfox.org/mozilla-central/source/browser/components/preferences/browserLanguages.xul#20

See bug 1485779 for the proper link.

https://support.mozilla.org/en-US/kb/use-firefox-another-language

It take that value should be 'use-firefox-another-language' (I haven't tried), and it might be a good-first-bug.

[Tracking Requested - why for this release]:
Bad UI that should be easy to fix in time for 67.

This has been broken since the original implementation in bug 1469688.

(In reply to Francesco Lodolo [:flod] from comment #1)

https://support.mozilla.org/en-US/kb/use-firefox-another-language

It take that value should be 'use-firefox-another-language' (I haven't tried), and it might be a good-first-bug.

This doesn't work, we need a public redirect URL for this page that we can plug into the language-specific SUMO URLs we generate from app.support.baseURL (ie https://support.mozilla.org/1/firefox/%VERSION%/%OS%/%LOCALE%/ + "suffix" ) which normally entails asking someone from SUMO.

Mark, is there an existing redirect slug in place for the use-firefox-another-language page that you're aware of? If not, we should ping Joni.

Blocks: 1469688
Flags: needinfo?(mstriemer)
Priority: -- → P2

Joni, can you generate a slug for the https://support.mozilla.org/en-US/kb/use-firefox-another-language page or let me know what was already generated? I don't see one in bug 1485779 where we were tracking this SUMO page.

Looks like we were going to use the same page for both, but they're on different pages. Once we have the slug we can link to this one directly.

Flags: needinfo?(mstriemer) → needinfo?(jsavage)

Sure, Mark. There wasn't an in-product slug yet so here's a new slug you can use: https://support.mozilla.org/1/firefox/%VERSION%/%OS%/%LOCALE%/change-language

Flags: needinfo?(jsavage)
Pushed by flodolo@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/25f585dc1f7f
Fix help link in browser languages dialog r=Gijs
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Assignee: nobody → mstriemer

Verified on 68.0a1 (2019-04-04) (64 bit)

Status: RESOLVED → VERIFIED

Comment on attachment 9055595 [details]
Bug 1539137 - Fix help link in browser languages dialog r?Gijs

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: None
  • User impact if declined: Link to SUMO for the language-switcher feature points to the wrong documentation
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Just correcting an existing link
  • String changes made/needed: none
Attachment #9055595 - Flags: approval-mozilla-beta?

Comment on attachment 9055595 [details]
Bug 1539137 - Fix help link in browser languages dialog r?Gijs

Trivial fix for a SUMO link, verified on Nightly, uplift approved for 67 beta 9, thanks.

Attachment #9055595 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify-
You need to log in before you can comment on or make changes to this bug.