Closed Bug 1539156 Opened 8 months ago Closed 8 months ago

Address barr autofilling 192.0.0.0 when typing IP addresses

Categories

(Firefox :: Address Bar, defect)

66 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1537640

People

(Reporter: kyles, Unassigned)

Details

Attachments

(1 file)

Attached image FFAutofill.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

When typing an IP address in the address bar, Firefox will fill in (not suggest, but actually enter) 0.0.0. It seems to trigger when I get to "https://192." and makes the address 192.0.0.0.

Deleting the added octets and typing again results in it happening again, but if I fill in another number in the second octet before erasing the 0s it won't happen again.

Actual results:

It makes browsing to local network equipment a PITA. It's been happening for a couple weeks.

Expected results:

Suggesting it would be fine, and I could ignore it, but it shouldn't actually enter the data so that I have to clear it out

Also, it only happens on https:// addresses, just entering 192. does not trigger it.

And I have no bookmarks or history for 192.0.0.0

Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago
Component: Untriaged → Address Bar
Resolution: --- → DUPLICATE
Duplicate of bug: 1537640
You need to log in before you can comment on or make changes to this bug.