Closed Bug 1539166 Opened 5 months ago Closed 5 months ago

Use shared ping scheduler logic in TelemetryController

Categories

(Toolkit :: Telemetry, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: gfritzsche, Assigned: janerik)

References

Details

Attachments

(7 files)

We now introduced a ~daily schedule logic for main pings, ecosystem pings & prio pings.

Can we move TelemetrySessions scheduler to TelemetryController and use it to drive all 3 pings?
That would give us shared scheduling logic.

Jan-Erik, would this fit into this iteration on your end?
I think it would be good to get this out of the way to enable a good start into Q2.

Flags: needinfo?(jrediger)
Priority: -- → P1
Assignee: nobody → jrediger
Flags: needinfo?(jrediger)

This is in preparation for further logic refactoring in later commits.

Depends on D26147

Depends on D26148

This is only called on environment-changed pings.
We avoid re-setting the scheduler timeout, so that we can trigger other
pings at regular intervals unrelated to main pings.
This will not cause the daily ping to be sent more often, at worst we
schedule something once too frequently.

Depends on D26149

Depends on D26152

Attachment #9055857 - Attachment description: Bug 1539166 - Allow other regular pings to be sent at regular intervals → Bug 1539166 - Allow other periodic pings to be sent at regular intervals
Blocks: 1542305
Pushed by jrediger@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2c0325bf2543
Refactor the session scheduler into its own module r=chutten
https://hg.mozilla.org/integration/autoland/rev/e66a133f9624
Remove expired probes from scheduler r=chutten
https://hg.mozilla.org/integration/autoland/rev/19caa11e5eb7
Remove unused variables r=chutten
https://hg.mozilla.org/integration/autoland/rev/50ada71796e4
Simplify daily ping reschedule r=chutten
https://hg.mozilla.org/integration/autoland/rev/5bac63a7f021
Allow other periodic pings to be sent at regular intervals r=chutten
https://hg.mozilla.org/integration/autoland/rev/42c3f90105c1
Trigger periodic ecosystem ping once a day r=chutten
https://hg.mozilla.org/integration/autoland/rev/16819d232d4d
Trigger periodic prio ping once a day r=chutten
Duplicate of this bug: 1535336
Summary: Consider shared ping scheduler logic in TelemetryController → Use shared ping scheduler logic in TelemetryController
You need to log in before you can comment on or make changes to this bug.