Browser crashes when User tries to set avatar image with Camera option.

VERIFIED FIXED in Firefox 67

Status

()

defect
--
major
VERIFIED FIXED
4 months ago
2 months ago

People

(Reporter: lqueirolo, Assigned: dminor)

Tracking

Trunk
mozilla68
Desktop
Windows 10
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 wontfix, firefox67 verified, firefox68 verified)

Details

(crash signature)

Attachments

(2 attachments)

Note

  • Tested on a laptop Lenovo with integrated camera.

Affected versions

  • 68 Nightly (2019-03-26)

Affected platforms

  • Windows 10

Steps to reproduce

  1. Click on Avatar icon.
  2. When expanded, click on image icon.
  3. Select Camera option.

Expected result

  • User is able to set an avatar image using camera option.

Actual result

  • Browser crashes when User tries to set avatar image with Camera option.
Crash Signature: [@ nsSSLStatus::~nsSSLStatus ]
Blocks: 1524665

This bug was first reported on Github, here's the link to the issue. https://github.com/mozilla/fxa-content-server/issues/6905

Can you link to a crashreport from crash-stats please?

Flags: needinfo?(lqueirolo)

If this is the Lenovo arm64 device, what nightly are you running - arm64 or 32-bit x86?

FWIW, using an arm64 build, I get a "Could not initialize camera" error on the fxa page. It seems it can't find the camera on the device?

A crash-stats report link would be super helpful. :-)

Dana, does this look to be the same as bug 1509654, or the sec-bug it duplicates?

Component: Sync → Security: PSM
Product: Firefox → Core

Those bugs had to do with going from a recent version of Firefox to an older one, which I gather isn't what's going on here, so this might be a separate issue.

Hi Gijs,

Adding the Crash stats:
https://crash-stats.mozilla.org/report/index/265eb7f1-4af9-42a0-96ed-f62e00190326

Please let me know if you need anything more,

Flags: needinfo?(lqueirolo)

What exact machine are you seeing this on, Luciana?

:dminor, based on bug 1524208, is there specific info that could help working out what's going on here?

Flags: needinfo?(lqueirolo)
Flags: needinfo?(dminor)

(In reply to :Gijs (he/him) from comment #3)

If this is the Lenovo arm64 device, what nightly are you running - arm64 or 32-bit x86?

FWIW, using an arm64 build, I get a "Could not initialize camera" error on the fxa page. It seems it can't find the camera on the device?

The Camera is disabled unless you are running the 19h1 preview or later version of Windows 10. I'm not sure if those are released yet, I opted into developer preview builds on my arm64 laptop to be able to test with the camera.

Sure,

I'm testing on a Lenovo T470 laptop with integrated camera, Win 10 Pro x64, OS version 17134.590
I used a new profile on the Nightly version for this test run and as soon as I click on "Allow" camera button the browser crashes.

Hope this helps

Flags: needinfo?(lqueirolo)

(In reply to :Gijs (he/him) from comment #7)

What exact machine are you seeing this on, Luciana?

:dminor, based on bug 1524208, is there specific info that could help working out what's going on here?

I'm missing a bit of context, where do you find the avatar icon and what does it look like? I want to see if I can reproduce this on my w540, although I haven't had any luck with bug 1524208 so far.

Flags: needinfo?(dminor)

(In reply to Luciana queirolo from comment #6)

Hi Gijs,

Adding the Crash stats:
https://crash-stats.mozilla.org/report/index/265eb7f1-4af9-42a0-96ed-f62e00190326

Looks like this is in webrtc.

Crash Signature: [@ nsSSLStatus::~nsSSLStatus ] → [@ RGB24ToARGBRow_SSSE3 ]
Component: Security: PSM → WebRTC

(In reply to Dan Minor [:dminor] from comment #10)

(In reply to :Gijs (he/him) from comment #7)

What exact machine are you seeing this on, Luciana?

:dminor, based on bug 1524208, is there specific info that could help working out what's going on here?

I'm missing a bit of context, where do you find the avatar icon and what does it look like?

It's the firefox account button, there in recent nightlies, next to the hamburger button. If you've removed it or whatever, I imagine the same is reproducible by opening the prefs/options, go to the sync section, click "manage account" (when signed in) and altering the avatar using the camera option per comment #0. The actual code for that lives on https://accounts.firefox.com/ and just uses webrtc getUserMedia to access the camera, afaict.

I want to see if I can reproduce this on my w540, although I haven't had any luck with bug 1524208 so far.

Yeah... Luciana, is this 100% reproducible for you? Crashes every time?

Flags: needinfo?(lqueirolo)
Flags: needinfo?(dminor)

Hi Gijs,

Yes this issue occurs every time I try to use the camera, it crashes every time.

Severity: normal → major
Flags: needinfo?(lqueirolo)
Assignee: nobody → dminor
Status: NEW → ASSIGNED
Flags: needinfo?(dminor)

(In reply to Luciana queirolo from comment #13)

Hi Gijs,

Yes this issue occurs every time I try to use the camera, it crashes every time.

Unfortunately it does not reproduce for me, but that is not surprising as it almost certainly depends upon what kind of camera is being used. If it is ok, I'd like to prepare a build with some extra debugging information in the camera and video capture code for you to try. This would help track down the problem.

Hi all,

Tried using the integrated camera on https://www.onlinemictest.com/webcam-test/ as Vijay requested, but the browser crash as well.

Hi Luciana,

Could you please try the Firefox build from here:
winx64 build: https://queue.taskcluster.net/v1/task/HJJZMhQsQb61V2OATlO4cg/runs/0/artifacts/public/build/target.zip
try job: https://treeherder.mozilla.org/#/jobs?repo=try&revision=83df40ca24b5b2fd02db86248acbabab4d7d0ea5&selectedJob=236457451

In the console there will be an output line starting with ">>>>" which contains info on the video type, width, height and rotation applied to the image coming from your camera. You might only get one line before Firefox crashes. If you could paste that output into a comment here that would be very helpful in figuring out what is going wrong. Thank you!

Flags: needinfo?(lqueirolo)

This try job has a potential workaround for the problem: https://treeherder.mozilla.org/#/jobs?repo=try&revision=bc5383f9d075dec4cf739d16778d6f456acb1220. It would be great if you could try it as well.

Hi

Tried on both builds, in the first one it crashed too quickly to get the console, but on the second one I was able to use the camera! yay!

Thanks!

Flags: needinfo?(lqueirolo)

We've hit a number of problems with handling of RGB24 video capture on
Windows. This adds a check that will ignore any RGB24 capture capabilities
when determining a best match if there are other capabilities available to
workaround the problems.

This is just a workaround, but with the volume of crashes we're seeing I think it is worth putting in place while we continue to investigate the underlying issue. I'm hopeful it will also workaround Bug 1533597 as that is also using RGB24 video capture on Windows.

Pushed by dminor@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c12307f3817b
Prefer non-RGB24 capabilities when available; r=pehrsons
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Comment on attachment 9054571 [details]
Bug 1539220 - Prefer non-RGB24 capabilities when available; r=pehrsons

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: None
  • User impact if declined: For users with affected cameras, this crashes 100% of the time making the camera unusable in Firefox.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This changes the capability selection code to prefer non-RGB24 capabilities, but those will still be used if there are no other choices. The only downside I can see is if the RGB24 capability for some reason supported a higher resolution in which case the user may be stuck with lower resolution video. That does not seem to be the case with any of the cameras tested so far.
  • String changes made/needed: None
Attachment #9054571 - Flags: approval-mozilla-beta?

Comment on attachment 9054571 [details]
Bug 1539220 - Prefer non-RGB24 capabilities when available; r=pehrsons

Low risk patch preventing crashes when using some camera devices in Firefox, medium number of crashes on beta and release, uplift approved to 67 beta 8.

Luciana could you test again when the patch is in beta if it crashes for you? Thanks

Flags: needinfo?(lqueirolo)
Attachment #9054571 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 1541871
QA Whiteboard: [qa-triaged]

Hi Pascal,

I tried reproducing the bug on the latest Nightly 68.0a1 (2019-04-05) and I couldn't, it wont' crash but now there's an error message on the pop up, I'll share a screenshot for that.

Posted image CAMERA ERROR.PNG
Flags: needinfo?(lqueirolo) → needinfo?(dminor)

Hi Luciana,

Does the camera work on this page: https://mozilla.github.io/webrtc-landing/gum_test.html (if you select Video)?

Flags: needinfo?(dminor) → needinfo?(lqueirolo)

Is this really only going to get fixed in 67? And is this only due May 14th!?!? Is there any workaround at all in 66?

I had logged a bug https://bugzilla.mozilla.org/show_bug.cgi?id=1541620 which got closed as a duplicate of this one but frankly the bug I logged is not trivial or low risk. My company wants to launch a new version of our platform that will use WebRTC for the first time and if a simple tech check of a user's integrated webcam causes Firefox to crash this is a huge problem for us!

I can consistently reproduce this bug, go to any generic WebRTC test page like Mozilla's own https://mozilla.github.io/webrtc-landing/ and try to test your webcam...total Firefox 66 crash. (Note Firefox Nightly does not have this problem)

If any point release to fix this can be released much, much sooner than May 14th it would really be a better approach.

Thanks!

I know Dan Minor didn't ask me, but I tried what he suggested and while I don't get a crash when I go to https://mozilla.github.io/webrtc-landing/gum_test.html (and select Video) I do get an error which I will upload a screenshot of now...

Aaaah - how do I upload an image?!?!?!?!

Please correct me if I'm wrong, but it sounds like the camera worked properly when this patch first landed but has subsequently stopped working again, except we now see an error, not a crash. I asked Luciana to test the webrtc-landing page to make sure this was a problem with the camera, and not something that had broken in the Firefox accounts code.

We need someone who can reproduce this problem to run a mozregression (https://mozilla.github.io/mozregression/) starting from commit c12307f3817b and going to today. This will verify that the camera did work properly when the workaround here first landed and then determine the commit that subsequently caused the error to occur.

We should file a new bug (WebRTC: Audio/Video) with the results from the mozregression. This problem only shows up for certain webcams. It does not reproduce with any of the cameras that I own, so I'm not able to investigate this further without additional information.

Hi Dan,

Tested on https://mozilla.github.io/webrtc-landing/gum_test.html on Nightly 68.0a1 (2019-04-07)and I was able to use the integrated camera with no problems
:)

Flags: needinfo?(lqueirolo) → needinfo?(dminor)

(In reply to Luciana queirolo from comment #34)

Hi Dan,

Tested on https://mozilla.github.io/webrtc-landing/gum_test.html on Nightly 68.0a1 (2019-04-07)and I was able to use the integrated camera with no problems
:)

If that page is working and the avatar image is not, it would be great if you could file a new bug as it sounds like we've hit a different problem. Thanks for your help testing this!

Flags: needinfo?(dminor)

(In reply to gareth.lloyd@americanwell.com from comment #30)

Is this really only going to get fixed in 67? And is this only due May 14th!?!? Is there any workaround at all in 66?

Hi Gareth, I can request that this be considered for a point release for Firefox 66, but before I do that we need to very certain that this does fix in fact fix the bug without introducing any new bugs. The fact that gum_test.html was broken for you last week but is working for Luciana this morning is worrisome.

(In reply to Dan Minor [:dminor] from comment #36)

(In reply to gareth.lloyd@americanwell.com from comment #30)

Is this really only going to get fixed in 67? And is this only due May 14th!?!? Is there any workaround at all in 66?

Hi Gareth, I can request that this be considered for a point release for Firefox 66, but before I do that we need to very certain that this does fix in fact fix the bug without introducing any new bugs. The fact that gum_test.html was broken for you last week but is working for Luciana this morning is worrisome.

Thanks Dan, let me know if there is any possible thing I can do to assist, as this is very urgent for us. I just tried the gun_test.html again this morning and it crashed again. Details from the crash are:

AdapterDeviceID: 0x5917
AdapterDriverVersion: 23.20.16.5017
AdapterSubsysID: 225817aa
AdapterVendorID: 0x8086
Add-ons: fxmonitor%40mozilla.org:2.8,formautofill%40mozilla.org:1.0,screenshots%40mozilla.org:35.0.0,webcompat%40mozilla.org:3.0.2,fpdlpffext%40forcepoint.com:8.5.2801.44
AvailablePageFile: 9033547776
AvailablePhysicalMemory: 1462571008
AvailableVirtualMemory: 138531747692544
BIOS_Manufacturer: LENOVO
BlockedDllList: 
BreakpadReserveAddress: 1974958882816
BreakpadReserveSize: 83886080
BuildID: 20190326175229
CPUMicrocodeVersion: 0x96
ContentSandboxCapable: 1
ContentSandboxLevel: 5
CrashTime: 1554729805
DOMIPCEnabled: 1
Email: gareth.lloyd@americanwell.com
EventLoopNestingLevel: 1
FramePoisonBase: 9223372036600889344
FramePoisonSize: 65536
GPUProcessLaunchCount: 1
GPUProcessStatus: Running
GraphicsCriticalError: |[0][GFX1-]: WMF VPX video decoding is disabled due to a previous crash. (t=328.413) 
InstallTime: 1554141561
MemoryErrorCorrection: None
ModuleSignatureInfo: {"Malwarebytes Corporation":["mbae64.dll"],"Microsoft Corporation":["api-ms-win-crt-runtime-l1-1-0.dll","api-ms-win-crt-string-l1-1-0.dll","api-ms-win-crt-heap-l1-1-0.dll","api-ms-win-crt-stdio-l1-1-0.dll","api-ms-win-crt-convert-l1-1-0.dll","api-ms-win-crt-locale-l1-1-0.dll","api-ms-win-crt-math-l1-1-0.dll","api-ms-win-crt-time-l1-1-0.dll","api-ms-win-crt-filesystem-l1-1-0.dll","api-ms-win-crt-environment-l1-1-0.dll","api-ms-win-crt-utility-l1-1-0.dll","api-ms-win-crt-multibyte-l1-1-0.dll","msvcr110.dll","msvcp110.dll","FileSyncShell64.dll","msvcp140.dll","VCRUNTIME140.dll"],"Microsoft Windows":["ole32.dll","crypt32.dll","wintrust.dll","oleaut32.dll","clbcatq.dll","OneCoreUAPCommonProxyStub.dll","coml2.dll","MFReadWrite.dll","mfc42.dll","quartz.dll","mfcore.dll","ksproxy.ax","mf.dll","MFSENSORGROUP.dll","FSClient.dll","dlnashext.dll","d3d9.dll","evr.dll","wscapi.dll","tiptsf.dll","duser.dll","dui70.dll","Kswdmcap.ax","devenum.dll","atlthunk.dll","dxva2.dll","ntshrui.dll","thumbcache.dll","explorerframe.dll","dataexchange.dll","twinapi.dll","cldapi.dll","edputil.dll","OneCoreCommonProxyStub.dll","mscms.dll","ktmw32.dll","linkinfo.dll","credui.dll","PhotoMetadataHandler.dll","ColorAdapterClient.dll","usp10.dll","DevDispItemProvider.dll","cscapi.dll","DWrite.dll","EhStorShell.dll","NetworkExplorer.dll","ondemandconnroutehelper.dll","InputHost.dll","TextInputFramework.dll","Windows.UI.dll","mfksproxy.dll","winrnr.dll","StructuredQuery.dll","pnrpnsp.dll","NapiNSP.dll","AudioSes.dll","mpr.dll","wininet.dll","dbgcore.dll","CoreUIComponents.dll","WindowsCodecs.dll","webauthn.dll","comctl32.dll","oleacc.dll","srvcli.dll","dcomp.dll","wsock32.dll","CoreMessaging.dll","apphelp.dll","WINMMBASE.dll","winmm.dll","version.dll","iertutil.dll","urlmon.dll","MMDevAPI.dll","rasadhlp.dll","vidcap.ax","davhlpr.dll","davclnt.dll","ntlanman.dll","drprov.dll","msdmo.dll","ksuser.dll","cscui.dll","avrt.dll","RTWorkQ.dll","mfplat.dll","d3d11.dll","WinTypes.dll","wkscli.dll","msvcp110_win.dll","policymanager.dll","nlaapi.dll","xmllite.dll","atl.dll","dhcpcsvc.dll","FWPUCLNT.DLL","dhcpcsvc6.DLL","winnsi.dll","winhttp.dll","propsys.dll","uxtheme.dll","dwmapi.dll","rmclient.dll","twinapi.appcore.dll","dxgi.dll","dbghelp.dll","wtsapi32.dll","ntmarta.dll","winsta.dll","rsaenh.dll","IPHLPAPI.DLL","dnsapi.dll","netutils.dll","mswsock.dll","cryptsp.dll","CRYPTBASE.DLL","bcrypt.dll","devobj.dll","sxs.dll","sspicli.dll","userenv.dll","profapi.dll","fltLib.dll","kernel.appcore.dll","powrprof.dll","msasn1.dll","msvcp_win.dll","win32u.dll","bcryptPrimitives.dll","KERNELBASE.dll","ucrtbase.dll","gdi32full.dll","cfgmgr32.dll","windows.storage.dll","shell32.dll","imagehlp.dll","user32.dll","advapi32.dll","rpcrt4.dll","psapi.dll","combase.dll","shlwapi.dll","msctf.dll","kernel32.dll","sechost.dll","nsi.dll","imm32.dll","ws2_32.dll","gdi32.dll","SHCore.dll","comdlg32.dll","msvcrt.dll","setupapi.dll","ntdll.dll"],"Mozilla Corporation":["firefox.exe","xul.dll","mozavcodec.dll","nss3.dll","mozavutil.dll","nssckbi.dll","freebl3.dll","softokn3.dll","mozglue.dll","lgpllibs.dll"],"Symantec Corporation":["ccLib.dll","IPSEng64.dll","sysfer.dll"],"Websense, Inc.":["QIPCAP64.dll","QIPOverlay.dll"]}
Notes: FP(D00-L1000-W00001000-T000) 
DWrite? DWrite+ WR? WR- OMTP? OMTP+4 
ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
ProductName: Firefox
ReleaseChannel: release
SafeMode: 0
SecondsSinceLastCrash: 74748
StartupCrash: 0
StartupTime: 1554655069
SystemMemoryUsePercentage: 82
TelemetryEnvironment: {"build":{"applicationId":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","applicationName":"Firefox","architecture":"x86-64","buildId":"20190326175229","version":"66.0.2","vendor":"Mozilla","displayVersion":"66.0.2","platformVersion":"66.0.2","xpcomAbi":"x86_64-msvc","updaterAvailable":true},"partner":{"distributionId":null,"distributionVersion":null,"partnerId":null,"distributor":null,"distributorChannel":null,"partnerNames":[]},"system":{"memoryMB":8030,"virtualMaxMB":134217728,"cpu":{"count":8,"cores":4,"vendor":"GenuineIntel","family":6,"model":142,"stepping":10,"l2cacheKB":256,"l3cacheKB":6144,"speedMHz":1896,"extensions":["hasMMX","hasSSE","hasSSE2","hasSSE3","hasSSSE3","hasSSE4_1","hasSSE4_2","hasAVX","hasAVX2","hasAES"]},"os":{"name":"Windows_NT","version":"10.0","locale":"en-US","servicePackMajor":0,"servicePackMinor":0,"windowsBuildNumber":17134,"windowsUBR":648,"installYear":2019},"hdd":{"profile":{"model":"SAMSUNG MZVLW256HEHP-000L7","revision":"5L7QCXB7"},"binary":{"model":"SAMSUNG MZVLW256HEHP-000L7","revision":"5L7QCXB7"},"system":{"model":"SAMSUNG MZVLW256HEHP-000L7","revision":"5L7QCXB7"}},"gfx":{"D2DEnabled":true,"DWriteEnabled":true,"ContentBackend":"Skia","LowEndMachine":false,"adapters":[{"description":"Intel(R) UHD Graphics 620","vendorID":"0x8086","deviceID":"0x5917","subsysID":"225817aa","RAM":null,"driver":"igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32","driverVersion":"23.20.16.5017","driverDate":"3-27-2018","GPUActive":true}],"monitors":[{"screenWidth":1920,"screenHeight":1080,"refreshRate":60,"pseudoDisplay":false},{"screenWidth":1920,"screenHeight":1080,"refreshRate":59,"pseudoDisplay":false}],"features":{"compositor":"d3d11","gpuProcess":{"status":"available"},"wrQualified":{"status":"blocked"},"webrender":{"status":"opt-in"},"advancedLayers":{"status":"available"},"d3d11":{"status":"available","version":45312,"warp":false,"textureSharing":true,"blacklisted":false},"d2d":{"status":"available","version":"1.1"}}},"appleModelId":null,"isWow64":false,"sec":{"antivirus":["Symantec Endpoint Protection"],"antispyware":null,"firewall":["Symantec Endpoint Protection"]}},"settings":{"blocklistEnabled":true,"e10sEnabled":true,"e10sMultiProcesses":8,"telemetryEnabled":false,"locale":"en-US","intl":{"requestedLocales":["en-US"],"availableLocales":["en-US"],"appLocales":["en-US"],"systemLocales":["en-US"],"regionalPrefsLocales":["en-US"],"acceptLanguages":["en-US","en"]},"update":{"channel":"release","enabled":true,"autoDownload":true},"userPrefs":{"browser.cache.disk.capacity":1048576,"browser.newtabpage.enabled":false,"browser.shell.checkDefaultBrowser":false,"browser.search.region":"US","browser.search.widget.inNavBar":false,"browser.startup.homepage":"<user-set>","browser.startup.page":3,"devtools.debugger.remote-enabled":true,"general.config.filename":"<set>"},"sandbox":{"effectiveContentProcessLevel":5},"addonCompatibilityCheckEnabled":true,"isDefaultBrowser":false,"attribution":{"campaign":"whatsnew","content":"%2528not%2Bset%2529","medium":"firefox-browser","source":"firefox-browser"},"defaultSearchEngine":"google-b-1-d","defaultSearchEngineData":{"name":"Google","loadPath":"jar:[app]/omni.ja!/google-b-1-d.xml","origin":"default","submissionURL":"https://www.google.com/search?client=firefox-b-1-d&q="},"searchCohort":"nov17-2"},"profile":{"creationDate":17987,"firstUseDate":17987},"addons":{"activeAddons":{"formautofill@mozilla.org":{"version":"1.0","scope":1,"type":"extension","updateDay":17981,"isSystem":true,"isWebExtension":true,"multiprocessCompatible":true,"blocklisted":false,"description":null,"name":"Form Autofill","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17981},"screenshots@mozilla.org":{"version":"35.0.0","scope":1,"type":"extension","updateDay":17981,"isSystem":true,"isWebExtension":true,"multiprocessCompatible":true,"blocklisted":false,"description":"Take clips and screenshots from the Web and save them temporarily or permanently.","name":"Firefox Screenshots","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17981},"webcompat@mozilla.org":{"version":"3.0.2","scope":1,"type":"extension","updateDay":17981,"isSystem":true,"isWebExtension":true,"multiprocessCompatible":true,"blocklisted":false,"description":"Urgent post-release fixes for web compatibility.","name":"Web Compat","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17981},"fxmonitor@mozilla.org":{"version":"2.8","scope":1,"type":"extension","updateDay":17987,"isSystem":true,"isWebExtension":true,"multiprocessCompatible":true,"blocklisted":false,"description":null,"name":"Firefox Monitor","userDisabled":false,"appDisabled":false,"foreignInstall":false,"hasBinaryComponents":false,"installDay":17987,"signedState":3},"fpdlpffext@forcepoint.com":{"version":"8.5.2801.44","scope":8,"type":"extension","updateDay":17549,"isSystem":false,"isWebExtension":true,"multiprocessCompatible":true,"blocklisted":false,"description":"Forcepoint Endpoint Firefox Extension.","name":"Forcepoint Endpoint","userDisabled":false,"appDisabled":false,"foreignInstall":true,"hasBinaryComponents":false,"installDay":17549,"signedState":2}},"theme":{"id":"default-theme@mozilla.org","blocklisted":false,"description":"A theme with the operating system color scheme.","name":"Default","userDisabled":false,"appDisabled":false,"version":"","scope":1,"foreignInstall":false,"hasBinaryComponents":false,"installDay":0,"updateDay":0},"activePlugins":[],"activeGMPlugins":{"gmp-gmpopenh264":{"version":"1.7.1","userDisabled":false,"applyBackgroundUpdates":1},"gmp-widevinecdm":{"version":"4.10.1146.0","userDisabled":false,"applyBackgroundUpdates":1}},"persona":"default-theme@mozilla.org"},"experiments":{"searchCohort":{"branch":"nov17-2"},"pref-rollout-block-autoplay-release-66-1535667":{"branch":"active","type":"normandy-prefrollout"},"rollout-monitor-v2-1505837":{"branch":"active","type":"normandy-prefrollout"},"prefflip-push-performance-1491171":{"branch":"enabled","type":"normandy-exp"}}}
ThreadIdNameMapping: 16492:"Gecko_IOThread",12632:"JS Watchdog",10476:"JS Helper",15076:"JS Helper",3540:"JS Helper",20172:"JS Helper",7092:"JS Helper",5356:"JS Helper",13700:"JS Helper",15304:"JS Helper",12348:"Timer",15852:"Link Monitor",19676:"Socket Thread",11020:"IPDL Background",13108:"VsyncIOThread",16208:"WindowsVsyncThread",13252:"Compositor",9520:"ImgDecoder #1",832:"ImageIO",17532:"Cache2 I/O",13660:"Cookie",14368:"GMPThread",1420:"Worker Launcher",20348:"DOM Worker",6944:"HTML5 Parser",14804:"StyleThread#1",12096:"StyleThread#0",11492:"StyleThread#2",13428:"StyleThread#4",1912:"StyleThread#3",10128:"StyleThread#5",6536:"ImageBridgeChild",3684:"ProcessHangMon",19164:"ImgDecoder #2",2620:"DataStorage",17536:"Cache I/O",17988:"URL Classifier",11136:"Classifier Update",18900:"DOM Worker",11476:"localStorage DB",20272:"QuotaManager IO",17636:"mozStorage #1",15384:"mozStorage #2",13056:"DOM Worker",16824:"COM MTA",7400:"SaveScripts",736:"mozStorage #3",14644:"mozStorage #4",9204:"mozStorage #5",10664:"mozStorage #6",10884:"mozStorage #7",11392:"DNS Resolver #223",9516:"DNS Resolver #227",19632:"DNS Resolver #229",21828:"ProxyResolution",22652:"DOM Worker",4672:"DNS Resolver #231",15692:"DNS Resolver #232",21100:"SSL Cert #153",676:"VideoCapture",22356:"StreamTrans #900",
Throttleable: 1
TotalPageFile: 19157524480
TotalPhysicalMemory: 8420106240
TotalVirtualMemory: 140737488224256
URL: https://mozilla.github.io/webrtc-landing/gum_test.html
UptimeTS: 138377.334017708
User32BeforeBlocklist: 1
Vendor: Mozilla
Version: 66.0.2
Winsock_LSP: AF_UNIX : 2 : 1 : 1 : 0 : 0x20026 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : a00943d9-9c2e-4633-9b59-0057a3160994 
 MSAFD Tcpip [TCP/IP] : 2 : 2 : 1 : 6 : 0x20066 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : e70f1aa0-ab8b-11cf-8ca3-00805f48a192 
 MSAFD Tcpip [UDP/IP] : 2 : 2 : 2 : 17 : 0x20609 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : e70f1aa0-ab8b-11cf-8ca3-00805f48a192 
 MSAFD Tcpip [RAW/IP] : 2 : 2 : 3 : 0 : 0x20609 : 0xc : %SystemRoot%\system32\mswsock.dll :  : e70f1aa0-ab8b-11cf-8ca3-00805f48a192 
 MSAFD Tcpip [TCP/IPv6] : 2 : 23 : 1 : 6 : 0x20066 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : f9eab0c0-26d4-11d0-bbbf-00aa006c34e4 
 MSAFD Tcpip [UDP/IPv6] : 2 : 23 : 2 : 17 : 0x20609 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : f9eab0c0-26d4-11d0-bbbf-00aa006c34e4 
 MSAFD Tcpip [RAW/IPv6] : 2 : 23 : 3 : 0 : 0x20609 : 0xc : %SystemRoot%\system32\mswsock.dll :  : f9eab0c0-26d4-11d0-bbbf-00aa006c34e4 
 RSVP TCPv6 Service Provider : 2 : 23 : 1 : 6 : 0x22066 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : 9d60a9e0-337a-11d0-bd88-0000c082e69a 
 RSVP TCP Service Provider : 2 : 2 : 1 : 6 : 0x22066 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : 9d60a9e0-337a-11d0-bd88-0000c082e69a 
 RSVP UDPv6 Service Provider : 2 : 23 : 2 : 17 : 0x22609 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : 9d60a9e0-337a-11d0-bd88-0000c082e69a 
 RSVP UDP Service Provider : 2 : 2 : 2 : 17 : 0x22609 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : 9d60a9e0-337a-11d0-bd88-0000c082e69a 
 Hyper-V RAW : 2 : 34 : 1 : 1 : 0x20026 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : 1234191b-4bf7-4ca7-86e0-dfd7c32b5445 
 MSAFD Irda [IrDA] : 2 : 26 : 1 : 1 : 0x20006 : 0x8 : %SystemRoot%\system32\mswsock.dll :  : 3972523d-2af1-11d1-b655-00805f3642cc
useragent_locale: en-US

This report also contains technical information about the state of the application when it crashed.

Hi Gareth, your crash is for Firefox 66.0.2 which does not have the fix from this bug applied to it yet.

Thanks for your attention here Dan. If this cannot be fixed in a patch/point release before May 14th release of 67, do you know if there is anything we can do from a dev perspective to work around this issue?

(In reply to gareth.lloyd@americanwell.com from comment #39)

Thanks for your attention here Dan. If this cannot be fixed in a patch/point release before May 14th release of 67, do you know if there is anything we can do from a dev perspective to work around this issue?

One thing you could try is setting different height, width and frameRate constraints when you are calling getUserMedia. That might get the camera capture code to choose a different capture format and work around the crash.

Will try and get back to you, thank you Dan!

Senior developers don't want to try any workarounds I'm afraid, they need a patch release of Firefox or we will just have to wait for 67.

Hi, I will mark this as Verified Fixed based on the fact that I can't reproduce the crash, but I also logged a new issue because I have a error message when I'm following the same steps from the description, you can see bug 1543194.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
See Also: → 1543069
See Also: 1543069
Duplicate of this bug: 1540165

Does anyone know when FF 67 is going to be released!? It was supposed to be May 14th but it's still not out... This problem is supposed to be fixed in 67...

(In reply to gareth lloyd from comment #45)

Does anyone know when FF 67 is going to be released!? It was supposed to be May 14th but it's still not out... This problem is supposed to be fixed in 67...

It has been delayed until the 21st.

(In reply to Dan Minor [:dminor] from comment #46)

(In reply to gareth lloyd from comment #45)

Does anyone know when FF 67 is going to be released!? It was supposed to be May 14th but it's still not out... This problem is supposed to be fixed in 67...

It has been delayed until the 21st.

OK thanks :dminor

You need to log in before you can comment on or make changes to this bug.