Closed Bug 1539255 Opened 1 year ago Closed 1 year ago

Back out new tab animations

Categories

(Firefox :: Theme, enhancement, P1)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 68
Tracking Status
firefox67 --- fixed
firefox68 --- fixed

People

(Reporter: Felipe, Assigned: Felipe)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We decided to temporarily back out the new tab animations until we're able to do more user testing and validation of the new animations. While they may have some potential perf wins on the book, it's less clear if it can be perceived as an improvements, and UX doesn't think the new animation as implemented is as pleasing as the existing one.

Since there are a few bugs to be fixed with them, and we'll put engineering efforts on hold until we have new directions to continue, it's better to remove them from the tree so that people don't get stuck with them (and e.g. bug 1526112) for too long.

Pushed by fgomes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/70dfe7fae016
Back out new tab animations. r=dao
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Comment on attachment 9053724 [details]
Bug 1539255 - Back out new tab animations. r=dao

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1355588
  • User impact if declined: Feature is not ready to roll out, so we should must back it out from beta
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky):
  • String changes made/needed: None
Attachment #9053724 - Flags: approval-mozilla-beta?

Comment on attachment 9053724 [details]
Bug 1539255 - Back out new tab animations. r=dao

Back out an experimental feature due to existing bugs and UX decision, uplift approved for 67 beta 7, thanks.

Attachment #9053724 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Duplicate of this bug: 1526112
You need to log in before you can comment on or make changes to this bug.