Closed Bug 1539257 Opened 5 years ago Closed 5 years ago

`about:telemetry` support for Origin Telemetry

Categories

(Toolkit :: Telemetry, enhancement, P1)

enhancement
Points:
2

Tracking

()

VERIFIED FIXED
mozilla68
Tracking Status
firefox68 --- verified

People

(Reporter: chutten, Assigned: chutten)

References

Details

Attachments

(1 file, 1 obsolete file)

To support QA, we'll be needing a way to inspect Origin Telemetry contents on a running Firefox.

The usual way is via about:telemetry... so let's do that.

This bug is about using the existing plaintext snapshotting API Telemetry.getOriginSnapshot() to display a section in about:telemetry's "current ping" area called "Origin Telemetry".

This should come with explainer text to describe in as plain language as possible that these origins are only sent when encoded in such a way that we only get aggregated statistics out of it. (in short, it's a privacy-preserving mechanism of data collection).

Might be worth passing the draft in front of comms before we ship it. We wouldn't want a misinterpretation turning this into a "thing".

...maybe we could show the plaintext and encoded prioData structures one after the other? Might be illustrative.

How urgent is this bug, given the conversion work happening in bug 1523741 (hopefully not far from the end)?

On a side note, there's a lot of hardcoding brand names in the strings (Mozilla, Firefox), and I'm not exactly sure we should be doing that.

(In reply to Francesco Lodolo [:flod] from comment #2)

How urgent is this bug, given the conversion work happening in bug 1523741 (hopefully not far from the end)?

The project "Content Blocking measurement with Prio" is targeted at Fx 68.
From my understanding, this bug is part of the project. I'm not sure how critical this bug is for the feature, but it's necessary for QA feature testing.

See Also: → 1523741
Assignee: nobody → chutten
Status: NEW → ASSIGNED
Points: --- → 2
Priority: -- → P1
Depends on: 1523741
Attachment #9054620 - Attachment is obsolete: true
Attachment #9056932 - Attachment description: Bug 1539257 - Show Origin Telemetry in about:telemetry r?janerik → Bug 1539257 - Show Origin Telemetry in about:telemetry l10n-r?flod r?janerik
Pushed by chutten@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/382518bd8029
Show Origin Telemetry in about:telemetry l10n-r?flod r=janerik,flod
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68

Hi Chris!
Could you give me some clue how to verify this issue? What event or action do I have to execute to verify it?
I'm looking at about: telemetry, in the Current ping - Event section but I'm not sure what I should find

Flags: needinfo?(chutten)

You have to set a couple of prefs (which ones, I keep forgetting) to turn on the part of Content Blocking that uses Origin Telemetry, then find a web page that exercises Content Blocking.

It may be that Ciprian's test plan already verifies this bug as part of the wider "Content Blocking using Origin Telemetry" program, so maybe I can save you some work with a well-placed needinfo... (and if not, it'll give me time to find those prefs)

Flags: needinfo?(chutten) → needinfo?(ciprian.georgiu)

Hi Marcela!

We've already covered this bug through our test plan as Chris said, but only on Nightly 69. If you want to verify this on Beta 68 as well, you need to set the following prefs to true in about: config: privacy.trackingprotection.origin_telemetry.enabled, telemetry.origin_telemetry_test_mode.enabled. Please see more details here.

Flags: needinfo?(ciprian.georgiu)

I verified this issue in Beta 68 and works ok.
I changed this prefs to true privacy.trackingprotection.origin_telemetry.enabled, telemetry.origin_telemetry_test_mode.enabled.

I’m not able to reproduce the issue. Based on this I will mark the bug as Verified.

Status: RESOLVED → VERIFIED
Flags: qe-verify+ → qe-verify-
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: