Closed Bug 1539283 Opened 6 months ago Closed 5 months ago

crashinject.exe and crashinjectdll.dll missing from Windows common.tests.tar.gz

Categories

(Firefox Build System :: General, enhancement)

enhancement
Not set

Tracking

(firefox68 fixed)

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: gbrown, Assigned: cmanchester)

References

Details

(Keywords: in-triage)

Attachments

(1 file)

In bug 1534858 I noticed that crashinject.exe and crashinjectdll.dll are missing from the common.tests archive, because they are missing from the list at

https://searchfox.org/mozilla-central/rev/2c912888e3b7ae4baf161d98d7a01434f31830aa/python/mozbuild/mozbuild/artifacts.py#501-516

I think crashinject should be included in the tests archive because test automation code expects it:

https://searchfox.org/mozilla-central/rev/7abb9117c8500ed20833746c9f8e800fce3a4688/build/automation.py.in#356

However, adding a dll to that list also accidentally includes the dll in the target.zip archive, which is clearly wrong, and resulted in backout of my proposed change:

https://bugzilla.mozilla.org/show_bug.cgi?id=1534858#c15

:glandium noted:

Be is a an artifact builds, and artifact builds install *.dll :( (see package-manifest.in)
Part of the problem is that dist/bin is kind of polluted with non-Firefox things.
Part of the problem is that wildcard for artifact builds.

I'm not sure how to address that.

Chris do you have any ideas how to address this issue?

Flags: needinfo?(cmanchester)

I think we need to be smarter about figuring out which msvc dlls the build needs, so an improvement to this: https://searchfox.org/mozilla-central/rev/3d469329a42644b41e66944d8da22d78d8c0f5ec/browser/installer/package-manifest.in#109

I can take a look at this later in the week if need be.

Flags: needinfo?(cmanchester)
Keywords: in-triage

gbrown, is this something you can take a look at based on comment 2, or should I find some time to take a look?

Thanks Chris, but I'm not very comfortable with build changes and I'm pretty busy. It would be great if you could take this.

Assignee: nobody → cmanchester
Pushed by cmanchester@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/674e4d7ead23
Use less general wildcard patterns when packaging dlls in an artifact build. r=nalexander
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Regressions: 1557019
You need to log in before you can comment on or make changes to this bug.