CHECKERBOARD_SEVERITY probe and friends aren't collected in release

RESOLVED FIXED in Firefox 67

Status

()

enhancement
P2
normal
RESOLVED FIXED
2 months ago
2 months ago

People

(Reporter: tdsmith, Assigned: tdsmith)

Tracking

(Blocks 2 bugs)

66 Branch
mozilla67
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox66 wontfix, firefox67 fixed, firefox68 fixed)

Details

Attachments

(2 attachments)

The CHECKERBOARD_SEVERITY probe isn't collected in release. We'd like to use that as an outcome measure for the WebRender studies, so we should queue that up for the 67 release.

I'll plan to update the probe definition this week.

The CHECKERBOARD probes are used as performance outcomes / diagnostics for WebRender.
We are beginning to test WebRender in release, so we should have these probes available.
This change additionally extends collection through version 73 to be compatible
with the January 2020 horizon for the ongoing nightly/beta WebRender study.

Depends on: 1238040
Keywords: leave-open
OS: Unspecified → All
Hardware: Unspecified → All
Target Milestone: --- → mozilla67
Posted file Data collection review β€”
Attachment #9054013 - Flags: data-review?(teon)
Priority: -- → P2
Comment on attachment 9054013 [details]
Data collection review

DATA COLLECTION REVIEW RESPONSE:

    Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes. These probes already exist in pre-release channels and this request is to include them in release. 
Their documentation is listed in in the definitions file [Histograms.json](https://hg.mozilla.org/mozilla-central/file/tip/toolkit/components/telemetry/Histograms.json) and in the [Probe Dictionary](https://telemetry.mozilla.org/probe-dictionary/).

    Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection is through Telemetry so it can be controlled through Firefox's Preferences.

    If the request is for permanent data collection, is there someone who will monitor the data over time?

No. This collection will expire Jan 2020.

    Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 1, Technical.

    Is the data collection request for default-on or default-off?

Default on for all channels.

    Does the instrumentation include the addition of any new identifiers?

No.

    Is the data collection covered by the existing Firefox privacy notice?

Yes.

    Does there need to be a check-in in the future to determine whether to renew the data?

Yes. :tdsmith is responsible for renewing or removing the collection before it expires Jan 2020.

---
Result: datareview+
Attachment #9054013 - Flags: review+

Updated

2 months ago
Attachment #9054013 - Flags: review+
Attachment #9054013 - Flags: data-review?(teon)
Attachment #9054013 - Flags: data-review+

Comment 4

2 months ago
Pushed by tismith@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/90c5adf892a1
Collect CHECKERBOARD probes in release and extend collection r=jrmuizel

Comment on attachment 9054012 [details]
Bug 1539309 - Collect CHECKERBOARD probes in release and extend collection r?jrmuizel

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: None
  • User impact if declined: No user impact; without uplift, the WebRender study planned for release 67 wouldn't be able to track these metrics.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Not risky because changes are isolated to probe definitions in Histograms.json
  • String changes made/needed: none
Attachment #9054012 - Flags: approval-mozilla-beta?

Comment on attachment 9054012 [details]
Bug 1539309 - Collect CHECKERBOARD probes in release and extend collection r?jrmuizel

Telemetry update that looks safe, uplift accepted for 67 beta 8, thanks.

Attachment #9054012 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.