Windows Preview per Tab is broken

VERIFIED FIXED in Firefox 67

Status

()

defect
P1
normal
VERIFIED FIXED
3 months ago
3 months ago

People

(Reporter: Felipe, Assigned: Felipe)

Tracking

(Regression, {regression})

unspecified
Firefox 68
Points:
---

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 verified, firefox68 verified)

Details

Attachments

(1 attachment)

The setting "Show tab previews in the Windows Taskbar" in about:preferences (a.k.a. browser.taskbar.previews.enable) is broken, probably due to bug 1528108.

If it is enabled, two errors show up in the Browser Console:

TypeError: doc is undefined PageThumbUtils.jsm:34:18
TypeError: this.canvasPreview is undefined WindowsPreviewPerTab.jsm:183:5

The problem is that the this.win object that we used is not a window. It's actually this TabWindow object that wraps the window:

https://searchfox.org/mozilla-central/rev/a7315d78417179b151fef6108f2bce14786ba64d/browser/modules/WindowsPreviewPerTab.jsm#353

Assignee: nobody → felipc
Status: NEW → ASSIGNED

Comment 3

3 months ago
Pushed by fgomes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d2cfbde267e9
Fix incorrect parameter in the Windows Taskbar Previews code. r=Standard8
Duplicate of this bug: 1538438

Comment on attachment 9053810 [details]
Bug 1539311 - Fix incorrect parameter in the Windows Taskbar Previews code. r=Standard8

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1528108
  • User impact if declined: The optional Windows-only feature "Show tab previews in the Windows Taskbar" is broken
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: Enable the option in about:preferences and move the mouse over Firefox in the taskbar
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky):
  • String changes made/needed: None
Attachment #9053810 - Flags: approval-mozilla-beta?
Flags: qe-verify?

Comment 6

3 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

Let's verify on Nightly first before uplifting, thanks.

Flags: qe-verify? → qe-verify+
QA Whiteboard: [qa-triaged]

Comment 8

3 months ago

Hi, I managed to reproduce this issue in older versions of Firefox but this issue does not occur anymore in the latest version of Firefox Nightly 68.0a1 (2019-03-28).

Comment on attachment 9053810 [details]
Bug 1539311 - Fix incorrect parameter in the Windows Taskbar Previews code. r=Standard8

Fix for an optional Windows only feature, contained patch for a non default feature and verified on Nightly by QA, uplift approved for 67 beta 7, thanks.

Attachment #9053810 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Comment 11

3 months ago

Hi, I have retested this issue in Beta 67.0b7 and the issue no longer occurs. I will mark this issue accordingly.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
No longer blocks: 1528108
Regressed by: 1528108
You need to log in before you can comment on or make changes to this bug.