Crash in [@ mdb_env_cthr_toggle]

RESOLVED WORKSFORME

Status

()

defect
P2
critical
RESOLVED WORKSFORME
4 months ago
16 hours ago

People

(Reporter: marcia, Unassigned)

Tracking

(4 keywords)

Trunk
Unspecified
Android
Points:
---

Firefox Tracking Flags

(firefox66 unaffected, firefox67+ wontfix, firefox68+ fixed)

Details

(crash signature)

This bug is for crash report bp-cc58c3a7-a677-4380-9aca-209310190222.

Seen while looking at beta crash stats - these crashes go back to at least 20190208095514 when 67 was in nightly: https://bit.ly/2UTQu2J. It doesn't appear we have any crashes in 66 so this regression seems to have started when nightly was in 67.

Some of the source code was touched in Bug 1508434.

No useful comments and not very many URLs:

Top 7 frames of crashing thread:

0  @0x5583c3b0 
1 libxul.so mdb_env_cthr_toggle 
2 libxul.so nsBoxFrame::GetContentInsertionFrame 
3 libxul.so mdb_env_cthr_toggle 
4 libxul.so nsBoxFrame::GetContentInsertionFrame 
5 libxul.so js::jit::MaybeEnterJit js/src/jit/Jit.cpp:103
6 libxul.so js::LiveSavedFrameCache::~LiveSavedFrameCache mfbt/Variant.h

Crash Signature: [@ mdb_env_cthr_toggle] → [@ mdb_env_cthr_toggle] [@ @0x0 | mdb_env_cthr_toggle]

Andrei, could you please investigate this? Samsung devices seem more affected.

Flags: needinfo?(andrei.bodea)

I couldn't reproduce this issue on the following builds: Latest Nightly build, Beta 67.0b5, Beta 670b7 with the following devices:

  • Samsung Galaxy Note 9(Android 8.1.0)
  • Samsung Galaxy S9(Android 8.1.0)
  • Samsung Galaxy S8(Android 8.1.0)
    During my tests I will try to use a Samsung daily and I will come back if I will be able to reproduce the issue or get any info.
Flags: needinfo?(andrei.bodea)

50 crashes so far in 67b5.

Priority: -- → P1

There is some stuff further down in the stack in the initial crash report that I posted that looks like Bug 1521158 (js::LiveSavedFrameCache::~LiveSavedFrameCache()). Wondering if this crash is related to that one, but that crash also has some crashes in 66.

Here are some of the top crashing devices:

  • Amazon KFSUWI (not supported)
  • Xiaomi MI5
  • Sony Xperia Z5

Also a correlation to Adreno 430 - (24.32% in signature vs 01.94% overall) adapter_device_id = Adreno (TM) 430 [39.13% vs 03.78% if adapter_vendor_id = Qualcomm]

#5 overall crash in 67.0b7

A few correlations in Beta:

  • (23.64% in signature vs 03.11% overall) adapter_device_id = Adreno (TM) 510 [54.17% vs 06.51% if adapter_vendor_id = Qualcomm]
  • (20.00% in signature vs 04.47% overall) android_version = 23 (REL)

A few URLs:

n-i to myself to look for a contact at qualcomm

Flags: needinfo?(lhenry)

Conversation with Qualcomm in progress (cpearce has the details).

Flags: needinfo?(lhenry)

Chris, could you please update the bug with info from conversations with Qualcomm?

Flags: needinfo?(cpeterson)

(In reply to Neha Kochar [:neha] from comment #10)

Chris, could you please update the bug with info from conversations with Qualcomm?

^ I think you want to talk to :cpearce, not :cpeterson.

Flags: needinfo?(cpeterson) → needinfo?(cpearce)

I emailed the Qualcomm list about bug 1470925, is this bug here thought to be the same as bug 1470925?

I've not had a response on the Qualcomm mailing list. I've been told by StPeter that the last time he raised an issue with Qualcomm about the Snapdragon 820 CPU, he was told they're no longer supported.

It may help us build a case with Qualcomm if we had some kind of aggregate number of crashes to represent how bad the problem here is, across all signatures that we think are related.

Flags: needinfo?(cpearce)

(In reply to Chris Peterson [:cpeterson] from comment #11)

(In reply to Neha Kochar [:neha] from comment #10)

Chris, could you please update the bug with info from conversations with Qualcomm?

^ I think you want to talk to :cpearce, not :cpeterson.

Thank you for correcting that, Chris. Sorry about the wrong ni.

[Tracking Requested - why for this release]:

there's not too much data available yet, but this seems to be the #2 top crash in the early rollout of firefox 67 on android.

Although 2 months ago there seemed to be a correlation to Adreno 510, it is looking now as if there is a much wider correlation of arm devices:

ARM Mali-400 MP 125 16.5%
Qualcomm Adreno (TM) 510 98 12.9%
Qualcomm Adreno (TM) 430 74 9.8%
Qualcomm Adreno (TM) 203 62 8.2%

Comments are not particularly useful in terms of getting some information about the crash.

Keywords: topcrash

Although 68 is marked as affected, in early 68 beta data I don't see any crashes yet.

Marking as P2 for now since nothing has been seen yet in 68.0 betas.

Priority: P1 → P2

If we don't see this crash after the 68 release we can likely close the bug as WORKSFORME.

No crashes seen in 68 release. I think we can close this one out as WFM and reopen if the crash reappears. This crash was seen in such a high volume it would good to understand why it went away in the 68 release.

Status: NEW → RESOLVED
Closed: 8 days ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.