Clearing list of already downloaded files causes crash

VERIFIED DUPLICATE of bug 153480

Status

SeaMonkey
Download & File Handling
--
critical
VERIFIED DUPLICATE of bug 153480
16 years ago
13 years ago

People

(Reporter: rjh, Assigned: Blake Ross)

Tracking

({crash, stackwanted})

Trunk
x86
Linux
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Need TB7660780K data)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1a+) Gecko/20020623
BuildID:    2002062304

There are several talkbalks:  TB7660780K, TB7660762G, TB7658192Q for this
problem.  With this build any attempt to remove the files that are finished
downloading causes a crash.  This may be a duplicate of others, but I don't use
RDF, etc.  The list entry that I am trying to delete is actually the
mozilla-i686-pc-linux-gnu-sea.tar.gz for this build.  It will crash if all I do
is start mozilla, then start download manager, then try to remove from list.

Reproducible: Always
Steps to Reproduce:
1.Start mozilla
2.Remove item from download manager list
3.

Actual Results:  crash

Expected Results:  item removed
(Reporter)

Comment 1

16 years ago
I had another idea.  I tried selecting individual files.  I was able to remove
everything except the mozilla download from the this.  I don't know whether the
problem is because it is mozilla or because it is the first on the list.  The
attempt to remove the mozilla download generated another talkback:  TB7663897H

Comment 2

16 years ago
Related: bug 153480.
Keywords: crash, stackwanted
Whiteboard: Need TB7660780K data

Updated

16 years ago
URL: n/a
(Reporter)

Comment 3

16 years ago
Further information.  I got tired of the crashing so I moved the download.rdf. 
When I looked at it I found two things:
 1) There were multiple entries for this file, with varying numbers of download
dates for each entry.  That may be the cause of the crash.
 2) There were a great many entries.  Why?  I've removed them from the list
according to the download manager.  This will be a privacy concern.  Is this a
residual bug?  Another bug? A feature (if so, it will lead to problems)?
(Reporter)

Comment 4

16 years ago
Still more.  I looked at the download.rdf and noticed one thing that is unique
to the name that causes the crash.  It is the only one that has a DownloadState
that is 3.  All the other files have "1".  This one entry has both "1" and "3".

                   NC:Name="mozilla-i686-pc-linux-gnu-sea.tar.gz"
                   NC:ProgressMode="none">
    <NC:StatusText>Finished</NC:StatusText>
    <NC:StatusText>Canceled</NC:StatusText>
    <NC:Transferred>12629KB of 12629KB</NC:Transferred>
    <NC:Transferred>3889KB of 12629KB</NC:Transferred>
    <NC:URL
resource="http://ftp35.newaol.com/pub/mozilla/nightly/latest-1.0.0/mozilla-i686-pc-linux-gnu-sea.tar.gz"/>
    <NC:File
resource="file://home/hornrj/master-distribs/Themes/mozilla-i686-pc-linux-gnu-sea.tar.gz"/>
    <NC:DownloadState NC:parseType="Integer">1</NC:DownloadState>
    <NC:DownloadState NC:parseType="Integer">3</NC:DownloadState>
    <NC:ProgressPercent NC:parseType="Integer">100</NC:ProgressPercent>
    <NC:ProgressPercent NC:parseType="Integer">30</NC:ProgressPercent>
  </RDF:Description>

This could also be irrelevant.  There are various other normal looking entries
for the mozilla tar file.  I don't know which one it the one that causes the crash.

Comment 5

16 years ago

*** This bug has been marked as a duplicate of 153480 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
marking verified as a duplicate.

if you decide to reopen this bug, please clarify why.

search string for bugspam removal: SalviaGuaranitica
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.