Closed Bug 1539630 Opened 8 months ago Closed 8 months ago

Incorrect Address Bar autocomplete behaviour when IP address-based bookmark present

Categories

(Firefox :: Address Bar, defect)

66 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1537640

People

(Reporter: thebertster, Unassigned)

Details

Attachments

(1 file)

Attached image Screenshots.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

From a blank profile, add a bookmark where the URL uses an IP address rather than hostname, e.g. https://10.1.2.3/foo

Begin typing in the Address Bar, e.g.:

https://10

Autocomplete fills begins to fill in the hostname, i.e. https://10.1.2.3 with the untyped portion (".1.2.3") being selected (normal behaviour so far).

Type the next character (.) and the incorrrect behaviour occurs.

Actual results:

Upon typing the ".", the autocompleted URL changes to https://10.0.0.0 and the untyped "0.0.0" part is NOT selected with the cursor still placed between the "." and the "0.0.0". As the user continues to type, the "0.0.0" remains appended to the end of the URL, e.g.:

https://10.1.2.3/foo0.0.0

This behaviour seems to occur for any IP-based bookmark; as soon as the first "." is typed, autocomplete appends "0.0.0".

Expected results:

It is unclear why autocomplete is appending "0.0.0" in the first place, but in any case the normal behaviour in the Address Bar is for the autocompleted (untyped) part of the URL to remain selected; this does not happen in this case.

This problem was not observed prior to r66.

Status: UNCONFIRMED → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1539573
Component: Untriaged → Address Bar
Duplicate of bug: 1537640
You need to log in before you can comment on or make changes to this bug.