Closed Bug 15397 Opened 20 years ago Closed 20 years ago

link certain distance down page fails to repaint

Categories

(Core :: DOM: UI Events & Focus Handling, defect, P3)

x86
Windows 98
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: allen.sam, Assigned: joki)

References

()

Details

(Whiteboard: [testcase])

Attachments

(2 files)

The 115th link in a document fails to repaint on a style change if a reflow is
not required. If a reflow is required, the 115th+ links repaint like they
should.
Attached file testcase
Attached file testcase
Please use the second testcase. The first one does not show the problem. (It
does show though that a reflow causes the repaint to happen like it should).
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
Unable to reproduce with current build
I can reproduce this reliably on the October 1st build. I'll try a later
build....
If you can still reproduce this, please let me know if it depends on things like
window size and scroll position.
OCCURS ON:
- Apprunner, Viewer (October 1st build) on Windows 98
- 640x480 & 800x600 resolutions

STEPS TO REPRODUCE:
1. Load http://bugzilla.mozilla.org/showattachment.cgi?attach_id=1955
2. Scroll down to where the test says 'link (first non-hoverable)'. This link
(and all following links on the document) does not repaint when it is hovered
over.

As far as I can tell window size and scroll position doesn't matter. Adding URL
where I first saw this.
Summary: 115th link fails to repaint on style change → link certain distance down page fails to repaint
On further investigation, the number of the link doesn't matter; what matters is
how far the link is positioned down the page. If in my testcase you enlarge the
font, then a link further up the page, like the 50th link, won't repaint.
Status: RESOLVED → REOPENED
1. I can reproduce this in the 10/7/99 win32 build. (reopening)
2. This may have something to do with selection... the hover style changes like
it should _if_ the user is also selecting text simultaneously (as in dragging
the cursor over the link while the mouse button is held in). If the user is not
selecting anything at the same time, the links do not change style on hover.
Resolution: WORKSFORME → ---
Clearing WORKSFORME resolution due to reopen of this bug.
Assignee: peterl → joki
Status: REOPENED → NEW
Component: Style System → Event Handling
Looks like a failure in mouse tracking or event handling.
Whiteboard: [testcase]
(adding radar)
*** Bug 16001 has been marked as a duplicate of this bug. ***
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → WORKSFORME
This now works. Someone must have fixed something in last couple months. Marking
Worksforme.
Status: RESOLVED → VERIFIED
Verifying WORKSFORME base on reporter's agreement on fix.
Component: Event Handling → User events and focus handling
You need to log in before you can comment on or make changes to this bug.