Closed Bug 1539792 Opened 1 year ago Closed 1 month ago

Tooltip for "bug xxxxxx" shows the commit message rather than the bug summary

Categories

(Tree Management :: Treeherder: Frontend, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jfkthame, Assigned: tin.la)

References

Details

(Keywords: good-first-bug, Whiteboard: [lang=js])

Attachments

(4 files)

Hovering over the linkified text "Bug xxxxxxx" in a treeherder changeset should show a tooltip with the bug title/summary; but instead, it just shows the changeset summary (commit message) again.

This is particularly obvious on a backout such as https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=db92f218cea95be1596b1be70ccb80db7024eae7, where the summary shows "Backed out changeset 827a1c12a137 (Bug 1538158) for bc failures at browser_action_searchengine.js.". The text "Bug 1538158" is a link to bugzilla, but its tooltip just repeats the backout message, instead of showing the bug title as expected.

This would be great to do. It requires a bit of work to fetch all those summaries from bugzilla (for bug suggestions, we do this on the server side). But it's certainly do-able.

Priority: -- → P3

I'll mark this as a good first bug. But it's more like a good SECOND or THIRD bug, because it's a bit more challenging.

I think this would be handled in a reactstrap tooltip, rather than normal html title value. https://reactstrap.github.io/components/tooltips/

So, you would set a toggle function on the Tooltip. In that function, you would call an API in this format (sample code):

const { data, failureStatus } = await getData(bugzillaBugsApi('bug', { id: 1447537 }));

Then set the tooltip value and the isOpen on the tooltip to show. The trick would be that it'll have to be a unique isOpen for that link, because there will usually be multiple bugs. So this will be slightly tricky.

Whiteboard: [lang=js]

Hello, I am an outreachy applicant and I will love to take up this bug

Hello, I am an outreachy applicant and I will love to take up this bug.

Pardon me, my comment appeared twice on refresh, and I cannot find a delete option. I would love to use this account instead as the email tallies with my outreachy application. I would love this task assigned to me. Thanks.

(In reply to Chioma Onyekpere from comment #5)

Pardon me, my comment appeared twice on refresh, and I cannot find a delete option. I would love to use this account instead as the email tallies with my outreachy application. I would love this task assigned to me. Thanks.

Flags: needinfo?(sclements)
Flags: needinfo?(cdawson)

Hi, I am an Outreachy applicant. If this issue hasn't been assigned yet please may I have it?

Hi Sam and Chioma-- Thanks so much for your interest! I'm sorry to say we have had to stop taking applicants for this project as the response has been large and we have hit our capacity at the moment. We set the project as not accepting applicants at this time on the morning of 10/2 (pacific time).

We encourage you to explore other projects at Mozilla, though, as there are a lot of fun ones out there. Thank you again and best wishes! :)

Flags: needinfo?(cdawson)
Flags: needinfo?(sclements)

Hello Dawson, thank you for responding. I'll take your advice and see what other fun project here I can join. Do have lots of fun!

Oh! I was late on this. You formerly offered to assign a bug to me via email yesterday. Thank you for your response, I will seek other projects to contribute to.

Flags: needinfo?(cdawson)

Oh shoot, I made a mistake. I apologize. We have had so many people I lost track. I can go ahead and assign this bug to you, then. Sorry for my confusion! I see the emails now.

Assignee: nobody → chioma.onyekpere.185617
Flags: needinfo?(cdawson)

OK, Chioma-- I have assigned this bug to you. If you have already moved on to another project, please let me know and I'll free this bug back up. Otherwise, I look forward to your submission. :)

Flags: needinfo?(chioma.onyekpere.185617)
Status: NEW → ASSIGNED

I have not moved on yet. Thank you so much!

Flags: needinfo?(chioma.onyekpere.185617)

Please, I have been unable to join the #treeherder IRC channel. How may I join the chat?
_ What I have done -
First, I get to the "Welcome to Kiwi IRC!" page with the dog picture
I set my preferred "Nickname"
then the"Channel" label already has #treeherder in the input box
I click on the "start" button

Then
I am taken to the channel, but I still see the "join channel" button by the top right, I see no former activities,
Inside the chat area I see "You need to be identified to a registered account to join this channel" which appears multiple times when I click on join channel
I send a message it appears then nothing

Chioma those are questions best asked in an email (so we only have conversations pertaining to the bug here). You'll need to register your nickname to join the channel (go to the "Nicknames" section): https://wiki.mozilla.org/IRC

Please, I seem to have missed the point of the bug, as Sarah pointed out to me in my PR. I looked through all the other commits on treeherder and logged revision on the console, I noticed that the tooltip called the comments ie revision.comments.
On the tooltip I tried to get the backed out changeset to render in the same format as the others. Please, if I could get an instance of a tooltip that renders as desired and a little more explanation it should put me on track on how to go about the debugging. Thanks

Flags: needinfo?(cdawson)

Chioma-- So the point of this change is to show the Bugzilla description, rather than the commit description. For example, if you look at this push:
https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=650273d192077a93007e509e7d7ec6690d84ee87

And you hover your mouse over the link in Treeherder that says: "Bug 1579507 - Fix non-working FTP telemetry probes, r=valentin"

You will see that the tooltip says exactly the same thing: "Bug 1579507 - Fix non-working FTP telemetry probes, r=valentin". This is the title of the COMMIT. But what we want is the title/summary of the Bug itself. So what we want the tooltip to say is: "Bug 1579507 - Collect telemetry on FTP usage".

But, as I was saying in comment 2, this requires a call to the bugzilla API to get that summary. So you can't do it with the classic title="foo" technique. You'll need to use a ReactStrap Tooltip component.

Does that help? If not, please let me know either in #treeherder, or add me as a "need-info" below to make sure I notice your question right away. :)

Flags: needinfo?(cdawson)

Please, what is the Bugzilla bugs Api url or path?

Flags: needinfo?(cdawson)

Chioma, there is a function in our code base that provides the bugzilla bugs url: https://github.com/mozilla/treeherder/blob/master/ui/helpers/url.js#L119

Flags: needinfo?(cdawson)

Chioma, were you planning on making changes to your pull request?

Flags: needinfo?(chioma.onyekpere.185617)
Duplicate of this bug: 1600796

Hello, Sarah yes, I intend to push my fix for review.

Flags: needinfo?(chioma.onyekpere.185617)

Can I fix this one?

Let me check with Chioma, since it's assigned to her. Chioma, do you intend to finish working on this bug in the next week? If not, I'd like to assign it to someone else.

Flags: needinfo?(chioma.onyekpere.185617)

I just tried to push a change and I was denied access to treeherder

Flags: needinfo?(chioma.onyekpere.185617)

Has it been closed? What was the exact message you saw in your terminal when pushing a change? Please attach your pull request here - it should be included so it's easy to find. (Go to Attachments at the top, select "Attach new file", paste the url to your pull request per the instructions and select "patch", then submit).

I cannot checkout to my old branch, here's the PR https://github.com/mozilla/treeherder/pull/5510.

I created a new branch and made my changes there, I cannot also push to the new branch. I am using the same github account

It looks like you're trying to push to the mozilla/treeherder repo instead of your fork.

Once you set origin to your fork, then type git push origin bug/Chioma/tool-tip-does-not-show-bug-summary --force. If this is unclear, please refer to github's guides - they have all of this written in their documentation.

Please only makes changes to the old branch, not a new one; bug/Chioma/tool-tip-does-not-show-bug-summary is the branch for your existing pull request. When you forget the name of the branch you're working on, git branch will show you all of the branches you have created. For future reference, you should also only use hyphens and not slashes when naming a branch, so for example tooltip-change is sufficient. The branch name is for reference and does not need to be lengthy.

I'm going to free up this bug for someone else to work on since there hasn't been a completed patch submitted.

Assignee: chioma.onyekpere.185617 → nobody
Status: ASSIGNED → NEW
Keywords: outreachy

Hello, I would like to try fixing this, but I haven't worked on any treeherder bugs before, only on two Firefox bugs. I'd really appreciate some guidance with this.

Soumya: This is the class the work would be done in: https://github.com/mozilla/treeherder/blob/1fb930b3e6066d3fdebef591ff6c6021f76588fe/ui/shared/Revision.jsx#L44

Please see comment 2 for more information about the approach. This work will be in ReactJS. Do you have React experience?

I'm not proficient in React but I have sufficient working knowledge of it so I'm willing to try this.

Assignee: nobody → tin.la
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.