Status

enhancement
P1
normal
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: jlast, Assigned: jlast)

Tracking

unspecified
Points:
---

Firefox Tracking Flags

(firefox67 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

We are releasing two significant new features to the Debugger (Column Breakpoints, Worker Debugging). It would be nice to uplift several UI improvements.

1536114 Update column breakpoint colors for debugger
1534328: Preserve mapped Breakpoint Snippets
1535095: Hidden column breakpoints are shown
1536113: Column Breakpoints have a blue background
1536201: site slow to load when debugger is open
1537589: Breakpoints are sometimes appearing and then disappearing from list on toolbox
1536216 Redesign Map Scopes Pane
1534808 Backed out changeset 33f142760b69 - Don't check for JavaScript
1538164 [release 130] added no sources message in Sources Pane (#7978). r=jlast
1532309: Log points should show multiple values. r=bhackett

Summary: Uplift Debugger improvements → Uplift Debugger UI improvements
Blocks: 1539817
No longer blocks: 1539817
Priority: -- → P1
Posted patch uplift-ui-2.patch (obsolete) — Splinter Review

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1538164
  • User impact if declined: some of the new features we're releasing will be less polished.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): the changes only affect the Firefox debugger.
  • String changes made/needed: yes
Assignee: nobody → jlaster
Attachment #9054572 - Flags: approval-mozilla-beta?

Not applying properly on my current mozill-beta checkout.

I tested this patch, UI item by item, and everything works as intended!

rebased on top of latest beta

Attachment #9054572 - Attachment is obsolete: true
Attachment #9054572 - Flags: approval-mozilla-beta?
Attachment #9054634 - Flags: approval-mozilla-beta?

Francesco, can you approve the introduction of new strings in this uplift to beta? Thanks

Flags: needinfo?(francesco.lodolo)

I'm not happy to uplift features this late in Beta, but I won't block on it for this time. For the future, I'd really like to understand what's been done to avoid it.

Also, in this specific case, I have pending questions on at least one of the strings (the comment is only a few days old, but I've asked on Slack well before that)
https://bugzilla.mozilla.org/show_bug.cgi?id=1536216#c6

Flags: needinfo?(francesco.lodolo)

Hello :flod. This specific case is special; the breakpoint system was completely rewritten and thus we needed the UI to reflect its changes. We're also in the middle of moving contributors from GitHub to MC. I appreciate your patience!

Comment on attachment 9054634 [details] [diff] [review]
uplift-ui-3.patch

Since flod is OK with the uplift despite the l10n impact, that this only affect the debugger and that we are still early in the cycle, I am approving this uplift for 67 beta 8, thanks.
Attachment #9054634 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.