it appears the windows01-64-ux laptops are running jobs on trunk when it should on be mozilla-central

RESOLVED FIXED in Firefox 67

Status

enhancement
RESOLVED FIXED
2 months ago
11 days ago

People

(Reporter: jmaher, Assigned: Callek)

Tracking

Version 3
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox67 fixed, firefox68 fixed)

Details

Attachments

(2 attachments)

Reporter

Description

2 months ago

our load has increased on the windows ux laptops and the queue will take a couple days to clear out.

we need to figure out why these are running on inbound/autoland and turn those tests off.

Updated

2 months ago
Blocks: 1530466
Reporter

Comment 1

2 months ago

this is a side effect of shippable builds - these were designed to run on nightlies only, now that shippable is the same, we need to pin these tests to be m-c only.

Reporter

Comment 2

2 months ago

and it looks to be setup properly to be try/m-c:
https://searchfox.org/mozilla-central/source/taskcluster/ci/test/raptor.yml#14

not sure why this is on inbound/autoland

Comment 4

2 months ago
Pushed by jwood@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3d678990e647
Properly avoid running on -ux hardware oustide of try/mozilla-central. r=jmaher

Comment 5

2 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Assignee: nobody → bugspam.Callek

It appears we have talos/raptor jobs running on mozilla-beta for windows10-64-ux. I didn't think these configuration changes needed to be uplifted, or am I wrong?

https://treeherder.mozilla.org/perf.html#/graphs?series=mozilla-beta,1829086,1,10

Flags: needinfo?(jmaher)
Reporter

Comment 7

a month ago

these should only be running on mozilla-central and try, not mozilla-beta. Is there a need to run these elsewhere- if so we would need to consider more devices.

Flags: needinfo?(jmaher)

(In reply to Joel Maher ( :jmaher ) (UTC-4) from comment #7)

these should only be running on mozilla-central and try, not mozilla-beta. Is there a need to run these elsewhere- if so we would need to consider more devices.

Right, Im saying that they are currently running on mozilla-beta. I'm not suggesting this is something we want, I'm querying why this fix doesn't appear to have addressed mozilla-beta. We noticed it in Perfherder alerts. https://treeherder.mozilla.org/perf.html#/graphs?series=mozilla-beta,1829086,1,10

Flags: needinfo?(jmaher)
See Also: → 1539741
Reporter

Comment 9

28 days ago

I believe the answer is this was not uplifted to mozilla-beta.

:ryanvm, how do we request a beta uplift?

Flags: needinfo?(jmaher) → needinfo?(ryanvm)

It's a test-only change, so it just needs to be on the sheriffs' radar to do so :)

Flags: needinfo?(ryanvm)
Whiteboard: [checkin-needed-beta]
Whiteboard: [checkin-needed-beta]

disable tp6-3 on windows ux laptops from running on autoland

this was a regression when we turned off tp6-3 for windows aarch64

Reporter

Updated

12 days ago
Flags: needinfo?(jmaher)
Reporter

Updated

11 days ago
Duplicate of this bug: 1550397

Comment 16

11 days ago
Pushed by jmaher@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/def8a63f9038
disable tp6-3 on windows ux laptops from running on autoland. r=davehunt
You need to log in before you can comment on or make changes to this bug.