Closed Bug 1539868 Opened 2 years ago Closed 8 months ago

Consider adding a way to override the default settings directory

Categories

(Toolkit :: Startup and Profile System, enhancement, P3)

enhancement

Tracking

()

RESOLVED DUPLICATE of bug 283779

People

(Reporter: mossop, Unassigned)

Details

On most platforms Firefox's settings directory (where it stores the profiles and some other bits and pieces) is essentially fixed, just being chosen based on the OS settings. I think it would be worth considering whether to make it possible to override this from the command line or environment. The chief use-case is testing. Even though tests are started with a custom profile the profiles and other data is still loaded and can be modified by tests.

We have tests in tree that intentionally make changes to the profiles (https://searchfox.org/mozilla-central/source/browser/components/migration/tests/marionette/test_refresh_firefox.py being a good example). If something goes wrong during the test it can mean a user's profile list will have been modified which breaks the rule that tests should not affect anything outside of the test environment.

Priority: -- → P3

Although this has a more clear and compelling statement, same as bug 283779 ?

Flags: needinfo?(dtownsend)

Ah yes.

Status: NEW → RESOLVED
Closed: 8 months ago
Flags: needinfo?(dtownsend)
Resolution: --- → DUPLICATE
Duplicate of bug: 283779
You need to log in before you can comment on or make changes to this bug.