[RR/RCF]Roll (hover) over text href (link) causes duplication (duplicate text) on page

RESOLVED DUPLICATE of bug 177539

Status

()

Core
Layout
P3
normal
RESOLVED DUPLICATE of bug 177539
16 years ago
16 years ago

People

(Reporter: neilio, Assigned: Marc Attinasi)

Tracking

({testcase})

Trunk
Future
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1a+) Gecko/20020620
BuildID:    2002062008

On the index page of the URL listed, if you roll over the text that says "Our
philosophy can enhance your presence on the web." the link duplicates just under
the text repeatedly every time you roll over it. (see screencapture attached).

Reproducible: Always
Steps to Reproduce:
1. Go to URL
2. Roll over the text "Our philosophy can enhance your presence on the web."
3.

Actual Results:  The a:hover style is applied, but the text is also duplicated
on the page.

Expected Results:  Just the a:hover style should have been applied.
(Reporter)

Comment 1

16 years ago
Created attachment 88983 [details]
Screencapture of text hover problem
Hmm.  This seems like bug 145224, which should have been fixed a while ago.  Is
the build date reported above really the one that you're using?
(Reporter)

Comment 3

16 years ago
Well, that's what it says in my titlebar: (Build ID: 2002062008)...

Comment 4

16 years ago
Confirming bug, 2002-06-24-08 (trunk) on Windows 98 SE.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

16 years ago
Created attachment 88992 [details]
Testcase

Updated

16 years ago
Keywords: testcase

Comment 6

16 years ago
Hmm, how odd, I see that the testcase didn't double the link as it was supposed
to when loaded over HTTP. It does when loaded from disk though...
Attachment #88992 - Attachment mime type: text/html → text/xml

Comment 7

16 years ago
*** Bug 154085 has been marked as a duplicate of this bug. ***
Summary: Roll over text href causes duplication on page → [RR/RCF]Roll over text href causes duplication on page
*** Bug 154174 has been marked as a duplicate of this bug. ***
So, on a newer build I see the problem on the site, but not the testcase.  I
expect the author of the testcase has a :hover rule in userContent.css.
Attachment #88992 - Attachment mime type: text/xml → text/html
I can see this bug some of the time, at some window sizes...
...and I can see it in 2002-06-02-21-trunk as well, so it's been around for a while.
There seems that amount of text, or of links, is a factor to reproduce the bug.
Attachment #89091 [details]
(http://bugzilla.mozilla.org/attachment.cgi?id=89091&action=view)  always
reproduces for me.
David wrote:
> I expect the author of the testcase has a :hover rule in userContent.css.

Nope, I would never do something like that. I am always testing with a vanilla
nightly build. I can now reproduce the bug using the testcase too - as you say,
it seems to come and go...

I also noted that the problem disappeared if I removed too much of the text
before the link.

Comment 14

16 years ago
Confirming issue with testcase provided. Tested with July 1 OS X trunk
(2002-07-01-03)
Priority: -- → P3

Updated

16 years ago
Target Milestone: --- → Future

Comment 15

16 years ago
*** Bug 160475 has been marked as a duplicate of this bug. ***
Bug also occurs on Linux and Windows in current trunk builds -> All/All
OS: MacOS X → All
Hardware: Macintosh → All
changing summary for easier finding
Summary: [RR/RCF]Roll over text href causes duplication on page → [RR/RCF]Roll (hover) over text href (link) causes duplication (duplicate text) on page

Comment 18

16 years ago
I have this same problem on my homepage: http://www.iki.fi/hazor/
The same effect can be seen on several of my pages. They are all clean
xhtml basic (validated) and formatted with some advanced css.

Comment 19

16 years ago
Also happens at http://keir.mierle.com/, which uses :first-line (like at least
one of the dups).

Comment 20

16 years ago
I used to see this bug frequently on a message board:  http://empeg.comms.net/

It doesn't happen so often anymore, but both 1.2a and 1.2b will occationally
exhibit this behavior.

What makes it hard to track down is that it's not consistently reproduceable.  I
could hover over a link, have it act normal and then without clicking, hover
back over and have it start.  However, once it starts, I can repeatedly hover
over to get as many copies of the link text as I want.  When one link on a page
starts doing this, the other links will still appear correct when hovered over.

When it happens, if I reload the page, the problem will sometime disappear, but
other times, it will continue to misbehave.

I haven't been able to find any set of steps that will consistently reproduce
the problem.  If it happens once, I'll try to repeat the steps I took, but often
it won't happen again.

I read many web-based message board, but it only happens to me on one of them
http://empeg.comms.net/  that is also the only message board I read that's
running UBB Threads.  Looking at the HTML, I don't see anything odd, but I
haven't looked to see if there's any stylesheet quirks.

Comment 21

16 years ago
this is probably a dupe of bug 177539

Comment 22

16 years ago
testcase here is pretty close to the testcase for bug 177539 and the behavior at
the URL is the the same as bug 177539.

marking dupe

*** This bug has been marked as a duplicate of 177539 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.