Download Manager enhancement requests (right-click menu, etc.)

VERIFIED INVALID

Status

SeaMonkey
Download & File Handling
--
enhancement
VERIFIED INVALID
16 years ago
13 years ago

People

(Reporter: Ken Beal, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.1a+) Gecko/20020622
BuildID:    2002062208

I really like the Download Manager.  However, there are a couple features that
would make it even more fun.

Being able to right-click and select the options that are at the top would be
nice (i.e., have a right-click menu with Properties, Cancel, Remove From List,
Launch File, and Show in Explorer).

This one I consider a bug: if you click "Properties" it brings up the old-school
download window.  However, if you then close that using the [X] at the
upper-right, it cancels the download!  It shouldn't, it should continue it in
the Download Manager.  (At least it keeps the part it already downloaded, so I
only lose the time between clicking [X] and restarting, but it shouldn't stop
unless I click the *Cancel* button, either on the old-school dialog or in the
Download Manager.  The point is there's a way to show the old-school dialog from
DM, but there's no way to turn it off if the user just wants to watch the new DM
dialog.)

There's no way to restart/resume a failed download; that should be one of the
options on the right-click menu (and should be a button at the top as well). 
This should apply to downloads that are Failed, Not Started, or Canceled.

It would be nice if it saved the page that the download link came from, and gave
an option (at the top and on the right-click menu) to open a new window with
that page.  This is different from restarting the download, as perhaps there was
something else on that page (i.e., with ActivePerl, you download the installer
and then there's a "Next" link to continue the registration process).

Also, the Download Manager should have two additional columns so that it
displays the same (or more) information as the old-school dialog: Elapsed Time,
and Percent Complete (a number, that is, in addition to the Progress bar).


Reproducible: Always
Steps to Reproduce:
1. This is an enhancement request.
(Reporter)

Comment 1

16 years ago
I had one additional enhancement request:

The old-school dialog's title is "xx% of ..." -- so if you minimize it, even
with a lot of open windows, you'll see the percentage complete at the very least
just by looking down at the Task Bar.  The new Download Manager's title should
change if the user clicks on a file, to be "xx% of ... - Download Manager" (or
something similar).  This way the new functionality is a superset.

And if the user doesn't click on a file, the title should default to displaying
the percent complete of the bottom-most file in the display (i.e., most recent
download started).

Comment 2

16 years ago
I agree with the enhancements but the bug you submit, Ken, has already been
reported in Bug #153702.

Comment 3

16 years ago
Please don't submit more than one bug/request per bug number as it makes it hard
to work on them.

Your suggestions are already addressed:
The context menu: http://bugzilla.mozilla.org/show_bug.cgi?id=132019
Closing properties stops download:
http://bugzilla.mozilla.org/show_bug.cgi?id=153702

The opening of the original page might not have been addressed.

The time elapsed and percentage complete columns are already available. Just
click the last button to the right of the column names and you will be able to
see all the columns available for display.

I am going to mark this bug won's fix because of the number of requests you
placed together in one bug and most of them being duplicated.

You should check out
http://bugzilla.mozilla.org/buglist.cgi?product=Browser&component=Download+Manager
for all the stuff that's being worked on for the download manager.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 5

16 years ago
According to PreScreening Guidelines,

"...a single bug report that raises many different, unrelated issues. Please
feel free to resolve these bugs as INVALID"

==> not WONTFIX. Reopening.
Status: RESOLVED → UNCONFIRMED
Resolution: WONTFIX → ---

Comment 6

16 years ago
==> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → INVALID
mass-verification of Invalid bugs.

if you don't think the report is invalid, please check to see if it has already
been reported (it might be a duplicate instead). otherwise, make sure that there
are steps (a valid test case) that clearly display the issue as an unexpected
defect.

mail filter string for bugspam: SequoiadendronGiganteum
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.