Manage Cookies and Site Data values are offset

VERIFIED FIXED in Firefox 67

Status

()

defect
P1
normal
VERIFIED FIXED
5 months ago
4 months ago

People

(Reporter: csasca, Assigned: zbraniecki)

Tracking

({regression})

Trunk
Firefox 68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 wontfix, firefox67 verified, firefox68 verified)

Details

Attachments

(2 attachments)

Affected versions

  • Firefox 66.0.2
  • Firefox Beta 67.0b6
  • Firefox Nightly 68.0a1

Affected platforms

  • Windows 10 (x64)
  • macOS 10.12
  • Ubuntu 18.04 (x64)

Steps to reproduce

  1. Start Firefox
  2. Access the following link: https://bug1377104.bmoattachments.org/attachment.cgi?id=8882153
  3. Click on "Persist me" and then click on allow
  4. Access about:preferences#privacy and click on "Manage Data" from Cookies and Site Data

Expected result

  • The values from Cookies, Storage and Last used are retaining their place in the column.

Actual result

  • The values are offset by the addition of (Persistent), see the attachment.

Regression range

Has Regression Range: --- → yes
Has STR: --- → yes
Blocks: 1457021
Component: Layout → Preferences
Flags: needinfo?(gandalf)
Product: Core → Firefox

this seems like a layout issue due to the Storage column not being null. I'm not sure what's the way to solve it in the current XBL/CE CSS flex model, but I'm surprised Fluent is affecting this because we didn't really touch layout in that bug.

Flags: needinfo?(gandalf)

We know that changing to async filling of locale text affected various approaches to sizing so this seems very relevant here. Zibi, can you please investigate this?

Flags: needinfo?(gandalf)
Assignee: nobody → gandalf
Status: NEW → ASSIGNED
Flags: needinfo?(gandalf)

Ugh! Simple regression. I fixed it by bringing back label.value which I lost last time, but tbh, I'd love us to handle that better in richlistbox handler so that value and textContent of the label are treated equally.

Is this something we want to uplift to 67, or it can wait for bug 1536507 (ftl2ftl migration)?

Flags: needinfo?(jaws)

Looks like gandalf is on this, so P1'ing it.

Priority: -- → P1

I think we should look to uplift this. There will be other opportunities for ftl2ftl migration that we can test with that won't have the regression status.

Flags: needinfo?(jaws)

Then the sooner it lands the better, otherwise we risk going into release with a bunch of untranslated strings.

Pushed by zbraniecki@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e2237e45cd4a
Use label.value rather than text content in site data settings UI to use cropping. r=jaws,flod
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68

(In reply to Francesco Lodolo [:flod] from comment #5)

Is this something we want to uplift to 67, or it can wait for bug 1536507 (ftl2ftl migration)?

Just realized this was wrong, because the existing message isn't copied as-is, there's a message reference that changes from the old value.

Please nominate this for Beta uplift when you get a chance.

Flags: needinfo?(gandalf)

Comment on attachment 9055009 [details]
Bug 1540085 - Use label.value rather than text content in site data settings UI to use cropping. r?jaws

Beta/Release Uplift Approval Request

  • Feature/Bug causing the regression: Bug 1457021
  • User impact if declined: Values in the data settings UI can be visually misaligned.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): It's a simple change to two strings that has been verified on Nightly.
  • String changes made/needed: site-usage-pattern, site-usage-persistant
Flags: needinfo?(gandalf)
Attachment #9055009 - Flags: approval-mozilla-beta?

(In reply to Zibi Braniecki [:gandalf][:zibi] from comment #13)

  • String changes made/needed: site-usage-pattern, site-usage-persistant

At this point I'm OK with uplifting this.

Comment on attachment 9055009 [details]
Bug 1540085 - Use label.value rather than text content in site data settings UI to use cropping. r?jaws

Has l10n-drivers approval from flod, patch is straightforward and fixes a P1 regression, uplift approved for 67 beta 10, thanks.

Attachment #9055009 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

We have STR in comment #0, let's get it verified by QA as well.

Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Reproduced the issue on Windows 10 x64 using the STR from the description with 67.0b8, build ID: 20190404130536.

Confirming the fix across platforms (Win 10 x64, macOS 10.14 and Ubuntu 16.04 x64) on latest Nightly, build ID 20190410215612.

Leaving the qe-verify+ flag in place until this gets verified on Beta, too.

Confirming the fix on Fx 67.0b11 (buildID 20190415085659), too.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.