Closed Bug 1540109 Opened 1 year ago Closed 1 year ago

`new Response()` crashes Firefox tab when called from content script

Categories

(Firefox :: Extension Compatibility, defect)

66 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1426562

People

(Reporter: lukechilds123, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_13_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/73.0.3683.86 Safari/537.36

Steps to reproduce:

Calling "new Response();" from a content script in an Addon crashes the tab in Firefox.

This works fine in Chrome and fine in Firefox in context fo the page or devtools. It's only when called from a content script it crashes the tab.

It's not caused by any other code, I commented out all code in my extension so literally just the code "new Response();" existed. My content script is activated on twitter,com and as soon as I navigate to twitter.com the tab crashes instantly.

Actual results:

The tab crashes.

Expected results:

The tab shouldn't crash and I should get a response object returned.

This works fine in Chrome and fine in Firefox in context fo the page or devtools. It's only when called from a content script it crashes the tab.

Sorry, to clarify:

This works fine in Chrome in a page/devtools/content script.
This works fine in Firefox in a page/devtools.

It only crashes the tab when called in a content script in Firefox.

Attached is a super simple addon that runs a content script on https://lukechilds.co that literally just executes new Response();.

If you load this addon into Firefox and then visit https://lukechilds.co the tab will crash.

I was able to reproduce this issue on

User Agent Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:66.0) Gecko/20100101 Firefox/66.0

Component: Untriaged → Extension Compatibility

Anything I can do to help speed this up?

I can't release the Firefox update for my browser extension until this is resolved.

It's been a month since I reported this, anything I can do to help?

I can confirm this as well.

Upon digging into crash stats, it looks like this is a dupe of Bug 1426562.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1426562
You need to log in before you can comment on or make changes to this bug.