The "remove expression" button in the "Watch Expression" panel is oddly positioned

RESOLVED FIXED in Firefox 68

Status

defect
RESOLVED FIXED
4 months ago
4 months ago

People

(Reporter: nchevobbe, Assigned: davidwalsh)

Tracking

Trunk
Firefox 68

Firefox Tracking Flags

(firefox68 fixed)

Details

Attachments

(2 attachments)

Steps to reproduce

  1. Open the debugger
  2. In the watch expression panel, add a new ({a: 1}) expression
  3. Expand the object
  4. Expand the <prototype> node
  5. Hover the expression

Expected results

I see a "remove expression" button aligned with the first item of the tree

Actual results

The button is vertically aligned with the whole object, which looks a bit odd


Assigning to David as he requested on Slack 🙂

This is a recent regression since 67 is fine

Corrects the vertical alignment of the close button for watch expressions.

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a40b4bb80055
Align close button at top for expressions r=nchevobbe
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
You need to log in before you can comment on or make changes to this bug.