Closed Bug 1540183 Opened 10 months ago Closed 4 months ago

Multiple system crashes after 66.0.2 update installed

Categories

(Firefox :: General, defect, P5)

66 Branch
defect

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: dklballen, Unassigned)

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.12; rv:66.0) Gecko/20100101 Firefox/66.0

Steps to reproduce:

2019-03-29, On Mac OS 10.12.6 installed latest firefox release: 66.0.2. Post installation required firefox restart. Update 66.0.2 was installed at 07:37 today; as of now (09:18) system has crashed four times.

Actual results:

System crashes when attempting general browsing and application usage, e.g., watching baseball highlights video within facebook, google search on topic "Tesla" then following links to read articles, etc.

Expected results:

System should not crash.

Kathleen - Thanks for reporting. If you have any crash reports in about:crashes, can you share one of them here? That will help us investigate.

Flags: needinfo?(dklballen)

Original crash report attached. System crashed more than 20 times yesterday. Downgraded to 65.0.2 with same results. Temporary workaround is running firefox in safe mode.

Flags: needinfo?(dklballen)

Kathleen - I see a lot of errors in your log related to Symantec - "Could not generate an error report for a Symantec component." Perhaps your issue is being caused by an anti-virus program?

Hi Marcia - that may be possible. I'll contact Symantec support for guidance. Trouble is, I've had Symantec and Firefox on my system for a long, long time. The system crashes only began when Firefox auto-updated to 66.0.2. All other applications on my system run just fine, and running any other application (including the Safari browser) doesn't cause my system to crash. As I mentioned in a previous reply, my system does not crash if I run Firefox in safe mode. This would lead me to believe that an extension or add-on is the problem, BUT, I can't seem to find any extensions or add-ons installed. Also since my last reply, I allowed Firefox to re-update to 66.0.2. The problem didn't go away.

Just finished with Symantec support. They say the system crashes are NOT a result of their application, rather, the issue is with firefox.

CONFIRMED: I uninstalled Norton Security application from my Mac, then restarted the computer. Started Firefox in "normal" mode and the system crashed again. After system restart, started Firefox in "safe" mode - the system does not crash and I am able to use Firefox without issue. Interestingly, the Firefox "Crash Reports" folder says it was last updated at 10:40AM today, but there are no actual crash reports with a date/time stamp of today. Awaiting your guidance. Thanks.

As of 13:25 on 02 April:

  1. Did a "refresh firefox" at 11:00 AM today; created "Old Firefox Data" folder on my desktop
  2. Uninstalled Firefox
  3. Downloaded and installed Firefox from mozilla.org
  4. Started Firefox then restored bookmarks (Bookmarks -> Show All Bookmarks -> Import & Backup -> Restore)
  5. Followed instructions for "Recovering important data from an old profile" (http://mzl.la/1xKrzkF) and using "Old Firefox Data" from step 1, copied over ONLY places.sqlite, favicons.sqlite, key4.db, logins.json, permissions.sqlite, search.json.mozlz4, formhistory.sqlite, cookies.sqlite, cert9.db, handlers.json.
  6. Changed PREFERENCES for GENERAL: Download destination, Applications-mailto; HOME: home page URL, changed Top Sites to 2 Rows, deselected Recommended by Pocket, Highlights, and Snippets; SEARCH: removed all search engines except Google
  7. Quit Firefox
  8. Start Firefox in normal mode
  9. Logged into facebook, clicked one icon, system crashed.
  10. After system reboot, started Firefox in safe mode.
  11. Logged into bugzilla site and posted these comments.

Awaiting further guidance. Thank you.

As of 14:30 on 15 April:

Firefox auto-updated to 66.0.3 at 07:17 on 14 April. I quit Firefox and restarted in Normal mode this afternoon. After doing random Google searches and logging in to facebook, the system crashed as it did in my original bug report.

After system reboot, started Firefox in safe mode, logged into bugzilla site and posted these comments.

Awaiting further guidance. Thank you.

As of 13:10 on 06 May:

Firefox auto-updated to 66.0.4 at 06:57 on 06 May. I quit Firefox and restarted in Normal mode shortly after the update installed. After logging in to facebook, the system crashed as it did in my original bug report and previous comments.

System reboot was unsuccessful after several attempts over several hours. All attempts to restart system failed including starting in safe mode, verbose mode, recovery mode, resetting PRAM/NVRAM and SMC, peripherals disconnected, etc. After 6 hours of dealing with a "grey screen of death", I finally got the system to start.

After system start, started Firefox in safe mode, logged into bugzilla site and posted these comments.

Awaiting further guidance. Thank you.

Flags: needinfo?(tgrabowski)

Regarding the fact that there was no activity on the issue, I'll set the Firefox:: General component for a heads up. Please set the right component if you know a more suitable one, since I don't have the necessary knowledge to trace it. Thank you!

Component: Untriaged → General

Hi David,

Just curious if your comment is directed at me or someone within the firefox/bugzilla community. Please advise if you or anyone else needs any additional information from me.

Also note that Firefox auto-updated to 66.0.5 recently and the issue persists. This time, however, after the system crashed and I progressed through the various emergency start-up key sequences, doing an SMC reset (requires a battery pull), and getting to the Disk Recovery Utility repair function during start-up, I was finally able to get the MacbookPro to boot up properly. I can still only use Firefox in Safe Mode.

I'm happy to assist in troubleshooting or testing.

Best,

Kathleen

Flags: needinfo?(tgrabowski) → needinfo?(dolske)

Hi Kathleen. It was directed to the Firefox team.
Maybe you will be asked for more information after somebody will pick up this issue.
Thank you for your help!

Kathleen, please see the following links for help on Firefox crashes:

https://support.mozilla.org/en-US/kb/firefox-crashes-troubleshoot-prevent-and-get-help
https://support.mozilla.org/en-US/kb/firefox-crashes-asking-support

If they don't resolve your crashes, then please follow the instructions in the second link for submitting and viewing crash reports. Make sure your reports are submitted, and then please paste the link to one of your reports here in the bug so we can analyze it. (I see that you attached a file to this bug already, but it doesn't appear to be a crash report.)

Flags: needinfo?(dolske) → needinfo?(dklballen)
Priority: -- → P5

Hi Drew,

The first link you sent isn't really relevant to my bug reports. Firefox isn't crashing after the update, MY ENTIRE SYSTEM CRASHES. Getting my system back...just so it boots correctly....takes the better part of an entire day. I suspect the reason is that firefox was active at the time of the system crash and the system is trying to recover the processes that were active at the time of the system crash. Since firefox is "broken", the boot process hangs, or crashes, or gets stuck in a reboot loop.

What guidance can you provide re: firefox crashing my system? Please remember that system crashes do not happen when I start firefox in safe mode, which I've continued to do since the original bug report (except when testing after a firefox update has been applied; all testing has failed).

Thanks,

Kathleen

Flags: needinfo?(dklballen)

Understood. It might be related to something in your profile, especially if restarting in safe mode fixes it. Would you mind making a new temporary profile and starting Firefox normally with it, to see what happens? Info here: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

Hi again Drew,

I did as you suggested...here are the results (it did not go well)

Created a new profile called "test".
Launched the browser with the test profile from the about:profile window. (launch was in normal mode, not safe mode)
Logged into facebook (entered credentials manually)
The computer crashed immediately.
Experienced the restart loop again, then force-powered down the computer.
Disconnected all peripherals except the keyboard.
Restarted the Mac in Recovery mode and ran a disk repair. Once repair was complete, restarted the Mac via the Finder.
During startup I was prompted to recover the applications that were running at the time of the crash - I declined.
Mac booted normally.
Started firefox in safe mode....it launched using the new test profile.
Went back to about:profiles and saw my original default profile and the new test profile, switched the default to be the new test profile.
Quit firefox
Started firefox in normal mode. Confirmed it started with the new test profile.
Went to youtube and partially viewed a video.
Opened a new tab and went to the yahoo.com landing page.
The computer crashed immediately.
Experienced the restart loop again, then force-powered down the computer.
Attempted to restart the Mac in Recovery mode; restart failed the power-on self test. Rather than the normal start chime, the system repeated 3 beeps over and over. Also, the display was really jacked up. I took a video of this in case you wanted to see and hear it. My system has never done this before!
Force-powered down the system.
Powered the system back up.
The system booted normally.
Started firefox in safe mode, then went to about:profiles.
Attempted to launch a new browser window using the original profile, but the launch failed. Evidently during one of the sessions using the test profile, firefox auto-updated to 67.0.1. The original profile was still at 67.0 (updated on May 22). Firefox automatically created a new post-update profile and I started it in safe mode.
Went back to about:profiles and attempted to remove the test profile. Since it was the active profile for this session it could not be removed.
I set my original profile as the default and removed the newly auto-created profile (I chose the option to save files)
Quit firefox, then attempted to restart in safe mode.
The firefox restart failed with a message saying something about a version mis-match for the profiles, and to continue launching the application it would create a new profile. I selected continue and started in safe mode.
Went back to about:profiles and observed three profiles: the original profile, the test profile, and the newly-created profile. I removed the test profile (with the option to save files).
Went to the mozilla support site and downloaded 67.0 for mac from the ftp site.
Quit firefox.
Replaced 67.0.1 with 67.0 on my system.
Started firefox in safe mode using the original profile.
Removed the newly auto-created profile (with the option to save files).
Now I'm back to having only my original profile, running version 67.0, and only launching firefox in safe mode.

What else can we try?

Thanks,

Kathleen

Greetings - just checking in to see if there's been any progress with this bug report. As of July 14, Firefox on my system is at version 68.0 and the issue is still present, namely, if I start Firefox in normal mode my system crashes. Recovery requires starting my system from an emergency boot disk, resetting the PRAM, and on most (but not all) occasions doing an SMC reset as well. When I start Firefox in safe mode, there are no issues.

Any guidance, resolution, etc. you can provide is much appreciated.

Thanks,

Kathleen

Flags: needinfo?(dolske)

Greetings,

After six months of frustrating system crashes every time I started Firefox in normal mode, and it taking several hours to recover my system after each crash, I think I finally got to the bottom of this, aka, the root cause of the crashes. I'm still not entirely sure why the crashes only happened when Firefox is started - I did not have this experience with any other applications on my system.

In August I replaced my hard drive and the hard drive cable that connects it to the logic board, installed a fresh version of the OS, and restored all my data and applications. For Firefox, I also had to restore my bookmarks from a backup since those disappeared with the update to 69.0. After all that, the system crashes continued every time I started Firefox in normal mode. When I started Firefox in safe mode, the crashes did not occur.

After lots and lots of research I learned that the symptoms I was experiencing may be due to a failing GPU. I found instructions for reflowing the GPU and took care of that. Since completion of that little task, Firefox starts in normal mode without issue. Today I updated to 69.01 and started it back up in normal mode. Bookmarks are still present and Firefox doesn't crash my system.

We can now call this resolved.

Who'd a thunk, right?

Have a good day,

Kathleen

Status: UNCONFIRMED → RESOLVED
Closed: 4 months ago
Flags: needinfo?(dolske)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.