If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

smileworks.com - Some dentist information is not displayed

RESOLVED WORKSFORME

Status

Tech Evangelism Graveyard
English US
RESOLVED WORKSFORME
16 years ago
2 years ago

People

(Reporter: Matt Seitz, Assigned: Arun Ranganathan)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:1.1a+) Gecko/20020624
BuildID:    2002062408

This site allows searching for dentists by zip code.  When one clicks on one of
the dentists' names, one is supposed to see a page containing various
information about the dentist:  location, education, hours, etc.  A frame to the
left contains links to the various sections of the report.

In Mozilla, only the location is displayed, the other sections are not.  The
links to the other sections do not cause any change in the display.
  

Reproducible: Always
Steps to Reproduce:
1.  Go to www.smileworks.com
2.  Select "Find a dentist" in the upper left
3.  In the "Quick Search" section, enter the following values:
     Find a dentist near: Home
     Zip code: 95123
     I need:  a cleaning/checkup
4.  Click the "Quick" button
5.  Click on the first dentist's name

Actual Results:  A map of the dentist's location and her address were displayed.

Expected Results:  In addition to the map and address, the dentists education,
office hourse, treatments offered, etc., should also have been displayed.

The Javascript console reports:
Error: uncaught exception: [Exception... "Failure"  nsresult: "0x80004005
(NS_ERROR_FAILURE)"  location: "JS frame ::
http://dentists.smileworks.com/Template5/nav.asp?oID=12097 :: MM_findObj :: line
29"  data: no]
->JSEng?
Assignee: attinasi → rogerl
Component: Layout → JavaScript Engine
QA Contact: petersen → pschwartau
Summary: smileworks.com - Some dentist information is not displayed → smileworks.com - Some dentist information is not displayed

Comment 2

16 years ago
Confirming bug with Mozilla trunk 20020617xx on WinNT.
Matt: thank you for such a precise steps to reproduce this.

After doing the query and clicking on the link for the first dentist,
we get sent to http://dentists.smileworks.com/default.asp?oID=12097.
The problem occurs in this frame in the page:

http://dentists.smileworks.com/Template5/dentist_homepageDynamic.asp?oID=12097&C
oupon=0&Template=5


The problem is caused by an invalid HTML comment marker <!--->
To see this:

1. Save the HTML for the above frame locally
2. Add this tag to the HTML: <base href="http://www.dentists.smileworks.com">
3. Open the page in Mozilla
4. As Matt reports, there is only a map and an address visible
5. In IE6, there is more info: "Telephone", "Office Hours", "Overview", etc.
6. Now search for the invalid HTML comment marker <!---> and delete it.
7. Load the page in Mozilla: now all the info is visible



From http://www.w3.org/TR/html4/intro/sgmltut.html#h-3.2.4 :
--------------------------------------------------------------------------------
3.2.4 Comments
HTML comments have the following syntax:

<!-- this is a comment -->
<!-- and so is this one,
     which occupies more than one line -->

White space is not permitted between the markup declaration open delimiter("<!")
and the comment open delimiter ("--"), but is permitted between the comment
close delimiter ("--") and the markup declaration close delimiter (">").
A common error is to include a string of hyphens ("---") within a comment. 
Authors should avoid putting two or more adjacent hyphens inside comments.
--------------------------------------------------------------------------------


Reassigning to Tech Evangelism so the site can correct this mistake -
Assignee: rogerl → aruner
Component: JavaScript Engine → US Ecommerce
Product: Browser → Tech Evangelism
QA Contact: pschwartau → bclary
Version: other → unspecified

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
Created attachment 89031 [details]
With the invalid HTML comment removed, loads fine in Mozilla
404?
(Reporter)

Comment 5

15 years ago
The site has been restructured and no longer shows this problem.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 6

15 years ago
tech evang june 2003 reorg
Component: US Ecommerce → English US
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.