Perma tier2 clang tidy [taskcluster:error] Task timeout after 3600 seconds. Force killing container. readability-inconsistent-declaration-parameter-name has a definition with different parameter names

RESOLVED FIXED in Firefox 68

Status

defect
P5
normal
RESOLVED FIXED
2 months ago
a month ago

People

(Reporter: intermittent-bug-filer, Assigned: bastien)

Tracking

(Regression, {intermittent-failure, regression})

unspecified
mozilla68

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

2 months ago
treeherder

#[markdown(off)]
Filed by: apavel [at] mozilla.com

https://treeherder.mozilla.org/logviewer.html#?job_id=236297218&repo=mozilla-inbound

https://queue.taskcluster.net/v1/task/e6jZbb3LSJaVAbGoWmX3YQ/runs/0/artifacts/public/logs/live_backing.log

[task 2019-03-27T06:08:23.935Z] {
[task 2019-03-27T06:08:23.963Z] Warning: readability-braces-around-statements in /builds/worker/checkouts/gecko/js/src/irregexp/RegExpEngine.h: statement should be inside braces
[task 2019-03-27T06:08:23.963Z] /builds/worker/checkouts/gecko/js/src/irregexp/RegExpEngine.h:631:13: warning: statement should be inside braces [readability-braces-around-statements]
[task 2019-03-27T06:08:23.990Z] else
[task 2019-03-27T06:08:24.018Z] ^
[taskcluster:error] Task timeout after 3600 seconds. Force killing container.
[task 2019-03-27T06:08:24.045Z] {
[task 2019-03-27T06:08:24.074Z] Warning: readability-inconsistent-declaration-parameter-name in /builds/worker/checkouts/gecko/js/src/irregexp/RegExpEngine.h: function 'js::irregexp::BackReferenceNode::EatsAtLeast' has a definition with different parameter names
[task 2019-03-27T06:08:24.074Z] /builds/worker/checkouts/gecko/js/src/irregexp/RegExpEngine.h:895:17: warning: function 'js::irregexp::BackReferenceNode::EatsAtLeast' has a definition with different parameter names [readability-inconsistent-declaration-parameter-name]
[task 2019-03-27T06:08:24.102Z] virtual int EatsAtLeast(int still_to_find,
[taskcluster 2019-03-27 06:08:24.678Z] === Task Finished ===
[taskcluster 2019-03-27 06:08:24.679Z] Unsuccessful task run with exit code: -1 completed in 3626.128 seconds

This first occurred on this merge: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?changeset=528eacf3d3f64eb49bd53a7e16ca2c9103bdbad9

Mike can it be from Bug 1537641?

Flags: needinfo?(mh+mozilla)
Summary: Perma clang tidy [taskcluster:error] Task timeout after 3600 seconds. Force killing container. readability-inconsistent-declaration-parameter-name has a definition with different parameter names → Perma tier2 clang tidy [taskcluster:error] Task timeout after 3600 seconds. Force killing container. readability-inconsistent-declaration-parameter-name has a definition with different parameter names

Mike can it be from Bug 1537641?

No, it can't.

Flags: needinfo?(mh+mozilla)

Kim can you please assign someone to take a look at this?

Failure rate is high, however this was classified as bug 1411358.

Flags: needinfo?(kmoir)

In the particular one linked in comment 0, the problem is that hg status --rev 'max(ancestors(tip) and public())' -q --no-status returned nothing, making TRY_MODIFIED_FILES empty, which apparently triggered doing a full clang-tidy of the entire tree, and that doesn't finish within the allocated hour. The latter is probably related to the worker type used for those jobs being under-resourced for a full tree clang-tidy (that one used c3.xlarge, which have only 4 cores, which is not a lot to do a full tree analysis).

It's worth noting that one rerun/retrigger failed differently, with a non empty but very large TRY_MODIFIED_FILES, and failed with bug 1538770.

So probably the main problem here is TRY_MODIFIED_FILES being empty.

Blocks: 1535355
Flags: needinfo?(bastien)

hg status --rev 'max(ancestors(tip) and public())' -q --no-status seems to be designed for try, but doesn't quite fit the bill on other branches...

Assignee

Comment 5

2 months ago

This should be fixed by Bug 1538770. I would need Andrew's review on this bug.

Flags: needinfo?(bastien) → needinfo?(ahal)

I don't think get_outgoing_files is going to do the right thing on non-try.

Assignee

Comment 7

2 months ago

Maybe we can limit the clang tasks to try runs by using run_on_projects ?

Comment hidden (Intermittent Failures Robot)
Assignee

Comment 10

2 months ago

I made a patch that limit the generation of clang tools tasks to try & code-review.

I tested it by running ./mach taskgraph morphed with the parameters.yml from the failed task in top comment.
The clang tools task are not present anymore in the generated taskgraph with this patch, but are still there while running against a try push or code-review push

Flags: needinfo?(ahal)
Assignee: nobody → bastien

Comment 11

2 months ago
Pushed by babadie@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9b9c50876092
Run clang tools tasks only on try & code-review, r=glandium,sylvestre

Comment 13

2 months ago
Pushed by babadie@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/cb394c9bb56d
Run clang tools tasks only on try & code-review, r=glandium,sylvestre

Looks like a fix has landed for this so I will close the ni for me.

Flags: needinfo?(kmoir)

Comment 15

2 months ago
bugherder
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Assignee

Updated

2 months ago
Flags: needinfo?(bastien)
Comment hidden (Intermittent Failures Robot)
You need to log in before you can comment on or make changes to this bug.