Closed Bug 1540408 Opened 5 months ago Closed 4 months ago

Move nsSVGLength2 and nsSVGNumber2 into the mozilla namespace

Categories

(Core :: SVG, task, P3)

task

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox68 --- fixed

People

(Reporter: longsonr, Assigned: longsonr)

References

Details

Attachments

(3 files)

No description provided.
Assignee: nobody → longsonr

Now that the wrapper classes are called DOMSVGAnimated the internal representations can be named SVGAnimated.
Given that nsSVGLength2 and nsSVGNumber2 will require moving into the mozilla namespace they are not included here.

This would get you 99% of the patch.

hg mv -f dom/svg/SVGBoolean.cpp dom/svg/SVGAnimatedBoolean.cpp
hg mv -f dom/svg/SVGBoolean.h dom/svg/SVGAnimatedBoolean.h
hg mv -f dom/svg/SVGClass.cpp dom/svg/SVGAnimatedClass.cpp
hg mv -f dom/svg/SVGClass.h dom/svg/SVGAnimatedClass.h
hg mv -f dom/svg/SVGEnum.cpp dom/svg/SVGAnimatedEnumeration.cpp
hg mv -f dom/svg/SVGEnum.h dom/svg/SVGAnimatedEnumeration.h
hg mv -f dom/svg/SVGInteger.cpp dom/svg/SVGAnimatedInteger.cpp
hg mv -f dom/svg/SVGInteger.h dom/svg/SVGAnimatedInteger.h
hg mv -f dom/svg/SVGIntegerPair.cpp dom/svg/SVGAnimatedIntegerPair.cpp
hg mv -f dom/svg/SVGIntegerPair.h dom/svg/SVGAnimatedIntegerPair.h
hg mv -f dom/svg/SVGNumberPair.cpp dom/svg/SVGAnimatedNumberPair.cpp
hg mv -f dom/svg/SVGNumberPair.h dom/svg/SVGAnimatedNumberPair.h
hg mv -f dom/svg/SVGOrient.cpp dom/svg/SVGAnimatedOrient.cpp
hg mv -f dom/svg/SVGOrient.h dom/svg/SVGAnimatedOrient.h
hg mv -f dom/svg/SVGString.cpp dom/svg/SVGAnimatedString.cpp
hg mv -f dom/svg/SVGString.h dom/svg/SVGAnimatedString.h
hg mv -f dom/svg/SVGViewBox.cpp dom/svg/SVGAnimatedViewBox.cpp
hg mv -f dom/svg/SVGViewBox.h dom/svg/SVGAnimatedViewBox.h

cd /dom/svg (and then repeat the below dom/base and layout/svg perhaps although I made the changes there manually)

sed -i '.bak' 's/SVGString/SVGAnimatedString/g' *.cpp
sed -i '.bak' 's/SVGString/SVGAnimatedString/g' *.h
sed -i '.bak' 's/SVGClass/SVGAnimatedClass/g' *.h
sed -i '.bak' 's/SVGClass/SVGAnimatedClass/g' *.cpp
sed -i '.bak' 's/SVGBoolean/SVGAnimatedBoolean/g' *.cpp
sed -i '.bak' 's/SVGBoolean/SVGAnimatedBoolean/g' *.h
sed -i '.bak' 's/SVGEnum/SVGAnimatedEnumeration/g' *.h
sed -i '.bak' 's/SVGEnum/SVGAnimatedEnumeration/g' *.cpp
sed -i '.bak' 's/SVGInteger/SVGAnimatedInteger/g' *.cpp
sed -i '.bak' 's/SVGOrient/SVGAnimatedOrient/g' *.cpp
sed -i '.bak' 's/SVGOrient/SVGAnimatedOrient/g' *.h
sed -i '.bak' 's/SVGInteger/SVGAnimatedInteger/g' *.h
sed -i '.bak' 's/SVGOrient/SVGAnimatedOrient/g' *.h
sed -i '.bak' 's/SVGOrient/SVGAnimatedOrient/g' *.cpp
sed -i '.bak' 's/SVGInteger/SVGAnimatedInteger/g' *.cpp
sed -i '.bak' 's/SVGInteger/SVGAnimatedInteger/g' *.h
sed -i '.bak' 's/SVGEnum/SVGAnimatedEnumeration/g' *.cpp
sed -i '.bak' 's/SVGEnum/SVGAnimatedEnumeration/g' *.h
sed -i '.bak' 's/SVGBoolean/SVGAnimatedBoolean/g' *.h
sed -i '.bak' 's/SVGAnimatedStringList/SVGStringList/g' *.cpp
sed -i '.bak' 's/SVGAnimatedStringList/SVGStringList/g' *.h
sed -i '.bak' 's/SVGAnimatedOrientSMILType/SVGOrientSMILType/g' *.cpp
sed -i '.bak' 's/SVGAnimatedOrientSMILType/SVGOrientSMILType/g' *.h
sed -i '.bak' 's/SVGNumberPair/SVGAnimatedNumberPair/g' *.cpp
sed -i '.bak' 's/SVGNumberPair/SVGAnimatedNumberPair/g' *.h
sed -i '.bak' 's/SVGIntegerPair/SVGAnimatedIntegerPair/g' *.h
sed -i '.bak' 's/SVGIntegerPair/SVGAnimatedIntegerPair/g' *.cpp
sed -i '.bak' 's/SVGAnimatedIntegerPairSMILType/SVGIntegerPairSMILType/g' *.h
sed -i '.bak' 's/SVGAnimatedIntegerPairSMILType/SVGIntegerPairSMILType/g' *.cpp
sed -i '.bak' 's/SVGAnimatedNumberPairSMILType/SVGNumberPairSMILType/g' *.cpp
sed -i '.bak' 's/SVGAnimatedNumberPairSMILType/SVGNumberPairSMILType/g' *.h
sed -i '.bak' 's/SVGAnimatedStringInfo/SVGStringInfo/g' *.cpp
sed -i '.bak' 's/SVGAnimatedStringInfo/SVGStringInfo/g' *.h
sed -i '.bak' 's/SVGAnimatedEnumerationMapping/SVGEnumMapping/g' *.cpp
sed -i '.bak' 's/SVGAnimatedEnumerationMapping/SVGEnumMapping/g' *.h
sed -i '.bak' 's/SVGAnimatedEnumerationValue/SVGEnumValue/g' *.h
sed -i '.bak' 's/SVGAnimatedEnumerationValue/SVGEnumValue/g' *.cpp
sed -i '.bak' 's/SVGViewBox/SVGAnimatedViewBox/g' *.h
sed -i '.bak' 's/SVGViewBox/SVGAnimatedViewBox/g' *.cpp
sed -i '.bak' 's/SVGAnimatedViewBoxRect/SVGViewBoxRect/g' *.cpp
sed -i '.bak' 's/SVGAnimatedViewBoxRect/SVGViewBoxRect/g' *.h
sed -i '.bak' 's/SVGAnimatedViewBoxSMILType/SVGViewBoxSMILType/g' *.cpp
sed -i '.bak' 's/SVGAnimatedViewBoxSMILType/SVGViewBoxSMILType/g' *.h
sed -i '.bak' 's/SVGAnimatedViewBoxTearoffTable/SVGViewBoxTearoffTable/g' *.cpp
sed -i '.bak' 's/SVGAnimatedViewBoxTearoffTable/SVGViewBoxTearoffTable/g' *.cpp

Priority: -- → P3
Keywords: leave-open
Pushed by longsonr@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/1242bd22d38d
Part 1 - Move most internal attribute representation classes to be of the form SVGAnimated. r=dholbert

nsSVGLength2 becomes SVGAnimatedLength in the mozilla namespace, similar for nsSVGNumber2

The mechanical parts are

hg mv -f dom/svg/nsSVGLength2.cpp dom/svg/SVGAnimatedLength.cpp
hg mv -f dom/svg/nsSVGLength2.h dom/svg/SVGAnimateLength.h
hg mv -f dom/svg/nsSVGNumber2.cpp dom/svg/SVGAnimatedNumber.cpp
hg mv -f dom/svg/nsSVGNumber2.h dom/svg/SVGAnimatedNumber.h

cd dom/svg

sed -i '.bak' 's/nsSVGLength2/SVGAnimatedLength/g' *.h
sed -i '.bak' 's/nsSVGLength2/SVGAnimatedLength/g' *.cpp
sed -i '.bak' 's/nsSVGNumber2/SVGAnimatedNumber/g' *.cpp
sed -i '.bak' 's/nsSVGNumber2/SVGAnimatedNumber/g' *.h
rm *.bak

Now that SVGViewBox has become SVGAnimatedViewBox SVGViewBoxRect can be named SVGViewBox.

Pushed by longsonr@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/481a37f3892a
Part 2 - Move nsSVGLength2 and nsSVGNumber2 to the mozilla namespace renaming them to be SVGAnimatedLength and SVGAnimatedNumber. r=dholbert

Looks like the patch is missing a "d" in its rename there:

rename from dom/svg/nsSVGLength2.h
rename to dom/svg/SVGAnimateLength.h
                          ^^^ missing a "d"

(quoting https://hg.mozilla.org/integration/mozilla-inbound/rev/481a37f3892a )

Type: enhancement → task
Pushed by longsonr@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/ea65b4513b3b
Part 2 - Move nsSVGLength2 and nsSVGNumber2 to the mozilla namespace renaming them to be SVGAnimatedLength and SVGAnimatedNumber. r=dholbert
Pushed by longsonr@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0d9193a6224f
Part 3 - Rename SVGViewBoxRect to SVGViewBox r=dholbert
Flags: needinfo?(longsonr)
Keywords: leave-open
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Duplicate of this bug: 591808
You need to log in before you can comment on or make changes to this bug.