Perma TEST-UNEXPECTED-FAIL | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage js | Uncaught exception - report breakage button is visible - timed out after 50 tries when Gecko 68 merges to Beta on 2019-05-06

VERIFIED FIXED in Firefox 68

Status

()

defect
P1
normal
VERIFIED FIXED
3 months ago
2 months ago

People

(Reporter: aiakab, Assigned: johannh)

Tracking

68 Branch
Firefox 68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68+ verified)

Details

Attachments

(4 attachments)

Reporter

Description

3 months ago

[Tracking Requested - why for this release]:

Central as Beta:
https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=691ab1e0cca6088ae4dc591c5bfbd4091190deef&selectedJob=237135401

Failure log https://treeherder.mozilla.org/logviewer.html#?job_id=237135401&repo=try
https://treeherder.mozilla.org/logviewer.html#?job_id=237126525&repo=try

Part of that log

[task 2019-03-30T14:06:01.705Z] 14:06:01 INFO - TEST-START | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js
[task 2019-03-30T14:06:10.062Z] 14:06:10 INFO - TEST-INFO | started process screentopng
[task 2019-03-30T14:06:10.530Z] 14:06:10 INFO - TEST-INFO | screentopng: exit 0
[task 2019-03-30T14:06:10.531Z] 14:06:10 INFO - Buffered messages logged at 14:06:01
[task 2019-03-30T14:06:10.532Z] 14:06:10 INFO - Entering test bound setup
[task 2019-03-30T14:06:10.534Z] 14:06:10 INFO - Leaving test bound setup
[task 2019-03-30T14:06:10.535Z] 14:06:10 INFO - Entering test bound testReportBreakageVisibility
[task 2019-03-30T14:06:10.537Z] 14:06:10 INFO - Console message: [JavaScript Warning: "The resource at “http://trackertest.org/” was blocked because content blocking is enabled." {file: "http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html" line: 0}]
[task 2019-03-30T14:06:10.540Z] 14:06:10 INFO - Buffered messages logged at 14:06:02
[task 2019-03-30T14:06:10.541Z] 14:06:10 INFO - TEST-PASS | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | report breakage button has the correct visibility -
[task 2019-03-30T14:06:10.543Z] 14:06:10 INFO - Console message: [JavaScript Warning: "The resource at “http://trackertest.org/” was blocked because content blocking is enabled." {file: "http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html" line: 0}]
[task 2019-03-30T14:06:10.544Z] 14:06:10 INFO - TEST-PASS | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | report breakage button has the correct visibility -
[task 2019-03-30T14:06:10.544Z] 14:06:10 INFO - Console message: [JavaScript Warning: "The resource at “http://trackertest.org/” was blocked because content blocking is enabled." {file: "http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html" line: 0}]
[task 2019-03-30T14:06:10.546Z] 14:06:10 INFO - TEST-PASS | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | report breakage button has the correct visibility -
[task 2019-03-30T14:06:10.546Z] 14:06:10 INFO - Buffered messages logged at 14:06:03
[task 2019-03-30T14:06:10.546Z] 14:06:10 INFO - TEST-PASS | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | report breakage button has the correct visibility -
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - Console message: [JavaScript Error: "The character encoding of the plain text document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the file needs to be declared in the transfer protocol or file needs to use a byte order mark as an encoding signature." {file: "http://trackertest.org/browser/browser/base/content/test/trackingUI/cookieServer.sjs" line: 0}]
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “http://trackertest.org/browser/browser/base/content/test/trackingUI/cookieServer.sjs” was blocked because it came from a tracker and content blocking is enabled." {file: "http://not-tracking.example.com/browser/browser/base/content/test/trackingUI/cookiePage.html" line: 0}]
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “http://trackertest.org/browser/browser/base/content/test/trackingUI/cookieServer.sjs” was blocked because it came from a tracker and content blocking is enabled." {file: "http://not-tracking.example.com/browser/browser/base/content/test/trackingUI/cookiePage.html" line: 0}]
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - Console message: [JavaScript Warning: "Request to access cookie or storage on “http://trackertest.org/browser/browser/base/content/test/trackingUI/cookieServer.sjs” was blocked because it came from a tracker and content blocking is enabled." {file: "http://not-tracking.example.com/browser/browser/base/content/test/trackingUI/cookiePage.html" line: 0}]
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - TEST-PASS | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | report breakage button has the correct visibility -
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - Leaving test bound testReportBreakageVisibility
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - Entering test bound testReportBreakageCancel
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - Console message: [JavaScript Warning: "The resource at “http://trackertest.org/” was blocked because content blocking is enabled." {file: "http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html" line: 0}]
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - Buffered messages logged at 14:06:04
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - TEST-PASS | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | report breakage button is visible -
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - TEST-PASS | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | recorded telemetry for the click -
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - TEST-PASS | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | Report breakage view was shown -
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - TEST-PASS | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | Main view was shown -
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - Leaving test bound testReportBreakageCancel
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - Entering test bound testTP
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - Console message: [JavaScript Warning: "The resource at “http://trackertest.org/” was blocked because content blocking is enabled." {file: "http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html?a=b&1=abc&unicode=%F0%9F%A6%8A" line: 0}]
[task 2019-03-30T14:06:10.557Z] 14:06:10 INFO - Buffered messages finished
[task 2019-03-30T14:06:10.558Z] 14:06:10 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | Uncaught exception - report breakage button is visible - timed out after 50 tries.
[task 2019-03-30T14:06:10.558Z] 14:06:10 INFO - Leaving test bound testTP
[task 2019-03-30T14:06:10.560Z] 14:06:10 INFO - Entering test bound testFP
[task 2019-03-30T14:06:10.560Z] 14:06:10 INFO - Console message: [JavaScript Warning: "The resource at “http://trackertest.org/” was blocked because content blocking is enabled." {file: "http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html?a=b&1=abc&unicode=%F0%9F%A6%8A" line: 0}]
[task 2019-03-30T14:06:10.562Z] 14:06:10 INFO - Console message: [JavaScript Warning: "The resource at “https://fingerprinting.example.com/” was blocked because content blocking is enabled." {file: "http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html?a=b&1=abc&unicode=%F0%9F%A6%8A" line: 0}]
[task 2019-03-30T14:06:10.802Z] 14:06:10 INFO - TEST-PASS | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | Shows the correct URL in the report UI. -
[task 2019-03-30T14:06:10.820Z] 14:06:10 INFO - TEST-PASS | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | request was a post -
[task 2019-03-30T14:06:10.822Z] 14:06:10 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-03-30T14:06:10.823Z] 14:06:10 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | Should send the correct form data - ["","Content-Disposition: form-data; name="title"\r\n\r\ntracking.example.org\r\n","Content-Disposition: form-data; name="body"\r\n\r\nFull URL: http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html?\r\nuserAgent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:68.0) Gecko/20100101 Firefox/68.0\r\n\r\nPreferences\r\nprivacy.trackingprotection.enabled: true\r\nprivacy.trackingprotection.pbmode.enabled: true\r\nurlclassifier.trackingTable: mochitest2-track-simple\r\nnetwork.http.referer.defaultPolicy: 3\r\nnetwork.http.referer.defaultPolicy.pbmode: 2\r\nnetwork.cookie.cookieBehavior: 0\r\nnetwork.cookie.lifetimePolicy: 0\r\nprivacy.restrict3rdpartystorage.expiration: 2592000\r\nprivacy.trackingprotection.fingerprinting.enabled: true\r\nprivacy.trackingprotection.cryptomining.enabled: true\r\n\r\nComments\r\nThis is a comment\r\n","Content-Disposition: form-data; name="labels"\r\n\r\ntrackingprotection,fingerprinting\r\n",""] deepEqual ["","Content-Disposition: form-data; name="title"\r\n\r\ntracking.example.org\r\n","Content-Disposition: form-data; name="body"\r\n\r\nFull URL: http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html?\r\nuserAgent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:68.0) Gecko/20100101 Firefox/68.0\r\n\r\nPreferences\r\nprivacy.trackingprotection.enabled: true\r\nprivacy.trackingprotection.pbmode.enabled: true\r\nurlclassifier.trackingTable: mochitest2-track-simple\r\nnetwork.http.referer.defaultPolicy: 3\r\nnetwork.http.referer.defaultPolicy.pbmode: 2\r\nnetwork.cookie.cookieBehavior: 0\r\nnetwork.cookie.lifetimePolicy: 0\r\nprivacy.restrict3rdpartystorage.expiration: 2592000\r\nprivacy.trackingprotection.fingerprinting.enabled: true\r\nprivacy.trackingprotection.cryptomining.enabled: true\r\n\r\nComments\r\nThis is a comment\r\n","Content-Disposition: form-data; name="labels"\r\n\r\ncookierestrictions,fingerprinting\r\n",""] - JS frame :: chrome://mochitests/content/browser/browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js :: testReportBreakage/</< :: line 259
[task 2019-03-30T14:06:10.825Z] 14:06:10 INFO - Stack trace:
[task 2019-03-30T14:06:10.826Z] 14:06:10 INFO - chrome://mochitests/content/browser/browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js:testReportBreakage/</<:259
[task 2019-03-30T14:06:10.828Z] 14:06:10 INFO - resource://testing-common/httpd.js:handleResponse:2172
[task 2019-03-30T14:06:10.829Z] 14:06:10 INFO - resource://testing-common/httpd.js:process:1147
[task 2019-03-30T14:06:10.830Z] 14:06:10 INFO - resource://testing-common/httpd.js:_handleResponse:1555
[task 2019-03-30T14:06:10.832Z] 14:06:10 INFO - resource://testing-common/httpd.js:_processBody:1418
[task 2019-03-30T14:06:10.833Z] 14:06:10 INFO - resource://testing-common/httpd.js:onInputStreamReady:1306
[task 2019-03-30T14:06:10.978Z] 14:06:10 INFO - Leaving test bound testFP
[task 2019-03-30T14:06:10.980Z] 14:06:10 INFO - Entering test bound testCM
[task 2019-03-30T14:06:11.116Z] 14:06:11 INFO - Console message: [JavaScript Warning: "The resource at “http://trackertest.org/” was blocked because content blocking is enabled." {file: "http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html?a=b&1=abc&unicode=%F0%9F%A6%8A" line: 0}]
[task 2019-03-30T14:06:11.355Z] 14:06:11 INFO - Console message: [JavaScript Warning: "The resource at “http://cryptomining.example.com/” was blocked because content blocking is enabled." {file: "http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html?a=b&1=abc&unicode=%F0%9F%A6%8A" line: 0}]
[task 2019-03-30T14:06:11.696Z] 14:06:11 INFO - TEST-PASS | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | Shows the correct URL in the report UI. -
[task 2019-03-30T14:06:11.720Z] 14:06:11 INFO - TEST-PASS | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | request was a post -
[task 2019-03-30T14:06:11.730Z] 14:06:11 INFO - Not taking screenshot here: see the one that was previously logged
[task 2019-03-30T14:06:11.731Z] 14:06:11 INFO - TEST-UNEXPECTED-FAIL | browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js | Should send the correct form data - ["","Content-Disposition: form-data; name="title"\r\n\r\ntracking.example.org\r\n","Content-Disposition: form-data; name="body"\r\n\r\nFull URL: http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html?\r\nuserAgent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:68.0) Gecko/20100101 Firefox/68.0\r\n\r\nPreferences\r\nprivacy.trackingprotection.enabled: true\r\nprivacy.trackingprotection.pbmode.enabled: true\r\nurlclassifier.trackingTable: mochitest2-track-simple\r\nnetwork.http.referer.defaultPolicy: 3\r\nnetwork.http.referer.defaultPolicy.pbmode: 2\r\nnetwork.cookie.cookieBehavior: 0\r\nnetwork.cookie.lifetimePolicy: 0\r\nprivacy.restrict3rdpartystorage.expiration: 2592000\r\nprivacy.trackingprotection.fingerprinting.enabled: false\r\nprivacy.trackingprotection.cryptomining.enabled: true\r\n\r\nComments\r\nThis is a comment\r\n","Content-Disposition: form-data; name="labels"\r\n\r\ntrackingprotection,cryptomining\r\n",""] deepEqual ["","Content-Disposition: form-data; name="title"\r\n\r\ntracking.example.org\r\n","Content-Disposition: form-data; name="body"\r\n\r\nFull URL: http://tracking.example.org/browser/browser/base/content/test/trackingUI/trackingPage.html?\r\nuserAgent: Mozilla/5.0 (X11; Linux i686 on x86_64; rv:68.0) Gecko/20100101 Firefox/68.0\r\n\r\nPreferences\r\nprivacy.trackingprotection.enabled: true\r\nprivacy.trackingprotection.pbmode.enabled: true\r\nurlclassifier.trackingTable: mochitest2-track-simple\r\nnetwork.http.referer.defaultPolicy: 3\r\nnetwork.http.referer.defaultPolicy.pbmode: 2\r\nnetwork.cookie.cookieBehavior: 0\r\nnetwork.cookie.lifetimePolicy: 0\r\nprivacy.restrict3rdpartystorage.expiration: 2592000\r\nprivacy.trackingprotection.fingerprinting.enabled: false\r\nprivacy.trackingprotection.cryptomining.enabled: true\r\n\r\nComments\r\nThis is a comment\r\n","Content-Disposition: form-data; name="labels"\r\n\r\ncookierestrictions,cryptomining\r\n",""] - JS frame :: chrome://mochitests/content/browser/browser/base/content/test/trackingUI/browser_trackingUI_report_breakage.js :: testReportBreakage/</< :: line 259

Reporter

Comment 1

3 months ago

It seems that these failures are caused by https://bugzilla.mozilla.org/show_bug.cgi?id=1538684

Johann can you please take a look?

Flags: needinfo?(jhofmann)

[Tracking Requested - why for this release]:

Comment hidden (Intermittent Failures Robot)
Comment hidden (Intermittent Failures Robot)
Attachment #9056875 - Attachment description: Bug 1540416 - set up Report Breakage preference before page load because that's when it gets unhidden → Bug 1540416 - set up Report Breakage preference before page load because that's when it gets unhidden. r=johannh
Attachment #9056877 - Attachment description: Bug 1540416 - Reflect that cryptomining or fingerprinting blocking prefs don't enable cookie restrictions → Bug 1540416 - Reflect that cryptomining or fingerprinting blocking prefs don't enable cookie restrictions. r=johannh
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Flags: needinfo?(jhofmann)
Priority: -- → P1

Comment 11

2 months ago
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2c2b6f2cb293
Move toggling the report breakage button out of onContentBlockingEvent. r=ewright
https://hg.mozilla.org/integration/autoland/rev/5e0cf8b42fcf
Correctly test cookie restrictions in browser_trackingUI_report_breakage. r=ewright

Comment 12

2 months ago
bugherder
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 68
Regressions: 1544595
You need to log in before you can comment on or make changes to this bug.