Middle mouse button acts as BACK

RESOLVED WORKSFORME

Status

SeaMonkey
Tabbed Browser
RESOLVED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Eric, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1a) Gecko/20020611
BuildID:    2002061104

although i have the middle mouse button (scroll wheel) set to open a link in a
new tab, it only works as the BACK command in the browser. it used to work, and
control clicking a link still works correctly. It does this everywhere on screen.

Reproducible: Always
Steps to Reproduce:
1.Middle-click a link
2.
3.

Actual Results:  Browser went back one page

Expected Results:  Opened the link in a new tab, as per the settings in prefrences.

i recentlly re-installed windows (without re-format). Some system settings were
changed.
QA Contact: sairuh → pmac
Reporter: Can you reproduce this bug with a recent build of Mozilla (for
example, 1.4 RC1)? If so, then please comment again with details. If not, then
please resolve this bug as WORKSFORME. Thanks.

Comment 2

15 years ago
I've also got this very annoying bug with 1.4 RC2 on Windows ME. For a long time
I blamed Logitech as it happened when I installed the newer 9.76 drivers and
does not happen with the older drivers. However, after unintalling all the
Logitech drivers, middle mouse (or mouse3) still acts as a "back button" in the
browser. It seems as if something in the older Logitech drivers blocks this
behaviour, but the newer drivers (with many bugfixes) allow it to go through.

This is exceedingly annoying as it clashes with the "middlemouse opens tabs"
functionality. 

Comment 3

15 years ago
I've just checked with 1.4 RC3 and the problem is still there, even with no
Logitech drivers installed (just the default Microsoft ones running). 

Comment 4

15 years ago
I have tried creating news user profile in both Mozilla and under windows, and
the problem still happens.

Would it be useful for me to supply a dependency walker profile on this problem?

Comment 5

15 years ago
no respone-->resolving wfm
john_pub_mail1@blueyonder.co.uk: for your issue please file a new bug
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.