pab.na2 address book import nonfunctional in Mozilla 1.0

VERIFIED DUPLICATE of bug 35509

Status

VERIFIED DUPLICATE of bug 35509
17 years ago
14 years ago

People

(Reporter: nbi, Assigned: racham)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
I was not able to import an address book from Netscape 4.79 (pab.na2) directly
using 'import'. An attempt to do so results in a greyed-out window which
eventually has to be cancelled since nothing is ever imported.

The workaround is to export an LDIF version of the address book from the old
browser and then to 'import' this LDIF into Mozilla. This shouldn't be
neccessary, apparently there's a bug in how the pab.na2 is read by Mozilla.

Comment 1

17 years ago
==> address book
Assignee: Matti99 → racham
Component: Browser-General → Address Book
Product: Browser → MailNews
QA Contact: imajes-qa → nbaca
-> invalid

Please always include your build ID

There is no import function in Mozilla for Netscape 4.7x Mails.
You can import this adressbook if you use Netscape6.x/7.x.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

17 years ago
Your answer is contradicted by the help information. The verbatim help text is
below. Which is it, is the help incorrect or the import non-functional?

Importing Address Books

If you have a Mozilla address book from another user profile or computer, or if
you have an address book from a previous version of Mozilla or another mail
program, you can import its entries into the Address Book window as a new
address book. You can import address book files that are in these formats:
Communicator 4.x (pab.na2), Mozilla (.ldif), tab-delimited (.tab),
comma-separated (.csv), or text (.txt) formats. When you import an address book,
Mail & Newsgroups creates a new address book with the imported entries.

You can also import mail messages and settings from Netscape Communicator,
Eudora, Outlook, and Outlook Express.

To import an address book into Mozilla, begin from the Mail window:

   1. Open the File menu, and choose Import. You see the Mozilla Mail Import Wizard.
   2. Follow the instructions to import address books.

      Tip: Communicator address book files (pab.na2) are stored in your user
profile directory (for example, C:\Program Files\Mozilla\Users, where \Users
contains the user profiles directories).
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
This help is wrong.
They copied it from the Netscape help.

found the dupe...


*** This bug has been marked as a duplicate of 35509 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
Verified Duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.