Closed Bug 1540521 Opened 2 years ago Closed 2 years ago

Crash in [@ mozilla::layers::CompositorBridgeParent::RecvBeginRecording]

Categories

(Core :: Graphics: Layers, defect, P2)

defect

Tracking

()

RESOLVED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- fixed

People

(Reporter: calixte, Assigned: barret)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-3bbcea78-a2cb-4b4d-84dd-ffe4b0190331.

Top 10 frames of crashing thread:

0 xul.dll class mozilla::ipc::IPCResult mozilla::layers::CompositorBridgeParent::RecvBeginRecording gfx/layers/ipc/CompositorBridgeParent.cpp:2606
1 xul.dll mozilla::layers::PCompositorBridgeParent::OnMessageReceived ipc/ipdl/PCompositorBridgeParent.cpp:1353
2 xul.dll void mozilla::ipc::MessageChannel::DispatchMessage ipc/glue/MessageChannel.cpp:2078
3 xul.dll nsresult mozilla::ipc::MessageChannel::MessageTask::Run ipc/glue/MessageChannel.cpp:1968
4 xul.dll bool MessageLoop::DeferOrRunPendingTask ipc/chromium/src/base/message_loop.cc:450
5 xul.dll MessageLoop::DoWork ipc/chromium/src/base/message_loop.cc:523
6 xul.dll void base::MessagePumpForUI::DoRunLoop ipc/chromium/src/base/message_pump_win.cc:203
7 xul.dll base::MessagePumpWin::Run ipc/chromium/src/base/message_pump_win.h:79
8 xul.dll MessageLoop::RunHandler ipc/chromium/src/base/message_loop.cc:308
9 xul.dll base::Thread::ThreadMain ipc/chromium/src/base/thread.cc:192

There is 1 crash in nightly 68 with buildid 20190330093331. In analyzing the backtrace, the regression may have been introduced by patch [1] to fix bug 1536174.

[1] https://hg.mozilla.org/mozilla-central/rev?node=8186704e6d03

Flags: needinfo?(bas)
Priority: -- → P2

Still a fairly low volume crash on 68 nightly. Changing platform to all since I saw one Mac crash. Also added a single installation crash signature.

Crash Signature: [@ mozilla::layers::CompositorBridgeParent::RecvBeginRecording] → [@ mozilla::layers::CompositorBridgeParent::RecvBeginRecording] [@ mozilla::layers::CompositorBridgeParent::RecvEndRecording]
OS: Windows 10 → All
Hardware: Unspecified → All

This is due to attempting to take a composition recording with WebRender enabled, which isn't currently supported. I can reproduce locally and have a fix.

Assignee: nobody → brennie
Status: NEW → ASSIGNED
Flags: needinfo?(bas)

The CompositorBridgeParent won't have a LayerManager when running with
WebRender, so attempting to take a composition recording will cause a crash. We
now silently fail to take the recording since recording is (a) Nightly only and
(b) not supported on Web Render.

Pushed by brennie@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/beb59fe4dd80
Only attempt to set the CompositionRecorder on the LayerManager when there is one r=mstange
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.