Perma /browser_webconsole_warning_groups.js | Test timed out when Gecko 68 merges to Beta on 2019-05-06

VERIFIED FIXED in Firefox 68

Status

()

defect
VERIFIED FIXED
3 months ago
2 months ago

People

(Reporter: RaulGurzau, Assigned: nchevobbe)

Tracking

({regression})

unspecified
mozilla68
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr60 unaffected, firefox66 unaffected, firefox67 unaffected, firefox68+ verified)

Details

Attachments

(2 attachments)

Reporter

Description

3 months ago

[Tracking Requested - why for this release]:

Central as Beta simulation: https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&revision=7d697d08b5569edf179d3f1d700a5506ace0cd01&selectedJob=237220974

Log link:https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=237220974&repo=try&lineNumber=3544

Log snippet:

15:18:44 INFO - TEST-START | devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups.js
15:20:14 INFO - TEST-INFO | started process screenshot
15:20:15 INFO - TEST-INFO | screenshot: exit 0
15:20:15 INFO - Buffered messages logged at 15:18:44
15:20:15 INFO - Entering test bound testContentBlockingMessage
15:20:15 INFO - Buffered messages logged at 15:18:45
15:20:15 INFO - Adding a new tab with URL: http://example.com/browser/devtools/client/webconsole/test/mochitest/test-warning-groups.html
15:20:15 INFO - Tab added and finished loading
15:20:15 INFO - Opening the toolbox
15:20:15 INFO - Toolbox opened and focused
15:20:15 INFO - Log a tracking protection message to check a single message isn't grouped
15:20:15 INFO - Buffered messages logged at 15:19:29
15:20:15 INFO - Longer timeout required, waiting longer... Remaining timeouts: 1
15:20:15 INFO - Buffered messages finished
15:20:15 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups.js | Test timed out -
15:20:15 INFO - GECKO(3660) | console.warn: "Error while detaching the thread front: 'detach' request packet to 'server1.conn330.child1/context18' can't be sent as the connection is closed."
15:20:15 INFO - Removing tab.
15:20:15 INFO - Waiting for event: 'TabClose' on [object XULElement].
15:20:15 INFO - Got event: 'TabClose' on [object XULElement].
15:20:15 INFO - Tab removed and finished closing
15:20:15 INFO - GECKO(3660) | MEMORY STAT | vsize 1544MB | vsizeMaxContiguous 90MB | residentFast 555MB | heapAllocated 116MB
15:20:15 INFO - TEST-OK | devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups.js | took 90419ms
15:20:15 INFO - checking window state

Flags: needinfo?(nchevobbe)
Assignee

Comment 2

3 months ago

From the screenshots, it looks like we don't even get the first content blocking message.
Is devtools/client/webconsole/test/mochitest/browser_webconsole_warning_group_content_blocking.js fine? Because it's more or less the same logic.

browser_webconsole_warning_group_content_blocking.js passes. It runs directly before that.

Assignee

Comment 4

3 months ago

How can I reproduce the failure locally? apply the patch on beta branch is enough?

Flags: needinfo?(nchevobbe) → needinfo?(aryx.bugmail)

It's the code on central modified to behave like beta. Please use the mozilla-central code and run this:

Modify the code to behave like beta but don't push to the Try server: https://wiki.mozilla.org/Sheriffing/How_To/Beta_simulations#TRUNK_AS_EARLY_BETA

./mach try release -v 68.0b1 --tasks release-sim --migration central-to-beta --no-push
Then you can apply your changes (there are some backup files from the previous command in the source directory, but those shouldn't matter).
You can try an artifact build, using the same base revision as the beta simulations yesterday might speed this up: https://hg.mozilla.org/mozilla-central/rev/c06dfc552c647a6ce96f35cd84c32a589dc85608

Flags: needinfo?(aryx.bugmail)

Comment 7

3 months ago
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/07800c801230
Fix browser_webconsole_warning_groups.js beta permafail. r=aryx.
Reporter

Comment 8

3 months ago
bugherder
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Assignee: nobody → nchevobbe
Assignee

Comment 11

2 months ago

is this still happening?

Flags: needinfo?(nchevobbe)

This works on Nightly and early beta because

pref("network.cookie.cookieBehavior", 4 /* BEHAVIOR_REJECT_TRACKER */);

https://searchfox.org/mozilla-central/rev/6dab6dad9cc852011a14275a8b2c2c03ed7600a7/browser/app/profile/firefox.js#1539

The image gets loaded.

pushPref("privacy.trackingprotection.enabled", true);

doesn't have an affect on this, the test also passes with it set to true.

To get it working on late beta, this is needed:

[await ]pushPref("browser.contentblocking.features.standard", "-tp,tpPrivate,cookieBehavior4,-cm,-fp");

It can also be fixed by switching the TLDs of the test uri (example.com => example.org) and tracker uri (tracking.example.org => tracking.example.com)

https://searchfox.org/mozilla-central/rev/6dab6dad9cc852011a14275a8b2c2c03ed7600a7/toolkit/components/url-classifier/tests/UrlClassifierTestUtils.jsm#21

Nicholas, can you decide on the blocking mechanism, please?

Flags: needinfo?(nchevobbe)

There is also https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=e390ac673a3cff99a9396bba9248c70450607600&selectedJob=240158887 on the most recent beta-sim

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=240158887&repo=try&lineNumber=12276

[task 2019-04-13T14:10:45.212Z] 14:10:45 INFO - TEST-START | devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups_outside_console_group.js
[task 2019-04-13T14:12:15.240Z] 14:12:15 INFO - TEST-INFO | started process screentopng
[task 2019-04-13T14:12:15.535Z] 14:12:15 INFO - TEST-INFO | screentopng: exit 0
[task 2019-04-13T14:12:15.536Z] 14:12:15 INFO - Buffered messages logged at 14:10:45
[task 2019-04-13T14:12:15.537Z] 14:12:15 INFO - Entering test bound testContentBlockingMessage
[task 2019-04-13T14:12:15.537Z] 14:12:15 INFO - Adding a new tab with URL: http://example.com/browser/devtools/client/webconsole/test/mochitest/test-warning-groups.html
[task 2019-04-13T14:12:15.538Z] 14:12:15 INFO - Tab added and finished loading
[task 2019-04-13T14:12:15.539Z] 14:12:15 INFO - Opening the toolbox
[task 2019-04-13T14:12:15.539Z] 14:12:15 INFO - Toolbox opened and focused
[task 2019-04-13T14:12:15.540Z] 14:12:15 INFO - Log a console.group
[task 2019-04-13T14:12:15.541Z] 14:12:15 INFO - Matched a message with text: "myGroup", all messages received.
[task 2019-04-13T14:12:15.542Z] 14:12:15 INFO - Matched a message with text: "log in group", all messages received.
[task 2019-04-13T14:12:15.545Z] 14:12:15 INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups_outside_console_group.js | Got the expected number of messages -
[task 2019-04-13T14:12:15.546Z] 14:12:15 INFO - Checking "▼ myGroup"
[task 2019-04-13T14:12:15.548Z] 14:12:15 INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups_outside_console_group.js | There's an expanded arrow -
[task 2019-04-13T14:12:15.551Z] 14:12:15 INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups_outside_console_group.js | Message includes the expected "myGroup" content - "myGroup" -
[task 2019-04-13T14:12:15.552Z] 14:12:15 INFO - Checking "| log in group"
[task 2019-04-13T14:12:15.553Z] 14:12:15 INFO - TEST-PASS | devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups_outside_console_group.js | Message includes the expected "log in group" content - "log in group" -
[task 2019-04-13T14:12:15.554Z] 14:12:15 INFO - Log a tracking protection message to check a single message isn't grouped
[task 2019-04-13T14:12:15.555Z] 14:12:15 INFO - Buffered messages logged at 14:11:30
[task 2019-04-13T14:12:15.557Z] 14:12:15 INFO - Longer timeout required, waiting longer... Remaining timeouts: 1
[task 2019-04-13T14:12:15.558Z] 14:12:15 INFO - Buffered messages finished
[task 2019-04-13T14:12:15.559Z] 14:12:15 INFO - TEST-UNEXPECTED-FAIL | devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups_outside_console_group.js | Test timed out -
[task 2019-04-13T14:12:15.560Z] 14:12:15 INFO - GECKO(2721) | console.warn: "Error while detaching the thread front: 'detach' request packet to 'server1.conn333.child1/context18' can't be sent as the connection is closed."
[task 2019-04-13T14:12:15.718Z] 14:12:15 INFO - Removing tab.
[task 2019-04-13T14:12:15.719Z] 14:12:15 INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2019-04-13T14:12:15.727Z] 14:12:15 INFO - Got event: 'TabClose' on [object XULElement].
[task 2019-04-13T14:12:15.737Z] 14:12:15 INFO - Tab removed and finished closing
[task 2019-04-13T14:12:15.798Z] 14:12:15 INFO - GECKO(2721) | MEMORY STAT | vsize 1750MB | residentFast 754MB | heapAllocated 121MB
[task 2019-04-13T14:12:15.798Z] 14:12:15 INFO - TEST-OK | devtools/client/webconsole/test/mochitest/browser_webconsole_warning_groups_outside_console_group.js | took 90587ms

Same changes needed to fix browser_webconsole_warning_groups_outside_console_group.js (added to the "workaround" patch).

Comment hidden (Intermittent Failures Robot)
Flags: needinfo?(aryx.bugmail)

No, Nicolas shall decide show the test shall actually work (see comment 14).

Flags: needinfo?(aryx.bugmail)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Target Milestone: mozilla68 → ---
Assignee

Comment 20

2 months ago

(In reply to Sebastian Hengst [:aryx] (needinfo on intermittent or backout) from comment #19)

No, Nicolas shall decide show the test shall actually work (see comment 14).

This is fine to me. I added the pref in both test and they pass with --verify, so I'm happy with that.
Should I push a patch to phabricator or do you have something ready Sebastian?

Flags: needinfo?(nchevobbe) → needinfo?(aryx.bugmail)
Attachment #9058069 - Attachment description: Bug 1540546 - [workaround] fix webconsole test about grouping of content blocking messages. DON'T CHECK-IN, DON'T REVIEW → Bug 1540546 - fix webconsole tests about grouping of content blocking messages. r=nchevobbe

Comment 21

2 months ago
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/0f66c499026a
fix webconsole tests about grouping of content blocking messages. r=nchevobbe
Assignee

Comment 22

2 months ago

(clearing ni?)

Flags: needinfo?(aryx.bugmail)

Comment 23

2 months ago
bugherder
Status: REOPENED → RESOLVED
Closed: 3 months ago2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
You need to log in before you can comment on or make changes to this bug.