Closed Bug 1540587 Opened 3 years ago Closed 3 years ago

After a playback of AV1 video, RDD isn't used for video in tabs in other content processes

Categories

(Core :: Audio/Video: Playback, defect, P1)

defect

Tracking

()

VERIFIED FIXED
mozilla68
Tracking Status
firefox-esr60 --- unaffected
firefox66 --- unaffected
firefox67 --- unaffected
firefox68 --- verified

People

(Reporter: tgnff242, Assigned: mjf)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

  1. Open Firefox with a clean profile.
  2. Play an AV1 video in a tab.
  3. Open a second tab and ensure that it's in a different content process, then load to play the same or another video.
  4. Observe the CPU usage and the number of threads of RDD through a system monitor at steps (2) and (3).

Actual results:

At step (2), normally, there's some CPU usage for the RDD process, and 11 threads are counted. At step (3) there's no CPU usage at all, and 6 threads are counted.

Expected results:

Similar results at both steps.

It's a regression. Bisection points to Bug 1539030.

23:09.01 INFO: No more inbound revisions, bisection finished.
23:09.01 INFO: Last good revision: 105411e3cf06b2fca98d4e0507efb80875103228
23:09.01 INFO: First bad revision: a0bed49e8b107a7dc6f1f74dcddd5353ae177130
23:09.01 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=105411e3cf06b2fca98d4e0507efb80875103228&tochange=a0bed49e8b107a7dc6f1f74dcddd5353ae177130

Blocks: 1539030
Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(mfroman)
Keywords: regression

I'll take a look.

Flags: needinfo?(mfroman)

Yep - I missed that. Thank you for catching this!

Assignee: nobody → mfroman
Status: UNCONFIRMED → NEW
Ever confirmed: true

The patch for 1539030 didn't do what I'd hoped, and caused issues
with decoding av1 on additional tabs so I'm removing the "fix".

Rank: 9
Priority: -- → P1
Pushed by mfroman@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a8474c6fd9a3
remove patch for 1539030 to fix decoding on additional tabs. r=jya
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla68
Flags: qe-verify+

Hello!
I successfully reproduced the issue using Firefox 68.0a1 (20190331215222) using Ubuntu 18.0.4 when playing an AV1 video just having 13 threads for RDD process after Step2 and no CPU usage at all and 6 threads counted after Step3 from comment 0.

Can I get a confirmation that the present behavior in the following video is the expected one? Made a screen recording with the results using Firefox 68.0 (20190705220548): link.

Thank you!

Flags: needinfo?(mfroman)

:atrif, would you mind describing the current behavior you're asking to verify in the video? Thanks!

Flags: needinfo?(mfroman) → needinfo?(alexandru.trif)

Yes ofc, sorry for not doing that in the first place. Using the same STR as in comment 0 to compare the results:

(In reply to tgn-ff from comment #0)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0

Steps to reproduce:

  1. Open Firefox with a clean profile.
  2. Play an AV1 video in a tab.
  3. Open a second tab and ensure that it's in a different content process, then load to play the same or another video.
  4. Observe the CPU usage and the number of threads of RDD through a system monitor at steps (2) and (3).

Actual results:

At step (2), normally, there's some CPU usage for the RDD process, and 11 threads are counted. At step (3) there's no CPU usage at all, and 6 threads are counted.

Expected results:

Similar results at both steps.

After step 2 the thread count for the RDD process is set to 11 and uses some CPU.

After step 3 the thread count remains the same and the RDD process is still using almost the same amount of CPU.

Changing video tabs between them increase the thread count and CPU usage but after waiting for a while it comes back to normal.
If there more information needed please let me know. Thank you!

Flags: needinfo?(alexandru.trif)

That all sounds like I'd expect.

Thank you!
As per comment 8 and comment 9, the issue is verified fixed using Firefox 68.0 (20190705220548) on Ubuntu 18.04.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.