Autofill dialogs should be Yes/No, not Ok/Cancel

VERIFIED DUPLICATE of bug 13032

Status

()

defect
P3
minor
VERIFIED DUPLICATE of bug 13032
20 years ago
11 years ago

People

(Reporter: mmastrac, Assigned: morse)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

20 years ago
The dialogs that pop up asking you to autofill a username/password field should
have Yes/No options, rather than Ok/Cancel.

Reproduction steps:

1.  Surf to a page that requires a login
2.  Enter your name/password
3.  It will ask "save your password?  Ok/Cancel"
4.  Click Cancel for "no"
5.  It will then ask "remember this decision? Ok/Cancel"
6.  Click Cancel for "no"

Expected behaviour:

For steps 3 and 5 it should say "Yes/No"

Any question which can be answered with a Yes or a No should have those two
options as buttons in the dialog, rather than Ok/Cancel.
Assignee

Updated

20 years ago
Status: NEW → RESOLVED
Last Resolved: 20 years ago
Resolution: --- → DUPLICATE
Assignee

Comment 1

20 years ago
You're absolutely right.  It's already coded to bring up a yes/no dialog.  But
the yes/no dialogs are not working so temorarily we are using the ok/cancel
dialogs.  See bug 13032 for the details.

*** This bug has been marked as a duplicate of 13032 ***

Updated

20 years ago
Status: RESOLVED → VERIFIED

Comment 2

20 years ago
[bugday] they're definately the same bug. marking verified.

Comment 4

19 years ago
[richb - 21st March 2000 - 13:20]
The compiler guy came back with another suggestion:

    "The following code won't work to turn off tail-call optimization.
     But it gave me another idea, below.
 
     > #define STUB_ENTRY(n) \
     > nsresult nsXPTCStubBase::Stub##n() \
     > { \
     >     int retval = SharedStub(n);     \
     >     return retval;                  \
     > }
 
    "You could try the following, with the original verion of SharedStub()
     plus the fix for the save instr.
 
     #define STUB_ENTRY(n) \
     nsresult nsXPTCStubBase::Stub##n() \
     { \
         int dummy; /* defeat tail-call optimization */ \
         return SharedStub(n, &dummy); \
     }   
 
     That should defeat the tail call optimization,
     without much extra code (probably one instruction)." 
 
His change (plus the fix for the extern declaration for SharedStub in
xptcstubs_sparc_solaris.cpp, which now reads: 
 
extern "C" int SharedStub(int, int*); 
 
compiles, builds and runs (with the Sun CC 5.0 compiler). I tried -O2, -g
and -O4. It also compiles, builds and successfully runs it with gcc with -O2. 
These are the only variants I've tried. I've no reason to believe the other 
optimisation levels won't be successful as well. 
 
The sets of diffs for this change are at:
 
http://bugzilla.mozilla.org/showattachment.cgi?attach_id=6752 
 
This affects: 
 
xptcinvoke_asm_sparc_solaris_SUNW.s 
xptcstubs_asm_sparc_solaris.s 
xptcstubs_sparc_solaris.cpp 
 
This fix also includes the adjustment to the save instruction for the 
XPTC_InvokeByIndex routine in xptcinvoke_asm_sparc_solaris_SUNW.s. 
 
This would appear to be an acceptable solution.
 
Anybody care to comment on this?  You are all awfully quiet out there.

Also, I'm new to the Mozilla Way, so what's the next step I need to do in order
to get these changes officially checked back? Do I need a reviewer?

Thanks.
Assignee

Comment 5

19 years ago
Huh???  I think you posted the above comments to the wrong bug report.  At least 
I hope so because I don't see what this report has to do with "tail call 
optimiziation", whatever that is.

Updated

11 years ago
Component: Form Manager → Form Manager
Product: Core → Toolkit
QA Contact: paulmac → form.manager
You need to log in before you can comment on or make changes to this bug.